2006 wrangler not getting fuel - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-09-2011, 07:35 AM   #1
Newb
 
Join Date: Mar 2011
Posts: 3
2006 wrangler not getting fuel

Both ASD and Fuel relays are working. Changed the CPS. Fuel pump not working. I checked for codes and none showing. Tried checking voltage to the pump but not sure of the color of the wires. There were 2 blue, 1 orange and 1 black. When I added fuel to the throttle body, she will start. NEED help.

hwalzer is offline   Quote Quick Reply
Old 03-09-2011, 09:38 AM   #2
Jeeper
 
jgorm's Avatar
 
Join Date: May 2010
Location: San Diego
Posts: 1,918
sounds like a bad fuel pump. Maybe do more research and find the wire colors to test for voltage before you replace it.

__________________
my 06 LJ rubicon
2.5" SL, 1" BL, DIY highline, 35s with double beadlocks.
jgorm is offline   Quote Quick Reply
Old 03-09-2011, 09:49 AM   #3
Jeeper
 
just4fun's Avatar
 
Join Date: Feb 2011
Posts: 8,424
Have somebody hit the gas tank with a hammer while you are cranking the engine to start. If it starts it the fuel pump that's bad.
just4fun is offline   Quote Quick Reply
Old 03-09-2011, 01:36 PM   #4
Newb
 
Join Date: Mar 2011
Posts: 3
will do. just about tried everything else.
hwalzer is offline   Quote Quick Reply
Old 03-09-2011, 02:39 PM   #5
Jeeper
 
Join Date: Aug 2008
Posts: 2,473
Do you hear the pump running for the initial 5 seconds?

No? I think the orange wire is the hot to the pump, not sure.
One of those wires should have 12 volts on it for the first 5 seconds after the key is turned to start, then it goes away. Test one at a time. If yes, voltage is there for the 5s, replace pump.

if you can hear it running for the 5s, then look for a restriction somewhere - crushed line etc.
__________________
It's no wonder the country is falling apart - stupidity abounds!
rrich is offline   Quote Quick Reply
Old 03-09-2011, 02:44 PM   #6
Jeeper
 
zeus8582's Avatar
 
Join Date: Jan 2011
Location: Tennessee
Posts: 195
I like the previous method...... Have somebody smack it with a hammer.....
Works every time.......
__________________
"Sometimes the road less traveled isn't a road"
/l ,[____],
l---L -OlllllllO-
()_)-()_)-o-)_)
Sent from my Iphone 5 using WF Access
zeus8582 is offline   Quote Quick Reply
Old 03-10-2011, 06:23 AM   #7
Newb
 
Join Date: Mar 2011
Posts: 3
I am getting voltage to the pump. Hammer smack no workie. Will change the pump. Kinda odd that the pump would go out so soon. Only 36k mls on vehicle.
hwalzer is offline   Quote Quick Reply
Old 03-10-2011, 09:05 AM   #8
Jeeper
 
Join Date: Aug 2008
Posts: 2,473
Check to make sure the tank has a good ground - tank to frame. I think the black wire is the ground wire.

__________________
It's no wonder the country is falling apart - stupidity abounds!
rrich is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Magnaflow Downpipe 2006 Wrangler Texasdeere TJ General Discussion Forum 6 02-27-2013 02:07 PM
2006 TJ Fuel Problems jflorentino73 TJ General Discussion Forum 0 05-06-2010 11:26 AM
hardtop on 2006 wrangler x jeepin06 TJ Tech Forum 6 04-16-2010 10:45 AM
Fellow Ohio Jeepers Help fick15 Ohio Jeep Forum 11 01-19-2010 10:56 PM
Wrangler fuel pump not running on start captflyte YJ Tech Forum 2 05-09-2009 09:39 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 06:41 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC