4 wheel drive dash light - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-22-2012, 06:14 PM   #1
Jeeper
 
Jcole231's Avatar
 
Join Date: Jul 2011
Location: Slidell
Posts: 273
4 wheel drive dash light

When putting the jeep into 4wd, it engages but the dash light does not come on. Anyone know any possibilities? Thanks

Jcole231 is offline   Quote
Old 11-22-2012, 06:17 PM   #2
Jeeper
 
InvertChaos's Avatar
 
Join Date: Sep 2010
Location: NoVa
Posts: 7,940
Probably a burned out bulb

__________________
|2004 Jeep TJ "Green Machine"|4.0L 5 speed Dana44|33x12.50x15 Goodyear Duratracs|2.5" RC coils + 1.25" body lift|OME NitroSport shocks|4.56 gears|Skid Row Engine Skid|BCC Sliders|Currie AntiRock|
InvertChaos is online now   Quote
Old 11-22-2012, 08:26 PM   #3
Jeeper

WF Supporting Member
 
Sccafire's Avatar
 
Join Date: Oct 2011
Location: 82 miles from the Rubicon Trail
Posts: 831
I'd try the 4wd indicator switch on the tcase.
__________________
Scott
Sccafire is offline   Quote
Old 11-23-2012, 03:30 AM   #4
Newb
 
Join Date: Nov 2012
Posts: 4
To see if it is the 4WD indicator light on the dash do the following:

1) push and hold the trip meter button
2) turn on the ignition while holding the button in
3) release the button and all of the lights on your dash should cycle (one at a time)
4) watch for the 4WD light

If your 4WD light works, the next step is to replace the 4WD switch on the transfer case.
Motor484 is offline   Quote
Old 11-23-2012, 03:38 AM   #5
Jeeper
 
darkproximity's Avatar
 
Join Date: Feb 2011
Location: Not Spokane, WA
Posts: 12,000
Or just clean the switch up, it shouldn't really fail
__________________
Apache chief, e ne chuk!
darkproximity is offline   Quote
Old 11-23-2012, 07:41 AM   #6
Jeeper
 
jasonduke5's Avatar
 
Join Date: Sep 2011
Location: Williamsport P>A
Posts: 434
from what i see on here all the time this is a very common issue with a TJ. it happened to mine. there was no cleaning it or anything it just took a crap. and before i take it out and try a quick fix i would spend the 20 bucks to fix it right. if it was something more expensive i might try something like that but from what i have leanrd in the past tho quick fixes never last long
jasonduke5 is offline   Quote
Old 11-23-2012, 08:11 AM   #7
Jeeper
 
bmpage84's Avatar
 
Join Date: Jun 2012
Location: PEOPLES REPUBLIC OF MASSACHUSETTS, Somerset
Posts: 535
LOL! Didn't even know they still had them on 03 and up! Mine has never gone on and neither has my daughters! (Both 03's)
__________________
Happy Trails!

Chrome on a Jeep is like a hot chick with herpes!

bmpage84 is offline   Quote
Old 11-23-2012, 10:14 AM   #8
Jeeper
 
JeepinDave's Avatar
 
Join Date: Oct 2010
Location: NW Ohio
Posts: 570
How do you get to the bulb? If I recall, the only bulbs you can get to at the back of the cluster are the backlights for the whole cluster and the brights symbol. Or am I wrong? It's been awhile.

JeepinDave is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:15 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC