4WD Hi problem - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-22-2011, 09:31 PM   #1
Invader17's Avatar
Join Date: Feb 2011
Location: Bristow, Va
Posts: 12
4WD Hi problem

Hello guys,

I drove my 06 TJ early in the morning today on 4wd Hi cause the road was a little bit snowy, and everytime that I released the gas pedal to shift gear or just to slow down, I felt a clacking noise and I felted under my feet. When I got home I drove it on 4WD Lo and didn't had any problems. The clutch was replace not even three weeks ago.

Anybody has any advice? Will appreciate any suggestion.

Invader17 is offline   Quote
Old 02-22-2011, 10:48 PM   #2
Rather be on the mountain

WF Supporting Member
Phil05LJ's Avatar
Join Date: Aug 2010
Location: Central Virginia
Posts: 1,475
I'm not sure if they changed the design of the 4wd shift linkage from 99-06 but it makes a heck of a racket on the floor pan when it wears out. Here's a link, it's a simple check underneath.

Phil05LJ is offline   Quote
Old 02-23-2011, 06:16 AM   #3
Invader17's Avatar
Join Date: Feb 2011
Location: Bristow, Va
Posts: 12
Thanks a lot. I will check the website.
Invader17 is offline   Quote
Old 02-23-2011, 08:08 AM   #4
Vector6's Avatar
Join Date: Jan 2006
Location: Morgantown,WV
Posts: 1,025
there probably wasn't enough snow on the road surface to warrant using 4wd and the drive-train was binding up.
USN 1985-1993
Vector6 is offline   Quote

4wd hi problem , clacking noise , tj wrangler 06

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! I am pulling my hair out with my jeep's engine cut-off problem HRDRCKN YJ Tech Forum 7 09-08-2011 01:47 PM
Grand Cherokee, starting problem after getting fuel injector serviced SusanH YJ General Discussion Forum 5 02-26-2011 02:04 PM
Intermittent Starting Problem airexec2 TJ Tech Forum 0 12-06-2010 01:49 PM
Intermittent engine bucking problem 98TJsport TJ Tech Forum 0 11-08-2010 04:42 PM
2400 miles on new jk having trans problem NTJeep JK Tech Forum 4 01-14-2009 02:03 AM

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:38 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC