97 jeep wrangler tj injector issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-09-2011, 01:00 PM   #1
Jeeper
 
Negat Corpen's Avatar
 
Join Date: Oct 2008
Location: Cheney, Washington
Posts: 19
97 jeep wrangler tj injector issue

I am new to this but here is my problem if you can help. I put a new engine in my 97 jeep 2.5 and now the injectors wont pulse i have checked grounds, relays, also power to the injectors the wierd parts is if i turn the key on and hook a volt meter from the battery positive to the black and green wire on the number 1 injector i get 12v. it doesnt sound right because i thought ground was supposed to pulse.

Negat Corpen is offline   Quote Quick Reply
Old 12-09-2011, 01:08 PM   #2
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,368
Images: 2
The ground is indeed supposed to pulse, as is the ground for the ignition coil. I'd be suspicious of something like the crankshaft position sensor not working which the PCM requires before it will enable the ignition and fuel injection systems. If the PCM isn't happy with all of its various inputs it monitors, it won't enable the fuel injectors or ignition system. Check the camshaft position sensor too if the crankshaft position sensor is good. If the ASD (auto shut down) relay is not enabled by the PCM, nothing like the fuel injectors and ignition system will work, it is the ASD relay that controls them and it is controlled by the PCM.

__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 12-09-2011, 01:10 PM   #3
Jeeper
 
Negat Corpen's Avatar
 
Join Date: Oct 2008
Location: Cheney, Washington
Posts: 19
the thing is i have spark to all my cyclinders my dad put a header on it and it melted the wires to the crank sensor so we butt connected the wires back together but know that i had the motor out i soldered the wires and heat shrink them could that cause problems
Negat Corpen is offline   Quote Quick Reply
Old 12-09-2011, 01:17 PM   #4
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,368
Images: 2
Since the crankshaft position sensor wiring melted to the header, it's possible that shorted its power to ground and that circuit is now dead. I'd check for power on the CPS wiring and start tracing back if there is no voltage on it. Might be as simple as a blown fuse.
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 12-09-2011, 01:21 PM   #5
Jeeper
 
Negat Corpen's Avatar
 
Join Date: Oct 2008
Location: Cheney, Washington
Posts: 19
it melted before the motor blew up then we fixed it and it ran fine i checked for power at the crank position sensor andc there was 5 volts
Negat Corpen is offline   Quote Quick Reply
Old 12-09-2011, 01:26 PM   #6
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,368
Images: 2
Place an ohmmeter across terminals B and C. Ohmmeter should be set to 1K-to-10K scale for this test. The meter reading should be open (high resistance). Replace the sensor if a low resistance is indicated.

That is right out of the '97 FSM.
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 12-09-2011, 01:55 PM   #7
Jeeper
 
Negat Corpen's Avatar
 
Join Date: Oct 2008
Location: Cheney, Washington
Posts: 19
it had no reading it read 0
Negat Corpen is offline   Quote Quick Reply
Old 12-09-2011, 02:16 PM   #8
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,368
Images: 2
0 as in a dead short with 0 Ohms (no resistance at all), or 0 as in no connection across it whatsoever?
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 12-09-2011, 02:24 PM   #9
Jeeper
 
Negat Corpen's Avatar
 
Join Date: Oct 2008
Location: Cheney, Washington
Posts: 19
i oredred a new one and thanks ill let you know if it starts when the part comes in
Negat Corpen is offline   Quote Quick Reply
Old 12-09-2011, 02:25 PM   #10
Jeeper
 
Negat Corpen's Avatar
 
Join Date: Oct 2008
Location: Cheney, Washington
Posts: 19
ya it was 0 nothing at all i even took the sensor out and checked on the other side of my solder and still nothing
Negat Corpen is offline   Quote Quick Reply
Old 12-10-2011, 03:33 PM   #11
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,368
Images: 2
Quote:
Originally Posted by Negat Corpen View Post
ya it was 0 nothing at all
I still don't know what you mean by that. 0 as in 0 resistance (dead short) or 0 as in 0 connection (open, no connection at all).
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 12-14-2011, 03:10 PM   #12
Jeeper
 
Negat Corpen's Avatar
 
Join Date: Oct 2008
Location: Cheney, Washington
Posts: 19
okay so i bought a new crank position sernsor didnt fix the problem now i am getting that codes 31 and 42 the evap solienod makes a surge sound like short cicuit when i turn the car on what does that mean and 42 is a short or something in the asd i dont know where to even start

Negat Corpen is offline   Quote Quick Reply
Reply

Tags
2.5jeep , injectors , wrangler

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Jeep Jokes jeeptales Off-Topic 39 07-24-2013 01:14 AM
Rugged Ridge XHD Front Modular Bumper Systems 07-11 Jeep JK Wranglers, Free Shipping Baseline 4x4 Outfitters Vendor Spotlight! Great Deals for Members. 27 03-08-2013 01:03 PM
*** Jeep JK Wrangler Skid Plates *** Baseline 4x4 Outfitters Vendor Spotlight! Great Deals for Members. 4 05-30-2012 01:50 PM
Biggest Jeep Freek Contest!!!! txoutdoorx4 Classifieds Archive 6 02-21-2011 10:48 AM
Chryseler Announces Prices for 2010 Geoff@Bestop Off-Topic 13 08-20-2009 11:10 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:17 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC