'97 TJ 4.0 Rough idle & Missing - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-28-2008, 02:55 PM   #1
Jeeper
 
Gerald's Avatar
 
Join Date: Jan 2008
Location: zimbabwe
Posts: 59
Images: 12
Unhappy '97 TJ 4.0 Rough idle & Missing

Hi guys, great forum, I am a newbie with Jeep having used Land Rovers & land Cruisers for most of my life and always wanting the real deal. Now I've got one and the damn thing is driving me nuts. It has only got 40k on the clock and the revs are erratic between 600 & 1500, cold & hot. Also has started to missfire and the gas consupmtion is getting worse. Have checked the codes with nothing conclusive - have so far fitted a new TPS, plugs, rotor, distributor cap, plug leads - still no better. Here in England jeep info is hard to come by. Here's hoping for some kind soul to enlighten me.....
Cheers
Gerald

Gerald is offline   Quote Quick Reply
Old 02-28-2008, 03:16 PM   #2
Jeeper
 
foxinthemudd's Avatar
 
Join Date: Apr 2007
Location: oregon
Posts: 2,708
check out your MAP sensor, or more likely your IAS.

__________________
Keepin the peace.

The difference between sport and combat is that in combat you bury the one who comes in second.

THANK YOU VETS!
foxinthemudd is offline   Quote Quick Reply
Old 02-28-2008, 03:31 PM   #3
Jeeper
 
Gerald's Avatar
 
Join Date: Jan 2008
Location: zimbabwe
Posts: 59
Images: 12
Thanks, excuse my ignorance, but what is the IAS?
Gerald is offline   Quote Quick Reply
Old 02-28-2008, 03:48 PM   #4
Jeeper
 
Gerald's Avatar
 
Join Date: Jan 2008
Location: zimbabwe
Posts: 59
Images: 12
Have also just got hold of some Dobinsons Springs and shocks, has anyone got any experience on this product with jeeps?
Regards
Gerald
__________________
If you outlaw Guns - Only outlaws will have guns

'98TJ - 4.0 - 5 spd - 2.5" Coil Lift - 1.25" Body Lift - 32x11.50 Muds
Gerald is offline   Quote Quick Reply
Old 02-28-2008, 04:14 PM   #5
Jeeper
 
4.0l sahara's Avatar
 
Join Date: Apr 2007
Location: shelton,ct
Posts: 2,228
Quote:
Originally Posted by Gerald View Post
Thanks, excuse my ignorance, but what is the IAS?
It's iac not ias. There is no idle air sensor. It stands for idle air controlle.
__________________
99 sahara
4.0/np231/ax15/d30/d35
flowmaster40,hpd30 with aussie locker,currie upper joints,4.88's, lca skids,chromo shafts,vanco brakes,d35 with super 35 and arb locker,re 4.5" springs,currie arms,re front uppers,Re shocks in back,walkerevens shocks up front, Re track bars with currie jj joints,anti rock,ss brake lines,re rear sway bar links,jks 1.25" bl and mml,bfg 35x12.5 km2's,craiger soft 8's,ome steering stabilizer,currie hd steering,rockmen front bumper,emp tank skid,lots more too.
4.0l sahara is offline   Quote Quick Reply
Old 02-28-2008, 05:52 PM   #6
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
I would say it would be the MAP sensor since it is missfireing also.The IAC would just be causeing a rough idle from being to low or idle to high or up and down between the two.
__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 02-28-2008, 06:00 PM   #7
Jeeper
 
4.0l sahara's Avatar
 
Join Date: Apr 2007
Location: shelton,ct
Posts: 2,228
Ya good chance it's the map since that regulates fuel flow.
__________________
99 sahara
4.0/np231/ax15/d30/d35
flowmaster40,hpd30 with aussie locker,currie upper joints,4.88's, lca skids,chromo shafts,vanco brakes,d35 with super 35 and arb locker,re 4.5" springs,currie arms,re front uppers,Re shocks in back,walkerevens shocks up front, Re track bars with currie jj joints,anti rock,ss brake lines,re rear sway bar links,jks 1.25" bl and mml,bfg 35x12.5 km2's,craiger soft 8's,ome steering stabilizer,currie hd steering,rockmen front bumper,emp tank skid,lots more too.
4.0l sahara is offline   Quote Quick Reply
Old 02-28-2008, 09:17 PM   #8
Jeeper
 
Join Date: Jan 2008
Posts: 138
That would throw codes.
__________________
http://i5.photobucket.com/albums/y15...IMG00236-1.jpg

H2 Recovery Team
Pierce07 is offline   Quote Quick Reply
Old 02-29-2008, 07:28 AM   #9
Jeeper
 
Gerald's Avatar
 
Join Date: Jan 2008
Location: zimbabwe
Posts: 59
Images: 12
thanks for all the advice, will post the final cure.
Cheers
__________________
If you outlaw Guns - Only outlaws will have guns

'98TJ - 4.0 - 5 spd - 2.5" Coil Lift - 1.25" Body Lift - 32x11.50 Muds
Gerald is offline   Quote Quick Reply
Old 03-01-2008, 01:33 PM   #10
Jeeper
 
foxinthemudd's Avatar
 
Join Date: Apr 2007
Location: oregon
Posts: 2,708
Quote:
Originally Posted by foxinthemudd View Post
check out your MAP sensor, or more likely your IAS.
Quote:
Originally Posted by 4.0l sahara View Post
It's iac not ias. There is no idle air sensor. It stands for idle air controlle.

thats what I ment.




Quote:
Originally Posted by Pierce07 View Post
That would throw codes.
mine never threw a code for the MAP. I ended up just replacing it and it was solved.
__________________
Keepin the peace.

The difference between sport and combat is that in combat you bury the one who comes in second.

THANK YOU VETS!
foxinthemudd is offline   Quote Quick Reply
Old 03-01-2008, 04:00 PM   #11
Jeeper
 
Gerald's Avatar
 
Join Date: Jan 2008
Location: zimbabwe
Posts: 59
Images: 12
Question

Tried clearing the ECU today bu disconnecting battery etc. Seemed to help the idle problem for a while, but after 20 miles or so, problem returned again, Gonna have a go at cleaning out the IAC tomorrow ..... just in case before I have to pay up for a MAP - these things are damn expensive in this country.
Cheers
__________________
If you outlaw Guns - Only outlaws will have guns

'98TJ - 4.0 - 5 spd - 2.5" Coil Lift - 1.25" Body Lift - 32x11.50 Muds
Gerald is offline   Quote Quick Reply
Old 03-01-2008, 04:04 PM   #12
Jeeper
 
Join Date: Nov 2006
Location: Chicago, IL
Posts: 8,286
Send a message via AIM to Triple88a Send a message via MSN to Triple88a Send a message via Yahoo to Triple88a Send a message via Skype™ to Triple88a
dont worry they are expensive everywhere.. about 200 ish around here.
Triple88a is offline   Quote Quick Reply
Old 03-01-2008, 07:45 PM   #13
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
The last one I put on a customers S-10 was $79 and I just checked and one for a 97 TJ is $97.It should trow a code but it my be showing more than one still making it hard to pin point.
__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 04-06-2008, 07:15 AM   #14
Jeeper
 
Gerald's Avatar
 
Join Date: Jan 2008
Location: zimbabwe
Posts: 59
Images: 12
Still fighting this, have cleaned out the IAC as well as cleaned all the connections and plugs on the MAP, TPS and IAC. The idle fault is much better but it is still is not as smoth as one would expect, and is a little lumpy. The gas milage went for a loop last week and even though there were no fault codes present, have fitted a new O2 sensor. I just know that I am gonna have to bite the bullet and fit a new Map sensor and IAC valve. Am taking it on long run today (in the snow!!!) so will hopefully have a better milage.
Later

__________________
If you outlaw Guns - Only outlaws will have guns

'98TJ - 4.0 - 5 spd - 2.5" Coil Lift - 1.25" Body Lift - 32x11.50 Muds
Gerald is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Runing rough, idle rough, cylinder #4 misfire spdrcrpete TJ General Discussion Forum 13 06-02-2008 02:32 PM
4.2 rough idle and stalling problem truemainer150 YJ Tech Forum 9 04-12-2008 06:10 PM
rough idle spanky TJ Tech Forum 9 04-08-2008 05:25 PM
rough idle for 5 or 10 minutes... Jonny15 TJ Tech Forum 5 04-02-2008 08:34 PM
I noticed rough idle after lift. bpowa TJ Tech Forum 11 07-31-2007 01:13 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:25 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC