97 won't idle - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-05-2011, 09:58 AM   #1
Jeeper
 
Fazed's Avatar
 
Join Date: Aug 2010
Location: Lexington, KY
Posts: 343
97 won't idle

I changed my water pump on my TJ 4.0, and now for some reason I can only start it with assist from the gas pedal, it will run, but take my foot off the gas and it won't idle. Just dies. Any ideas?

It ran fine before I changed the pump.

__________________
2007 JK Unlimited X
1997 TJ Sahara
Fazed is offline   Quote
Old 08-05-2011, 10:03 AM   #2
Commercial Member

WF Supporting Member
 
kfdjason7620's Avatar
 
Join Date: Apr 2011
Location: Kenly, NC
Posts: 3,962
Did you disconnect battery when you did the work?

kfdjason7620 is offline   Quote
Old 08-05-2011, 10:06 AM   #3
Jeeper
 
Fazed's Avatar
 
Join Date: Aug 2010
Location: Lexington, KY
Posts: 343
Quote:
Originally Posted by kfdjason7620
Did you disconnect battery when you did the work?
No. Did I jack it up by not doing so?
__________________
2007 JK Unlimited X
1997 TJ Sahara
Fazed is offline   Quote
Old 08-05-2011, 10:10 AM   #4
Commercial Member

WF Supporting Member
 
kfdjason7620's Avatar
 
Join Date: Apr 2011
Location: Kenly, NC
Posts: 3,962
I wouldn't think so
kfdjason7620 is offline   Quote
Old 08-05-2011, 10:12 AM   #5
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 36,301
That it will only run when you step on the accelerator pedal could point to a bad or disconnected IAC (idle air controller) or TPS (throttle position sensor). Or a battery that is nearly dead, did you have to jump start the Jeep or did it start ok with its battery?
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote
Old 08-05-2011, 10:13 AM   #6
Commercial Member

WF Supporting Member
 
kfdjason7620's Avatar
 
Join Date: Apr 2011
Location: Kenly, NC
Posts: 3,962
But 2 months ago I swapped trannys and had same symptoms, mine was the cps, the one that came with replacement tranny was bad, I put old oneback in and it did fine. But yours has got me scratching my head
kfdjason7620 is offline   Quote
Old 08-05-2011, 10:17 AM   #7
Jeeper
 
Fazed's Avatar
 
Join Date: Aug 2010
Location: Lexington, KY
Posts: 343
Ok. The battery was dead when I finished. Stupid me wasn't thinking about the hood light when I was working. Also, since this the play jeep, it hadn't been run in a while so it was already probably drained from sitting.

For grins, I disconnected the battery and reconnected. Started right up and idled fine. Gonna go drive it now and see if it stays running.
__________________
2007 JK Unlimited X
1997 TJ Sahara
Fazed is offline   Quote
Old 08-05-2011, 10:20 AM   #8
Jeeper
 
Fazed's Avatar
 
Join Date: Aug 2010
Location: Lexington, KY
Posts: 343
Quote:
Originally Posted by Fazed
Ok. The battery was dead when I finished. Stupid me wasn't thinking about the hood light when I was working. Also, since this the play jeep, it hadn't been run in a while so it was already probably drained from sitting.

For grins, I disconnected the battery and reconnected. Started right up and idled fine. Gonna go drive it now and see if it stays running.
Let me also state that I charged it back up before I tried it today, so for the previous event, the battery was fully charged. My last post made me kinda sound like an idiot.
__________________
2007 JK Unlimited X
1997 TJ Sahara
Fazed is offline   Quote
Old 08-05-2011, 10:22 AM   #9
Commercial Member

WF Supporting Member
 
kfdjason7620's Avatar
 
Join Date: Apr 2011
Location: Kenly, NC
Posts: 3,962
Cant hide from Jerry's sharp detective skills !!! Lol

kfdjason7620 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
4.2 carb problems stray YJ Tech Forum 20 09-29-2014 10:02 PM
Idle air control motor tbush95YJ YJ Tech Forum 0 12-22-2010 08:03 AM
rough idle dmwilson01 YJ Tech Forum 4 12-12-2010 10:16 PM
question for master mechanics about idle? autopc25 TJ Tech Forum 11 01-19-2010 05:52 PM
Erratic idle after start up for a minute when hot or cold? autopc25 TJ Tech Forum 2 01-09-2010 06:25 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:36 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC