'99 TJ A/C Question - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-02-2012, 10:13 PM   #1
Jeeper
 
Dempsey's Avatar
 
Join Date: Dec 2010
Location: Tobacco Country
Posts: 4,955
'99 TJ A/C Question

So I have done some reading and searching and about to buy a manual or take it somewhere but before I do I thought I would see if some on here could give me a hand.

My A/C on my new rig doesn't work and I want it to. The compressor is not engaging when I turn on the a/c. I have briefly hard wired the clutch and the clutch and compressor do function. I have bypassed the low pressure switch with a wire but still nothing. The relay is working and I have swapped the relay with another one....nothing.

Now the high pressure switch is not showing 12 volts and appears to be grounded...seems a little odd.

What else should I check?

Thanks

__________________
'76 CJ7
It's red.
'99 TJ
It's red too.
Dempsey is offline   Quote
Old 07-02-2012, 10:19 PM   #2
Mr. Little Tires

WF Supporting Member
 
gixxerphil's Avatar
 
Join Date: Dec 2010
Location: Auburn, Al
Posts: 32,972
I wish I could help, my move was to take it to a shop and fork out $1200 for a new system
But my nipples are hard every time I turn it on now

__________________
The last true Wrangler ended with a metal grille
gixxerphil is online now   Quote
Old 07-02-2012, 10:24 PM   #3
Jeeper
 
Dempsey's Avatar
 
Join Date: Dec 2010
Location: Tobacco Country
Posts: 4,955
Quote:
Originally Posted by gixxerphil View Post
I wish I could help, my move was to take it to a shop and fork out $1200 for a new system
But my nipples are hard every time I turn it on now
Thats for the mental image.

I'm too stubborn to do that.
__________________
'76 CJ7
It's red.
'99 TJ
It's red too.
Dempsey is offline   Quote
Old 07-02-2012, 11:14 PM   #4
Jeeper
 
div4gold's Avatar
 
Join Date: Feb 2012
Location: WA
Posts: 507
Is the system fully charged with R134?
__________________
2006 TJ Unlimited, stock.
div4gold is offline   Quote
Old 07-02-2012, 11:19 PM   #5
Mr. Little Tires

WF Supporting Member
 
gixxerphil's Avatar
 
Join Date: Dec 2010
Location: Auburn, Al
Posts: 32,972
Quote:
Originally Posted by Dempsey View Post
Thats for the mental image.

I'm too stubborn to do that.

I would have loved to learn to do it on my own, but in this Southern humidity it was easier to let them have the Jeep for 3 hours and be done
__________________
The last true Wrangler ended with a metal grille
gixxerphil is online now   Quote
Old 07-02-2012, 11:36 PM   #6
Jeeper
 
Black.Jeep.Alex's Avatar
 
Join Date: Jan 2012
Location: Murphy, NC
Posts: 212
at least you have an a/c compressor in yours lol my 99 didnt come with a/c. and everytime i tried fixing the a/c on my car it was a real pita. eventually i just gave in to the mechanic.
__________________
99 Wranlger TJ
Black.Jeep.Alex is offline   Quote
Old 07-02-2012, 11:46 PM   #7
Dont forget a Jack strap

WF Supporting Member
 
jkaufman_95's Avatar
 
Join Date: Sep 2010
Location: On the Road,
Posts: 30,846
Hey nick, the control panel commonly goes out on the tj air controls I believe. Just replaced mine (along with every other part) that might help
__________________
Do I look like a cat to you boy? Am I jumpin' around all nimbly bimbly from tree to tree? Am I drinking milk from a saucer? DO YOU SEE ME EATING MICE?
jkaufman_95 is offline   Quote
Old 07-03-2012, 06:04 AM   #8
Jeeper
 
Dempsey's Avatar
 
Join Date: Dec 2010
Location: Tobacco Country
Posts: 4,955
Quote:
Originally Posted by jkaufman_95 View Post
Hey nick, the control panel commonly goes out on the tj air controls I believe. Just replaced mine (along with every other part) that might help
Ok. We talked about that last night. That is a possiblity. Not sure how to troubleshoot that yet.
__________________
'76 CJ7
It's red.
'99 TJ
It's red too.
Dempsey is offline   Quote
Old 07-08-2012, 02:16 PM   #9
Newb
 
Join Date: Jun 2012
Posts: 3
Sounds like you are low on 134, the compressor is wired not to kick in when low of 134, get system rechared then see what you got, don't bypass the compressor clutch again it will damage the system.
tjblackhills is offline   Quote
Old 07-08-2012, 02:23 PM   #10
Newb
 
Join Date: Jun 2012
Posts: 3
ac problems

Sounds like you are low on 134r get system rechared then see what you got. Don't bypass compressor clutch again as you will damage the compressor it is made not to kick in when low on 134r.

tjblackhills is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:54 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC