Ac/heater speed control switch - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-08-2014, 08:06 PM   #1
Jeeper
 
jazzman's Avatar
 
Join Date: Jan 2013
Posts: 57
Ac/heater speed control switch

I bought this part about a month ago and it is not working now can it be the blow motor or can it be a defective part? It's been working perfectly fine. Can someone give me some info please??

jazzman is offline   Quote Quick Reply
Old 08-08-2014, 08:10 PM   #2
Jeeper

WF Supporting Member
 
O_M_Jeep's Avatar
 
Join Date: Aug 2011
Location: South Central Wyoming
Posts: 1,168
I usually have to take my HVAC controls out every 3-6 months and clean them really well, if you live in a dirty area or desert or just go topless a lot they will get pretty dirty in there. Or it could be a bad motor, but if replacing the switch worked last time thats a good place to start this time too.

__________________
There are a million ways to build a Jeep, pick one and do it - you bought a canvas, not a painting!

Click here to support Wranglerforum
Or else the teddy bear gets it
O_M_Jeep is offline   Quote Quick Reply
Old 08-08-2014, 08:21 PM   #3
Jeeper
 
jazzman's Avatar
 
Join Date: Jan 2013
Posts: 57
Thanks!
jazzman is offline   Quote Quick Reply
Old 08-08-2014, 08:30 PM   #4
Supporting Member

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 6,129
Images: 11
Follow this diagnostic to figure out what the problem is: Heater problems
__________________
Dennis
Water Dog is online now   Quote Quick Reply
Old 08-08-2014, 08:43 PM   #5
Jeeper
 
jazzman's Avatar
 
Join Date: Jan 2013
Posts: 57
Thanks I will.
jazzman is offline   Quote Quick Reply
Old 08-09-2014, 04:00 PM   #6
Jeeper
 
jazzman's Avatar
 
Join Date: Jan 2013
Posts: 57
Ok I bought the resistor and I bought the blower motor and I'm still not getting any AC can someone help me can it be that switch again fuses are ok.
jazzman is offline   Quote Quick Reply
Old 08-10-2014, 11:11 AM   #7
Jeeper
 
jazzman's Avatar
 
Join Date: Jan 2013
Posts: 57
Wow I got my AC fixed!! I want to thank you for all your help it was the melted connection the vacuum switch. Thanks again for your help Jeeper friends!!!

jazzman is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:50 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC