AC problem pls help - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-21-2012, 01:34 PM   #1
Newb
 
Join Date: May 2012
Posts: 1
AC problem pls help

Hi,
I have a 98' Wrangler Sahara 4.0 6cyl. For quite a while now my ac has been having problems with what i assume is the vacuum. It works, its cold, but anytime i accelerate for a moderate period of time or go up hills (at higher RPMs) the air slowly dies out and i can hear the vacuum building up with air, but as soon as i decelerate the vacuum releases and the air works great. it never fails to happen everywhere i go.

help would be awesome
Jon

superbuddha is offline   Quote
Old 05-21-2012, 02:29 PM   #2
Jeeper
 
50Johnbob's Avatar
 
Join Date: Dec 2011
Location: Deer Park, Tx
Posts: 564
Sounds like a vacuum leak to me, crawl under the passenger side of the Jeep and look up in the area under the battery and see if this hose is disconnected or cracked. It should be connected to the vacuum reservoir.
50Johnbob is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:41 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC