All gauges stopped working..help needed - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-06-2011, 05:39 PM   #1
Jeeper
 
Sandy Feet's Avatar
 
Join Date: May 2011
Location: PCB
Posts: 25
All gauges stopped working..help needed

Well, I just bought this Jeep, 97 TJ. I have disconnected an amp that wasnt working but thats about it. Today all of the gauges on the dash including the stereo is out. Nothing will come on. Any suggestions?? Thanks for any advice.

Sandy Feet is offline   Quote Quick Reply
Old 06-06-2011, 06:18 PM   #2
Jeeper
 
Sandy Feet's Avatar
 
Join Date: May 2011
Location: PCB
Posts: 25
checked all of the fuses and all are good. Also checked the wires. all dummy lights come on but not any gauges, stereo or fan controls.

Sandy Feet is offline   Quote Quick Reply
Old 06-06-2011, 06:30 PM   #3
Jeeper
 
Scoob's Avatar
 
Join Date: Aug 2005
Location: Iowa
Posts: 1,790
This is a common problem with the early year TJ's. A slap to dash will probably fix it.
__________________
Scoob
Scoob is offline   Quote Quick Reply
Old 06-06-2011, 06:39 PM   #4
Jeeper
 
Sandy Feet's Avatar
 
Join Date: May 2011
Location: PCB
Posts: 25
Disregard, problem solved. Thx!!
Sandy Feet is offline   Quote Quick Reply
Old 06-06-2011, 06:56 PM   #5
Jeeper
 
kboles89's Avatar
 
Join Date: Jan 2011
Location: elon, nc
Posts: 451
Did slapping it really fix it?
kboles89 is offline   Quote Quick Reply
Old 06-06-2011, 07:03 PM   #6
Jeeper
 
gpzjack's Avatar
 
Join Date: May 2010
Location: PA
Posts: 168
I remember the first time my dash stopped working...at 70mph....a quick punch of the dash cleared it right up. LOL
__________________
00 Wrangler, 07 Subaru Legacy, 06 Mazda5, 96 Dakota, 03 Kawasaki
gpzjack is offline   Quote Quick Reply
Old 06-06-2011, 07:29 PM   #7
Jeeper
 
Sandy Feet's Avatar
 
Join Date: May 2011
Location: PCB
Posts: 25
Nah, it was actually a fuse i missed under the hood. Simple fix, no punch necessary. lol

Sandy Feet is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
All gauges stopped working..help needed Sandy Feet TJ General Discussion Forum 4 06-07-2011 02:06 PM
Speedometer stopped working! bmanrkg3 TJ General Discussion Forum 6 05-21-2011 12:09 PM
gauges not working sinepome YJ Tech Forum 8 04-07-2011 08:21 PM
engine light stopped working mrbigjeep TJ Tech Forum 8 09-22-2006 10:38 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:51 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC