Bad fuel pump? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-29-2012, 10:34 PM   #1
JDT
Jeeper
 
JDT's Avatar
 
Join Date: Oct 2011
Location: Williamstown or Richmond, KY
Posts: 153
Bad fuel pump?

My 05 2.4L randomly starts sputtering when driving and sometimes when it's idling it'll lope, when it starts sputtering when driving if you push in the clutch and mat the gas it'll the RPMs slowly climb and the motor is missing and sputtering the whole time. It seems that it's random, but recently I've noticed it does it more often around a half tank of fuel, and really badly below a half which is what makes me suspect the fuel pump. The check engine light occasionally comes on and goes off when it's doing it, I can't remember the code but I'll get it tomorrow and report back. Thanks for any help!!! I just wanna get my Jeep runnin good all the time, not just 90% if the time.

JDT is offline   Quote Quick Reply
Old 03-30-2012, 12:11 AM   #2
I like Jeeps...

WF Supporting Member
 
jeepwayoflife's Avatar
 
Join Date: Nov 2011
Location: California
Posts: 2,723
Someone on here just had that EXACT same problem. You need to check the fuel filter, and maybe replace the fuel pump. When the tank gets low, it will be harder for the pump to pump and the engine will not get the gas it needs, causing the sputtering and low rpm's. Also, it could just be sediment In the fuel filter but almost everything I have seen says it is the fuel pump. Good luck!!

__________________
--------------------------------------------------------
Take it out and play with it
Drive it like you built it
jeepwayoflife is online now   Quote Quick Reply
Old 03-30-2012, 10:53 PM   #3
JDT
Jeeper
 
JDT's Avatar
 
Join Date: Oct 2011
Location: Williamstown or Richmond, KY
Posts: 153
I'm starting to really suspect the pump, like you said everything looks like it is and today I noticed when the rpm's are above 3,000 the motor looses power and starts sputtering around 4,000, which also makes me think the pump isn't supplying enough fuel. Looks like dropping the tank is in my future.
JDT is offline   Quote Quick Reply
Old 03-31-2012, 12:56 AM   #4
Jeeper
 
Wrangler06's Avatar
 
Join Date: Jun 2010
Location: Roanoke Virginia
Posts: 1,643
Mine started this the past couple weeks but no engine light..i was planning on doing the fuel filter is it above the tank?? figured its gotta be fuel related cause i have done all the fluids, plugs and wires,air filter cleaned the whole intake and throttle body... Figured its the fuel filter and/or pump or possibly an o2 sensor or pcv valve?
__________________
Impact Orange 06 Wrangler SE 2.4l 6 speed
OME and Bilsteins, 31x10.50 Kelly Safari Tsr
Magnaflow Exhaust, Rustoleum Lined Tub, Hard Top, Full Doors
Wrangler06 is offline   Quote Quick Reply
Old 03-31-2012, 04:18 PM   #5
JDT
Jeeper
 
JDT's Avatar
 
Join Date: Oct 2011
Location: Williamstown or Richmond, KY
Posts: 153
I was gonna do the filter too, but I heard its on top of the tank and its a "lifetime" filter so I might just do it and the pump together. My engine light is out now but it's still runnin bad, but mine always comes back on after a week or so and goes off after a couple days.
JDT is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LDT 465 multi fuel in Wrangler..... TheLynx General Jeep Discussion 5 04-25-2012 08:51 PM
Can i get a reveiw of whats good or bad about the bfgoodrich m/t km2?? Zesty Mike General Jeep Discussion 9 03-30-2012 05:24 PM
3.8L oil pump replacement Bluejeepman55 JK General Discussion Forum 0 03-29-2012 06:49 PM
Bad A@@ Concept from JEEP Akinvegas JK General Discussion Forum 7 03-29-2012 03:07 PM
Bad spot on frame jasonduke5 TJ General Discussion Forum 9 03-28-2012 11:30 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:32 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC