blower motor not working - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-01-2010, 09:04 PM   #1
Newb
 
Join Date: Sep 2010
Location: Pittsburgh Pennsylvania
Posts: 7
blower motor not working

Need help. Blower motor just quit working. Have spare motor that I know works plugged it in and it didn't work. May be switch not sure. Any ideas. Doesn't work on any speed. Fuse ok, is there a relay or fuse under hood in power distribution center. Scratching my head on this one.

Thanks for any help

jimseanor is offline   Quote Quick Reply
Old 12-01-2010, 09:21 PM   #2
Jeeper
 
mike_the_engineer's Avatar
 
Join Date: Mar 2010
Posts: 62
a

__________________
Roads? Where we're going we don't need... (puts on sunglasses)... roads.
mike_the_engineer is offline   Quote Quick Reply
Old 12-01-2010, 09:40 PM   #3
Jeeper
 
pokey's Avatar
 
Join Date: Feb 2010
Location: backroads of the Mojave
Posts: 1,106
Most likely the fan speed switch is bad ($25) or the connector attached to it is melted. Or the connector on the back of the climate mode switch is melted (fan relay). You'll have to get back behind those controls and check the connections. It isn't hard. Good luck.
__________________
__________________________________________
. . . . picking the lines with my twenty-nines . . . .
__________________________________________

'99 sport 4.0 5 speed, top-of-the-line floormats
pokey is offline   Quote Quick Reply
Old 12-03-2010, 09:59 AM   #4
Newb
 
Join Date: Sep 2010
Location: Pittsburgh Pennsylvania
Posts: 7
thanks, forgot to mention, have a 98 TJ Switch looks ok and everything behind dash looks ok replaced relay and resistor still doesn't work. Any idea how to remove the blower motor. Can it be removed from the engine compartment or do you have to remove the dash and remove from inside. Any help would be appreciated. Really stumped on this one.
jimseanor is offline   Quote Quick Reply
Old 12-03-2010, 10:27 AM   #5
[]D [] []V[] []D

WF Supporting Member
 
97sport09's Avatar
 
Join Date: Sep 2010
Location: Hoosier State
Posts: 695
pull your battery out and you will see it behind there. It will have 3 bolts that hold in the motor, to get to one of the bolts you need to take off the control module on the left

97sport09 is offline   Quote Quick Reply
Old 12-03-2010, 01:15 PM   #6
Newb
 
Join Date: Sep 2010
Location: Pittsburgh Pennsylvania
Posts: 7
Thanks

Quote:
Originally Posted by 97sport09 View Post
pull your battery out and you will see it behind there. It will have 3 bolts that hold in the motor, to get to one of the bolts you need to take off the control module on the left

Thanks for help, work out great. Blower motor is ok now really scratching my head. This was really helpful Thanks again
jimseanor is offline   Quote Quick Reply
Old 12-03-2010, 01:18 PM   #7
Newb
 
Join Date: Sep 2010
Location: Pittsburgh Pennsylvania
Posts: 7
Anyt Ideas. Blower motor checks out ok. Replaced resistor and relay. Fuses ok. Still blower motor doesn't run. This one is really driving me up a wall. Not sure about the switch itself. I seems I can only get it with the whole assembly. Any Ideas.
jimseanor is offline   Quote Quick Reply
Old 12-03-2010, 03:31 PM   #8
Jeeper
 
pokey's Avatar
 
Join Date: Feb 2010
Location: backroads of the Mojave
Posts: 1,106
You CAN get the fan speed switch by itself, about $25. Chrysler sells a lot of them because they go bad. Some dealers will tell you you need the whole panel with the 3 knobs. Not true. And make sure you check those 2 connectors on the back of the switches REAL good. Even if they don't look melted make sure they're making good contact with the male tabs on the back of the fan switch and climate mode switch, good luck.

__________________
__________________________________________
. . . . picking the lines with my twenty-nines . . . .
__________________________________________

'99 sport 4.0 5 speed, top-of-the-line floormats
pokey is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater Blower Switch- No Power!!!???!!! XGARDX TJ General Discussion Forum 2 09-06-2011 10:44 PM
Jeep serviced at the dealership; now blower vents sticking dasani TJ General Discussion Forum 11 07-22-2010 12:26 PM
Blower fan has stopped working? J.A TJ Tech Forum 6 01-17-2010 07:19 AM
99 Wrangler Blower motor Segrat1 TJ Tech Forum 2 08-17-2009 09:12 AM
Heater / Blower Problem 2000 Wrangler dougman1971 TJ Tech Forum 0 09-17-2008 07:56 AM



» Featured Product

All times are GMT -5. The time now is 01:44 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC