Break issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-16-2011, 10:57 PM   #1
Newb
 
Join Date: May 2011
Posts: 5
Break issue

Hi all, I am hoping you can provide me with some advice. I recently had my front breaks (calipers & Roters) at my local shop. Right front brake was grabbing (to the point of smoking) so I scheduled for a warranty repair. Unfortunately mechanics wife got very sick and he is unable to work on it. She is in a medically induces coma so totally understood. He said sounds like we got a bad caliper or hose. So I went to the same parts store he uses and got a new caliper and hose. Less than a thousand on the rotor. Only put a couple of hundred miles before the problem. So I replace the hose and begin to install caliper. Noticed that the bleeder was at the lower end of the caliper. Always thought they were on top. Compared to one I took off and the the bleeder is on the top not bottom. Take Caliper back to CarQuest and they say it is the correct one. I am a little suspicious but, go ahead and install. Bleed breaks and notice write off that something is not right. Caliper is locked up (No wheel turn). Pressure will build and not getting any air. With motor running they go straight to the floor. Sounds to me like I got screwed on the Caliper your thoughts?

dreamunelk is offline   Quote Quick Reply
Old 05-17-2011, 10:27 AM   #2
Jeeper
 
Shelby427's Avatar
 
Join Date: May 2011
Location: Lakeland FL and Hooversville PA
Posts: 2,130
YEP! Just cause the number on the box is right doesn't mean the part inside is.

The bleeder is on top as air rises in the fluid, it doesn't drop.

Take it back and have another clerk pull another one for you. *

Most likely it's a caliper for a front mount on the spindle instead of a rear mount.
Make sense?

* or go to another CQ store tell em what happened and they should take care of it.

__________________
97 Sahara, 74 Renegade, 72 CJ5, 55 Willy's (the Beast) Boss 302, 6:34 gearing, Bose 901 speakers.
God I miss that Jeep. Forgot the kinda Jeep, 80 SX4.
Shelby427 is offline   Quote Quick Reply
Old 05-17-2011, 10:29 AM   #3
Hardcore Jeeper
 
Peepers's Avatar
 
Join Date: Oct 2010
Location: Windsor, CT
Posts: 3,320
x2^^^ the bleeder should be on top. I just ordered new calipers for my truck and there are two different numbers, one for the left, and one for the right.
__________________
What have we got?
We have one heavily armed Recreational Vehicle


ΣΧ
The Power Tech 6
Peepers is offline   Quote Quick Reply
Old 05-17-2011, 10:37 AM   #4
President, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,947
wrong side caliper... upside down maybe? x3, bleeder should be on the top as air rises.
__________________
-Chris
President, ThumbJeeps
CB Callsign "AirForce One"


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote Quick Reply
Old 05-17-2011, 01:19 PM   #5
Jeeper
 
neverfastenough1's Avatar
 
Join Date: Nov 2010
Location: Savannah, Ga
Posts: 925
Should have installed the hose and then checked the brakes to see if it still locked up. The hose is more tan often the culprit when the brakes release over time. A stuck caliper stays stuck. Try the old caliper with the new hose. If it works just take the new caliper back.
neverfastenough1 is offline   Quote Quick Reply
Old 05-17-2011, 02:21 PM   #6
Jeeper
 
Join Date: Aug 2010
Posts: 466
Quote:
Originally Posted by dreamunelk View Post
Hi all, I am hoping you can provide me with some advice. I recently had my front breaks (calipers & Roters) at my local shop. Right front brake was grabbing (to the point of smoking) so I scheduled for a warranty repair. Unfortunately mechanics wife got very sick and he is unable to work on it. She is in a medically induces coma so totally understood. He said sounds like we got a bad caliper or hose. So I went to the same parts store he uses and got a new caliper and hose. Less than a thousand on the rotor. Only put a couple of hundred miles before the problem. So I replace the hose and begin to install caliper. Noticed that the bleeder was at the lower end of the caliper. Always thought they were on top. Compared to one I took off and the the bleeder is on the top not bottom. Take Caliper back to CarQuest and they say it is the correct one. I am a little suspicious but, go ahead and install. Bleed breaks and notice write off that something is not right. Caliper is locked up (No wheel turn). Pressure will build and not getting any air. With motor running they go straight to the floor. Sounds to me like I got screwed on the Caliper your thoughts?
he gave you the left side caliper
hookuspookus is offline   Quote Quick Reply
Old 05-18-2011, 10:27 PM   #7
Newb
 
Join Date: May 2011
Posts: 5
Thanks all for the help. Replaced caliper and everything seems fine. Only did about a 10 mile test drive but, all appears functional.

Yes, I did take back to CQ and got a ration when I said ti was the wrong one. The pulled one from the back room and it was the same. They kept saying our computer says this is the left side caliper. So I chose to believe them. I deal with them because they have a good reputation. I am not a mechanic and assumed they new what they were doing. Ended up going to Napa and getting another caliper. I plan to take wrong part back to CQ but, seem to have lost my receipt.

The problem was with the caliper. It was froze solid even after removing break line and loosening bleeder. Changed the break line because I had it my hand basically and I have almost 200k miles on my jeep. A good share on logging roads and other.

thanks again

dreamunelk is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me to diagnose rough ride/engine/ issue gammy TJ Tech Forum 8 05-21-2013 07:35 PM
P0431 issue, replaced front downstream, still issue Dixit TJ Tech Forum 7 07-12-2010 10:06 AM
New Jeeper. Fuel Issue? 2nd post South23 YJ Tech Forum 14 06-06-2010 11:10 AM
2" Lift - Front Vibration/Knocking Issue After Lift cmorra68 TJ Tech Forum 6 04-30-2009 03:03 PM
Summer 2008 Issue of JPFreek Magazine Available Now txoutdoorx4 General Jeep Discussion 1 06-25-2008 10:25 PM



» Featured Product

All times are GMT -5. The time now is 09:50 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC