Calling all AEM Bruteforce owners - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-12-2009, 07:37 PM   #1
Jeeper
 
Timberman's Avatar
 
Join Date: Sep 2008
Location: Oregon
Posts: 431
Calling all AEM Bruteforce owners

Hello!

I am having a little bit of an issue with my AEM Bruteforce intake.

The little plastic plug has fallen out twice.. I just discovered this a few minutes ago and this was the second time.

I called AEM last time and they gladly sent me another one, but it fell out too.

The person at AEM stated that this has never been an issue.. Leave it to me!!

So, has anyone else had any problems with the plastic plug falling out? If so, what was your remedy?

Thanks

Timber

__________________
"Greatness is not achieved without taking risk."
Timberman is offline   Quote Quick Reply
Old 12-13-2009, 10:09 AM   #2
Jeeper
 
Timberman's Avatar
 
Join Date: Sep 2008
Location: Oregon
Posts: 431
Looks like its just me who is having this problem... Seems to be par for the course as of late...

__________________
"Greatness is not achieved without taking risk."
Timberman is offline   Quote Quick Reply
Old 12-13-2009, 01:36 PM   #3
Jeeper
 
Join Date: Nov 2009
Location: Parsippany, NJ
Posts: 43
do you mean the plastic plug on top of the cone? If so, just glue it back in.
__________________
Patiently waiting for the right time to order a 2015 Hard Rock...
omgwtfbbqcopter is offline   Quote Quick Reply
Old 12-13-2009, 01:54 PM   #4
that's what she said

WF Supporting Member
 
jgano23's Avatar
 
Join Date: Oct 2008
Location: \m/-_-\m/
Posts: 16,482
Send a message via AIM to jgano23 Send a message via Yahoo to jgano23
sorry timberman, i have that intake, but have never had this, or any, problems with it.
jgano23 is offline   Quote Quick Reply
Old 12-13-2009, 06:06 PM   #5
Jeeper
 
2002Apex's Avatar
 
Join Date: Jun 2007
Location: Birmingham
Posts: 277
have the same intake.. 2nd one to be exact. never had a problem. unclear to which plug your talking about?
__________________

If in FIRST you dont succeed, hit SECOND and gas it!
2002Apex is offline   Quote Quick Reply
Old 12-13-2009, 07:33 PM   #6
Jeeper
 
Timberman's Avatar
 
Join Date: Sep 2008
Location: Oregon
Posts: 431
Quote:
Originally Posted by omgwtfbbqcopter View Post
do you mean the plastic plug on top of the cone? If so, just glue it back in.
No, it is the plastic plug on the actual tube itself..
__________________
"Greatness is not achieved without taking risk."
Timberman is offline   Quote Quick Reply
Old 12-14-2009, 04:17 PM   #7
Jeeper
 
Timberman's Avatar
 
Join Date: Sep 2008
Location: Oregon
Posts: 431
UPDATE:
Well, I called AEM this morning and the lady was eager to send me out another plug no questions asked.. Cool Right? Well, I received a call a little later today and it was a gentleman who stated that since they have already sent me a replacement plug once before he was a bit concerned.. Since this hadn't happened before, he was concerned with the hole itself..

So, instead of sending me another plug, they are going to replace the entire tube just to make absolutely certain this doesn't happen again!

Its finally nice to report on a company which actually cares about their customers!!

HUGE KUDOS to my friends at AEM Power..

Guess which kind of intake I will be installing on my JK Unlimited when the time comes?? Yup, she will have an AEM even if they are way more money!
__________________
"Greatness is not achieved without taking risk."
Timberman is offline   Quote Quick Reply
Old 12-15-2009, 09:03 AM   #8
Jeeper
 
mrcarcrazy's Avatar
 
Join Date: Jul 2009
Location: Midland/Odessa, TX
Posts: 3,613
definitely glad to hear they stepped up to the plate on their own. impressive this day in age.

__________________
#2 Jeep http://www.wranglerforum.com/f322/99...ld-819418.html
99 Sahara, automatic.
mrcarcrazy is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wrangler Owners of Ohio XNeoJesterX Ohio Jeep Forum 254 03-04-2014 04:22 PM
2009 Owners Manual on-line whitebomber JK General Discussion Forum 2 07-10-2009 07:38 AM
For Gun Owners In California JCS05Rubi Off-Topic 1 04-28-2009 02:19 AM
1st time Jeep owners, are you enjoying it? texascc General Jeep Discussion 21 03-29-2009 07:56 AM
WF Bowl I (Fantasy Football) 1BLKJP Off-Topic 241 09-17-2007 06:39 PM



» Featured Product

All times are GMT -5. The time now is 05:05 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC