Can anyone tell me what this is?? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-12-2013, 08:56 AM   #1
Jeeper
 
Blsport7's Avatar
 
Join Date: Feb 2012
Posts: 404
Can anyone tell me what this is??

Was looking under the hood today cause I heard sparking, I assumed it was the plug wires.. But now I see this spring looking thing is broken off of whatever it is supposed to e attached too.. Any thoughts??!? It was hard to take I picture but hopefully they are clear enough.
Attached Thumbnails
Click image for larger version

Name:	image-3465632520.jpg
Views:	113
Size:	122.1 KB
ID:	208984   Click image for larger version

Name:	image-982923520.jpg
Views:	114
Size:	121.3 KB
ID:	208986  

Click image for larger version

Name:	image-2523876846.jpg
Views:	94
Size:	95.5 KB
ID:	208987  

Blsport7 is offline   Quote
Old 02-12-2013, 09:20 AM   #2
Jeeper

WF Supporting Member
 
Black Magic Brakes's Avatar
 
Join Date: May 2011
Posts: 2,313
Quote:
Originally Posted by Blsport7 View Post
Was looking under the hood today cause I heard sparking, I assumed it was the plug wires.. But now I see this spring looking thing is broken off of whatever it is supposed to e attached too.. Any thoughts??!? It was hard to take I picture but hopefully they are clear enough.
You have a manual transmission and that is the aux throttle return spring. It attaches with the hook to the 3rd hole away from the firewall on the bracket next to the throttle body that the throttle cable and cruise control cable snap into.

The gray clip on the other end snaps onto the last attachment point on the thottle body lever.

__________________
I am Savvy, I am the brake Wizard.
Black Magic Brakes is offline   Quote
Old 02-12-2013, 10:12 AM   #3
Jeeper
 
Steve305's Avatar
 
Join Date: Nov 2012
Location: Soddy Daisy, TN
Posts: 389
Quote:
Originally Posted by Blsport7 View Post
Was looking under the hood today cause I heard sparking, I assumed it was the plug wires.. .
The return spring is definitely not your "sparking" issue, although it does need to be re-installed properly. Better find out what's going on in your electrical system before you have a fire .......
__________________
Just plain 'ole Steve.
Steve305 is offline   Quote
Old 02-12-2013, 10:26 AM   #4
Jeeper
 
Blsport7's Avatar
 
Join Date: Feb 2012
Posts: 404
Thanks a lot guys I thought I heard sparking and getting it looked at asap, but should I be driving it with the broken return spring? Sorry I don't know a lot about it.
Blsport7 is offline   Quote
Old 02-12-2013, 11:53 AM   #5
Jeeper
 
Blsport7's Avatar
 
Join Date: Feb 2012
Posts: 404
Bump,

Also I can't seem to for a replacement spring anywhere online.. Any thoughts?
Blsport7 is offline   Quote
Old 02-12-2013, 11:58 AM   #6
aka Oscar@JeepsOnTrails
 
lee indy's Avatar
 
Join Date: May 2009
Location: Middle Georgia
Posts: 5,740
thell have springs you can match up at lowes or an auto parts store. just take the borken one and match up the length
__________________
My Build Thread
lee indy is offline   Quote
Old 02-12-2013, 12:08 PM   #7
Jeeper
 
Patrick H's Avatar
 
Join Date: Nov 2011
Location: Northern NM
Posts: 3,136
Mine didn't have a return spring. Bought a square furniture plug that fit in the empty auto trans TV cable bracket, a threaded eye bolt, and a carb return spring. I used a nylon lock nut on the eye bolt so I can adjust the tension if I desire.
Attached Thumbnails
Click image for larger version

Name:	ForumRunner_20130212_110618.jpg
Views:	72
Size:	214.0 KB
ID:	209048  
Patrick H is offline   Quote
Old 02-12-2013, 12:12 PM   #8
Jeeper
 
Blsport7's Avatar
 
Join Date: Feb 2012
Posts: 404
Stupid question...... What exactly does it do? If it runs fine without one what purpose does it serve? Still going to replace it because it would drive me insane now knowing its supposed to be there.. But just curious.
Blsport7 is offline   Quote
Old 02-12-2013, 12:16 PM   #9
Jeeper
 
Patrick H's Avatar
 
Join Date: Nov 2011
Location: Northern NM
Posts: 3,136
Quote:
Originally Posted by Blsport7
Stupid question...... What exactly does it do? If it runs fine without one what purpose does it serve? Still going to replace it because it would drive me insane now knowing its supposed to be there.. But just curious.
My throttle was way too light. It was tough to maintain steady throttle in rough rocky sections
Patrick H is offline   Quote
Old 02-12-2013, 12:18 PM   #10
Jeeper
 
Blsport7's Avatar
 
Join Date: Feb 2012
Posts: 404
Gotcha. Thanks!
Blsport7 is offline   Quote
Old 02-12-2013, 12:20 PM   #11
Jeeper
 
TJspeed's Avatar
 
Join Date: Feb 2011
Location: New Mexico
Posts: 3,504
Quote:
Originally Posted by Patrick H View Post
My throttle was way too light. It was tough to maintain steady throttle in rough rocky sections
what did you do to fix it? Mine drives me up the wall.
__________________
2000 solar yellow 4.0 sport 3" BDS, 1.25" JKS body lift, 1" Zone motor lift, JKS quicker disconnects, 33x10.5 BFG KM2 on black american racing wheels. D44 rear.

TJspeed is online now   Quote
Old 02-12-2013, 12:22 PM   #12
Jeeper
 
Patrick H's Avatar
 
Join Date: Nov 2011
Location: Northern NM
Posts: 3,136
Quote:
Originally Posted by TJspeed

what did you do to fix it? Mine drives me up the wall.
Did you not read my post or see my pic?
Patrick H is offline   Quote
Old 02-12-2013, 12:24 PM   #13
Jeeper
 
TJspeed's Avatar
 
Join Date: Feb 2011
Location: New Mexico
Posts: 3,504
Quote:
Originally Posted by Patrick H View Post
Did you not read my post or see my pic?
oops!
__________________
2000 solar yellow 4.0 sport 3" BDS, 1.25" JKS body lift, 1" Zone motor lift, JKS quicker disconnects, 33x10.5 BFG KM2 on black american racing wheels. D44 rear.

TJspeed is online now   Quote
Old 02-12-2013, 12:25 PM   #14
Jeeper
 
Patrick H's Avatar
 
Join Date: Nov 2011
Location: Northern NM
Posts: 3,136
Quote:
Originally Posted by TJspeed

oops!
I did that the day after our Guaje Canyon run.
Patrick H is offline   Quote
Old 02-12-2013, 12:35 PM   #15
Jeeper
 
TJspeed's Avatar
 
Join Date: Feb 2011
Location: New Mexico
Posts: 3,504
Quote:
Originally Posted by Patrick H View Post
I did that the day after our Guaje Canyon run.
I knew you did, I just didnt know what you did exactly.
__________________
2000 solar yellow 4.0 sport 3" BDS, 1.25" JKS body lift, 1" Zone motor lift, JKS quicker disconnects, 33x10.5 BFG KM2 on black american racing wheels. D44 rear.

TJspeed is online now   Quote
Old 02-12-2013, 02:20 PM   #16
Jeeper
 
Blsport7's Avatar
 
Join Date: Feb 2012
Posts: 404
So... I replaced it, I don't see any difference In my throttle at all, but oh well at least its there.. Thanks for the help everyone, and as far as that "sparking noise" it has disappeared.. So idk what that was all about. Thanks again.
Blsport7 is offline   Quote
Old 02-12-2013, 02:21 PM   #17
Jeeper

WF Supporting Member
 
Black Magic Brakes's Avatar
 
Join Date: May 2011
Posts: 2,313
Quote:
Originally Posted by Blsport7 View Post
Bump,

Also I can't seem to for a replacement spring anywhere online.. Any thoughts?
I thought that picture was of yours, is the clip broken?

No matter, I have several if you need one.
__________________
I am Savvy, I am the brake Wizard.
Black Magic Brakes is offline   Quote
Old 02-12-2013, 02:40 PM   #18
Jeeper
 
Blsport7's Avatar
 
Join Date: Feb 2012
Posts: 404
Quote:
Originally Posted by Black Magic Brakes

I thought that picture was of yours, is the clip broken?

No matter, I have several if you need one.
The pictures I posted was mine. Of the broken one... I just went to autozone after work and found one... Not the exact coil size though

Blsport7 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:54 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC