Can't unhook electric connection to hard top - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-27-2012, 05:57 PM   #1
Jeeper
 
DeeJaysTJ's Avatar
 
Join Date: Aug 2012
Location: Isla Vista, CA
Posts: 47
Can't unhook electric connection to hard top

Went to take my hard top off the other day and I couldn't get the electric connection unplugged. Only had the Jeep for about a month and the last time I took the top off my brother undid the electrical connection and didn't have a problem. Read the owners manual and pushed down on the tab and it would not budge.

Summers great here in Santa Barbara, need to get the top off.

Thanks

DeeJaysTJ is offline   Quote
Old 08-27-2012, 06:28 PM   #2
Jeeper
 
Wildkarde's Avatar
 
Join Date: Jun 2010
Location: In the mountains
Posts: 327
Mine was real tight the first time I tried to unplug it, took way more ompf than i thought it would to get it apart. Since then, when i plug it back in i don't push it on far enough to snap. Never had another issue with it.

__________________
"Time you enjoy wasting, was not wasted"- John Lennon

"The Jeep is a manly device. And a womanly device. An American device. Its a fitting instrument to transport the free people of a free nation with the respect to which we are entitled and the dignity that we deserve. Okay, were a little crazy to have a Jeep for a daily driver. But if we go off our meds, we might wind up in a Prius"-P.J.O'rourke
Wildkarde is offline   Quote
Old 08-27-2012, 06:37 PM   #3
Jeeper
 
DeeJaysTJ's Avatar
 
Join Date: Aug 2012
Location: Isla Vista, CA
Posts: 47
Thanks, I gave it a few good tugs but the housing started to pull away from the hard top so I gave up... I'll give it another go and see how it goes from there.
DeeJaysTJ is offline   Quote
Old 08-27-2012, 07:50 PM   #4
Jeeper
 
Wildkarde's Avatar
 
Join Date: Jun 2010
Location: In the mountains
Posts: 327
can always try wd-40, might give it enough lube to slide off, and it's ok for electrical connections
__________________
"Time you enjoy wasting, was not wasted"- John Lennon

"The Jeep is a manly device. And a womanly device. An American device. Its a fitting instrument to transport the free people of a free nation with the respect to which we are entitled and the dignity that we deserve. Okay, were a little crazy to have a Jeep for a daily driver. But if we go off our meds, we might wind up in a Prius"-P.J.O'rourke
Wildkarde is offline   Quote
Old 08-27-2012, 08:13 PM   #5
Jeeper
 
Jeffreybomb's Avatar
 
Join Date: Jul 2011
Location: Chicago
Posts: 819
Images: 3
I had the same problem with my '04, probably because it was the first time the hard top was coming off.

Try pushing the plugs in on each other a tiny bit further. Your goal is to relieve the stress on the latch where it catches the hook. Then, gently push up on the latch. If you need to, try using a stubby flat head screwdriver, applying gradual pressure for a few seconds.

After that, try pulling the plugs apart with two slip joint pliers. Give just enough force on the pliers so you can get a firm grip on the plugs without feeling like you're going to crack them under the pressure.

It may help to repeat the process a couple times to loosen up the connection.

If it's totally screwed, you could always order another wiring set. Those tend to be kind of expensive, though.
__________________
This thread needs more ninjas. Ninjas and explosions.
Jeffreybomb is offline   Quote
Old 08-30-2012, 03:04 PM   #6
Jeeper
 
DeeJaysTJ's Avatar
 
Join Date: Aug 2012
Location: Isla Vista, CA
Posts: 47
Got it off today! Thanks for the help. Some wd-40 and working with it for a while got it unplugged.

Click image for larger version

Name:	image-2678510482.jpg
Views:	65
Size:	108.0 KB
ID:	155458

DeeJaysTJ is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 12:00 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC