Check engine light! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-04-2012, 12:12 AM   #1
Jeeper
 
BigGreenMachine's Avatar
 
Join Date: May 2012
Location: Englewood, CO
Posts: 921
Check engine light!

So long story short my check engine light came on. I gave the code for tps high voltage. I replaced it 4 times last two times with OEM. After the 4th time it finally started driving right. This was about 3 months ago. I never could get the CEL to go away. Driving down the road today it was gone. What gives? Anybody ever had their CEL go away randomly?

BigGreenMachine is offline   Quote
Old 09-04-2012, 12:43 AM   #2
Jeeper
 
Buz 1's Avatar
 
Join Date: Sep 2011
Location: Beaverdam, Ohio
Posts: 218
after 3 or so correct starts the pcm resets the cel. never had the luck though..

__________________
'97 TJ, 2.5L 5sp


Buz 1 is offline   Quote
Old 09-04-2012, 01:10 AM   #3
Jeeper
 
BigGreenMachine's Avatar
 
Join Date: May 2012
Location: Englewood, CO
Posts: 921
What do you mean correct starts? I tried clearing the code with a scanner, resetting the PCM and everything. I then gave up and months later it went away on its own.
BigGreenMachine is offline   Quote
Old 09-04-2012, 02:23 AM   #4
Jeeper
 
SeVeReDiStOrTiOn's Avatar
 
Join Date: May 2012
Location: CA
Posts: 768
I read somewhere that a bad clock spring can cause that code. For the code Buz is right, after several drive cycles if the code doesn't get re-tripped the light will go off but the code is still stored. You can clear the code completely with a scanner or doing the battery disconnect thing.
SeVeReDiStOrTiOn is offline   Quote
Old 09-04-2012, 02:45 AM   #5
Jeeper
 
BigGreenMachine's Avatar
 
Join Date: May 2012
Location: Englewood, CO
Posts: 921
Quote:
Originally Posted by SeVeReDiStOrTiOn
I read somewhere that a bad clock spring can cause that code. For the code Buz is right, after several drive cycles if the code doesn't get re-tripped the light will go off but the code is still stored. You can clear the code completely with a scanner or doing the battery disconnect thing.
I did battery and scanner multiple times, nothing.
BigGreenMachine is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:50 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC