Check Guage Lights Coming On - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-25-2012, 09:06 AM   #1
Jeeper
 
Capt TJ's Avatar
 
Join Date: Dec 2011
Location: Dubai
Posts: 28
Check Guage Lights Coming On

Hi fellas,

I was driving around for sometime and suddenly saw the check guage lights coming on. I also noticed that the temp guage was a little higher than usual. I had run the jeep only for about 20 mins or so. Also the oil pressure guage was also acting a little funny. Any thoughts?

Capt TJ is offline   Quote
Old 03-25-2012, 09:24 AM   #2
Newb
 
MarkTJ97's Avatar
 
Join Date: Mar 2012
Location: Southern Maryland originally NC
Posts: 12
Check gauges light

Hey Capt TJ,
I have had this problem too with my 97. There are lots of threads on this but the most common fix is to change the oil pressure sending unit. Its a cheap part like $25. If that doesn't work it might be smart to verify that you don't really have a problem with oil pressure. Get a pressure test gauge and connect it where the sending unit hooks up( just above the oil filter) see if this pressure matches the gauge indication. The early TJs have a "true" reading pressure gauge, not a dummy gauge as found in newer models. It may be normal to see it fluctuate quite a bit under different engine loads.
Also, the auto parts store didnt have a tester so I bought a cheap sunpro gauge and hooked it up temporarily to check mine. Worked great and will serve as my test set. Good luck with yours,
-Mark

MarkTJ97 is offline   Quote
Old 03-25-2012, 09:30 AM   #3
Jeeper
 
Capt TJ's Avatar
 
Join Date: Dec 2011
Location: Dubai
Posts: 28
Thnx Mark.. Will try this suggestion.
Capt TJ is offline   Quote
Old 03-26-2012, 08:37 AM   #4
Jeeper
 
Capt TJ's Avatar
 
Join Date: Dec 2011
Location: Dubai
Posts: 28
I have also noticed, when at a traffic signal, the lights on the gauge come on. But as soon as i accelerate the gauge shows me the correct reading and the light goes off. Next signal or at idle same thing happens. Accelerate again and lights go off.

I have also checked my oil level. OK.
Capt TJ is offline   Quote
Old 03-26-2012, 08:54 AM   #5
Jeeper
 
LULU05's Avatar
 
Join Date: Feb 2012
Posts: 128
Quote:
Originally Posted by Capt TJ
I have also noticed, when at a traffic signal, the lights on the gauge come on. But as soon as i accelerate the gauge shows me the correct reading and the light goes off. Next signal or at idle same thing happens. Accelerate again and lights go off.

I have also checked my oil level. OK.
I have an 05 TJ and am having the same problem. I changed the sending switch (dealer bought), changed oil and filter. I noticed the pressure is fine until she heats up to around 200 and the when the rpm's drop when slowing or at a stop the check gauges light come on and pressure drops to 0. I also notice that around 2500 rpm's there is a noticeable diesel like noise as well
LULU05 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Decisions, Decisions.... Does 305/70R17 on AEV Pintlers extend past fender? tiger3 Tires & Wheels 10 12-23-2013 06:47 PM
Surprise Straps... Definitely a company to check out! mattdenney07 JK General Discussion Forum 30 09-09-2012 01:20 AM
Signing on ArmyMPFromMO WF New Member Check In 10 03-29-2012 12:28 PM
back up lights dont work vincent13 TJ General Discussion Forum 3 03-25-2012 03:55 PM
back up lights wont work vincent13 Communications and Electronics 1 03-25-2012 10:47 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:48 PM.



Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC