Check Guages Light - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-22-2011, 09:56 AM   #1
Newb
 
Join Date: Jun 2011
Posts: 2
Unhappy Check Guages Light

Hi everyone!
Okay I am a new Jeep owner and new to the forum. I need some input of an issue I am having with my 2004 Jeep Wrangler with 34K miles on it. I only take it out on the weekend or use while my other vehicle is getting serviced. Well, the other day while driving the radio made a loud pop turned off then came back on and the check guages light came on. It did not see like I lost any power and all the guages seemed to be within "normal" range and within a few minutes the check guages light went off. Can anyone make any suggestions on what I should check first?

ticketmuffin is offline   Quote Quick Reply
Old 06-22-2011, 10:33 AM   #2
Jeeper

WF Supporting Member
 
jk'n's Avatar
 
Join Date: Jan 2009
Location: First Quadrant in the Land of the Free
Posts: 4,790
If you have a 2004 you should have posted this in the TJ forum to get a better response. I'll see if I can get them to move it over there.

__________________

Participate in life....Keep movin'....Go there....JK'n it.........Do it! Jeep #1: Red Rock 08 JK Rubicon 4dr, 6 sp manual, Stock Mud Tires, MyGIG Upgrade, Hard Top, after sale BestTop SunRider Soft Top, Congo Cage Rack, Mopar slush mats Jeep #2 Black 08 JK Rubicon 2dr, 6 sp manual, both tops, some chrome...uggg (my wife's jeep) Jeep #3 White 92 YJ (my son's jeep) A great quote from a good friend: "All hail click clack and master jk'n." Click and clack are my idols!
jk'n is offline   Quote Quick Reply
Old 06-22-2011, 10:42 AM   #3
Jeeper

WF Supporting Member
 
jk'n's Avatar
 
Join Date: Jan 2009
Location: First Quadrant in the Land of the Free
Posts: 4,790
There you go, darn they are quick!
__________________

Participate in life....Keep movin'....Go there....JK'n it.........Do it! Jeep #1: Red Rock 08 JK Rubicon 4dr, 6 sp manual, Stock Mud Tires, MyGIG Upgrade, Hard Top, after sale BestTop SunRider Soft Top, Congo Cage Rack, Mopar slush mats Jeep #2 Black 08 JK Rubicon 2dr, 6 sp manual, both tops, some chrome...uggg (my wife's jeep) Jeep #3 White 92 YJ (my son's jeep) A great quote from a good friend: "All hail click clack and master jk'n." Click and clack are my idols!
jk'n is offline   Quote Quick Reply
Old 06-22-2011, 10:46 AM   #4
Jeeper

WF Supporting Member
 
jk'n's Avatar
 
Join Date: Jan 2009
Location: First Quadrant in the Land of the Free
Posts: 4,790
BTW, welcome to Wrangler Forum.

This is a great place to learn about your jeep.

Very friendly and the moderators help to keep it that way.

Lots of helpful people and a fun place to hang out.

Don't forget to wave to other jeepers.

It's a tradition.

Good luck with your electrical glitch. Hope it is nothing. If it persists, I would start with checking for loose wiring, possibly a ground.
__________________

Participate in life....Keep movin'....Go there....JK'n it.........Do it! Jeep #1: Red Rock 08 JK Rubicon 4dr, 6 sp manual, Stock Mud Tires, MyGIG Upgrade, Hard Top, after sale BestTop SunRider Soft Top, Congo Cage Rack, Mopar slush mats Jeep #2 Black 08 JK Rubicon 2dr, 6 sp manual, both tops, some chrome...uggg (my wife's jeep) Jeep #3 White 92 YJ (my son's jeep) A great quote from a good friend: "All hail click clack and master jk'n." Click and clack are my idols!
jk'n is offline   Quote Quick Reply
Old 06-22-2011, 11:14 AM   #5
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 35,802
Seems electrical (obviously) did you loose total power? I know when you start the jeep the CEL comes on and then turns off. Check the battery connection for corrosion and make sure it's tight.
kjeeper10 is offline   Quote Quick Reply
Old 06-22-2011, 11:45 AM   #6
Newb
 
Join Date: Jun 2011
Posts: 2
The only thing that lost power was the radio, everything else seemed to be fine. The radio came back on and CEL went off. I am going to have someone check the connections later. This is the second time that happened within the week.

ticketmuffin is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Decoding Check Engine Light Gumpy2030 TJ General Discussion Forum 17 03-09-2011 10:46 PM
check engine, and check guages, and a bunch of codes ellman605 TJ Tech Forum 1 12-13-2010 10:37 AM
Check gauge light sedty TJ Tech Forum 4 03-04-2010 03:05 PM
fog light question... Jaydogg25 YJ General Discussion Forum 17 08-05-2009 03:49 PM
Check Engine Light vin211 TJ Tech Forum 4 04-07-2008 09:12 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 11:58 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC