Climate Control Lights - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-10-2011, 06:43 PM   #1
Newb
 
tr250's Avatar
 
Join Date: Dec 2010
Posts: 5
Climate Control Lights

So, I'm patting myself on the back for swapping out the faulty blower switch. I put it all back together and I'm loving the heat on all 4 speeds! Then I turn the lights on a couple days later. I have no climate control lights on my 2000 TJ? I figured it was easy enough to pull the bits back out of the center panel, so I got home from work & popped the center cover off & pulled the control out along with the knobs. Then I pop the front cover loose. As it's coming off, one of the lights magically goes on. OK, so I firmly seat the cover again and poof...out goes the light?? Only one was working so I'm scratching my head. I move the working light to a non-working light location and now nothing? Has anyone experienced a bad board inside the climate control box? Not much too it, but there is a ribbon board in there. Maybe I just had really bad timing and blew 2 of the 3 bulbs when I swapped the switch? This is puzzling my puzzler??

tr250 is offline   Quote Quick Reply
Old 01-10-2011, 06:47 PM   #2
Jeeper

WF Supporting Member
 
DerekM's Avatar
 
Join Date: Mar 2010
Location: Orem, Utah
Posts: 450
I have the exact same issue and have yet to figure it out. I've messed with it a few times and even got all new bulbs and still I have nothing. I wish someone knew the answer.

__________________
2001 TJ, 4.5" RE, 1" BL, 35" KM2. Black is good.
/l ,[____],
l---L -OlllllllO-
()_)-()_)-o-)_)
DerekM is offline   Quote Quick Reply
Old 01-10-2011, 06:49 PM   #3
Jeeper
 
jasonwrangler's Avatar
 
Join Date: Oct 2010
Location: Omaha, NE
Posts: 892
mine bulbs were totally blown, just get new ones from autozone and make sure you have a good connection.
jasonwrangler is offline   Quote Quick Reply
Old 01-11-2011, 04:34 AM   #4
Yipeee Kay Ayyy

WF Supporting Member
 
Wesboy's Avatar
 
Join Date: Feb 2010
Posts: 2,108
I have a '97 and sometimes my climate control lights come on straight away, but usually not. To get them to work I turn the fan on and off 2 or 3 times and the lights come on.
Weird.
Wesboy is offline   Quote Quick Reply
Old 01-11-2011, 05:28 AM   #5
Jeeper
 
robbiecc's Avatar
 
Join Date: Sep 2010
Posts: 771
my prob a little different but also weird. with the fan on 1, 2 or 3 my r/wiper and defrost lights are on, turn fan to 4 and off they go. took a while to figure the pattern, just thought they came on when they felt like it. climate control lights sofar are fine.
robbiecc is offline   Quote Quick Reply
Old 01-11-2011, 10:52 AM   #6
Jeeper
 
Join Date: Oct 2010
Location: MO
Posts: 62
Images: 2
I have the same problem with my 97. Have to tap on it a few times to get the lights to work
cedarcreekjerky is offline   Quote Quick Reply
Old 01-11-2011, 11:12 AM   #7
Jeeper
 
Mike_3303's Avatar
 
Join Date: Dec 2010
Location: Illinois
Posts: 551
Check to make sure the wires are not lose and if they have a ground wire that they are secure as well. You could always move the wires around untill they come on and then tape them in place so they stay on.
Mike_3303 is offline   Quote Quick Reply
Old 01-11-2011, 03:19 PM   #8
Lifetime Member

WF Lifetime Member
 
ezjeeper's Avatar
 
Join Date: Sep 2006
Location: Las Vegas, Nevada
Posts: 56
Send a message via Yahoo to ezjeeper
Quote:
Originally Posted by tr250 View Post
So, I'm patting myself on the back for swapping out the faulty blower switch. I put it all back together and I'm loving the heat on all 4 speeds! Then I turn the lights on a couple days later. I have no climate control lights on my 2000 TJ? I figured it was easy enough to pull the bits back out of the center panel, so I got home from work & popped the center cover off & pulled the control out along with the knobs. Then I pop the front cover loose. As it's coming off, one of the lights magically goes on. OK, so I firmly seat the cover again and poof...out goes the light?? Only one was working so I'm scratching my head. I move the working light to a non-working light location and now nothing? Has anyone experienced a bad board inside the climate control box? Not much too it, but there is a ribbon board in there. Maybe I just had really bad timing and blew 2 of the 3 bulbs when I swapped the switch? This is puzzling my puzzler??
What was wrong with the blower switch? The switch on my system that tells the air where to go (floor, dash, window, etc) is not working. The temperature does, the fan does. Dealer says the switch can't be fixed, the unit has to be rebuilt and the parts are on nationwide indefinite back order. No update on when it will be available. He knows an aftermarket provider, but I am waiting a month or two for weather to clear. Once the top comes off, I won't care about the HVAC and they can send it off for rebuild.
__________________
99 TJ Sahara - Black - Mods to come! Previous Jeeps - 95YJ and a 00XJ
Militaryjeepers.com

ezjeeper is offline   Quote Quick Reply
Old 01-11-2011, 03:27 PM   #9
Jeeper

WF Supporting Member
 
DerekM's Avatar
 
Join Date: Mar 2010
Location: Orem, Utah
Posts: 450
That is a very common issue. The switch gets too hot and melts the plastic. There is a write up on JPmags site that shows how to fix it. It's confusing and I had to have some help to do it.
__________________
2001 TJ, 4.5" RE, 1" BL, 35" KM2. Black is good.
/l ,[____],
l---L -OlllllllO-
()_)-()_)-o-)_)
DerekM is offline   Quote Quick Reply
Old 01-11-2011, 05:05 PM   #10
Jeeper
 
79Scout's Avatar
 
Join Date: Jan 2011
Location: Janesville, Wisconsin
Posts: 117
I found this link VERY helpful with all of the issues listed above:

http://www.wranglerforum.com/f5/writ...fix-52716.html

chop110 did a very thorough, great job on the write-up.
79Scout is offline   Quote Quick Reply
Old 01-11-2011, 08:25 PM   #11
Jeeper
 
Join Date: Jul 2009
Location: NE Wyoming
Posts: 331
ezjeeper, have you checked any local salvage yards or the internet? I have no idea, but would a unit from a Dakota work?
Wyominer is offline   Quote Quick Reply
Old 01-12-2011, 08:59 AM   #12
Newb
 
tr250's Avatar
 
Join Date: Dec 2010
Posts: 5
Quote:
Originally Posted by ezjeeper

What was wrong with the blower switch? The switch on my system that tells the air where to go (floor, dash, window, etc) is not working. The temperature does, the fan does. Dealer says the switch can't be fixed, the unit has to be rebuilt and the parts are on nationwide indefinite back order. No update on when it will be available. He knows an aftermarket provider, but I am waiting a month or two for weather to clear. Once the top comes off, I won't care about the HVAC and they can send it off for rebuild.
Yeah I could tell something got hot behind there. The DPO told me he replaced the blower and the resistor pack and got 1 speed back. I deduced that it had to be a bad switch as I only had the low speed

Anyway when I get a chance I'll put a meter on the connection points and the bulbs...see whats what?

Regards

Todd
2000 TJ
tr250 is offline   Quote Quick Reply
Old 01-12-2011, 09:09 AM   #13
Jeeper

WF Supporting Member
 
DerekM's Avatar
 
Join Date: Mar 2010
Location: Orem, Utah
Posts: 450
Please let us know what you find!
__________________
2001 TJ, 4.5" RE, 1" BL, 35" KM2. Black is good.
/l ,[____],
l---L -OlllllllO-
()_)-()_)-o-)_)
DerekM is offline   Quote Quick Reply
Old 02-01-2011, 10:46 AM   #14
Newb
 
tr250's Avatar
 
Join Date: Dec 2010
Posts: 5
Well so far I've verified that I have roughly 11.78 volts at each light location. Oddly enough when I pulled the control box away from the dash one of the lights came on?? Did all the testing that I knew to do and have to conclude it's some combination of bad bulbs and/or worn connecting points. Since I didn't have any new bulbs I buttoned it back up with 1 working bulb which worked for about a day. Guess I can try a battery charger on each light? I'll keep at it and report back

Todd
tr250 is offline   Quote Quick Reply
Old 02-01-2011, 12:36 PM   #15
Jeeper
 
zpratt4's Avatar
 
Join Date: Sep 2007
Location: Knoxville, TN
Posts: 257
I had the same problem after I replaced the switch for the fan speeds. The light behind the fan speed knob did not light up. I just bought new bulbs from autoillumination.com and replaced it and now it works. I think I read that you already tried replacing the bulb (can't remember). Is there any chance you got the wrong bulb? It is supposed to be the neo-wedge type B bulb. Sorry if this doesn't help. Hope you get it figured out.

Here is a link. They are about half way down.
http://autolumination.com/74.htm

__________________
GO VOLS!
zpratt4 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C / Climate Control Replacement Knobs - Where to get them?? AggieChris TJ General Discussion Forum 11 05-26-2011 11:48 PM
Climate control speed knob WSU Tony TJ Tech Forum 26 09-26-2010 03:41 PM
LED Tail lights. Vroooom TJ General Discussion Forum 3 09-19-2010 10:39 PM
Climate control bulbs? bridge TJ Tech Forum 5 03-29-2009 05:13 AM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 01:36 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:10 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC