clutch issues still... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-03-2013, 02:37 PM   #1
Jeeper
 
Jeepinjason's Avatar
 
Join Date: Oct 2012
Location: Colorado Springs
Posts: 89
Images: 19
clutch issues still...

Put new master and slave cylinder in for clutch in my 97 4.0 and trying to bleed the line... getting nothing... the level isn't dropping and pressure is still non existent... help please

Jeepinjason is offline   Quote
Old 10-03-2013, 02:59 PM   #2
Jeeper
 
C.L.'s Avatar
 
Join Date: Mar 2011
Location: North NJ
Posts: 2,198
Is the slave rod maybe missing the fork? That will give you zero pressure pretty easily. Can you confirm that the clutch is engaged? i.e. Jeep will NOT roll when left in gear, whether clutch pedal is pressed or not? It may also be possible that the clutch disk is hung up on the pilot shaft with the pressure plate at full compression. That would make the pedal feel very light even if it was properly bled and working.
C.L. is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:01 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC