crackle in speakers after new radio - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-22-2013, 09:09 AM   #1
Jeeper
 
jeeps4u2nv88's Avatar
 
Join Date: May 2012
Location: Lake Orion, MI
Posts: 118
Question crackle in speakers after new radio

So I bought a new Kenwood KDC-255U radio for my 97 TJ. I installed it last night, and after a headache of set backs I finally got everything hooked up and connected. I turned the radio on and everything worked. I turned up the volume and it was crystal clear until I got to mid to high volume. Then the sounds started to crack and became very unclear. This Kenwood replaced the original stock radio. Anyone have some ideas of why this would happen? I messed around with the connections and nothing made it better. I tried it with my iPhone connected with a AUX cable and the same crackle came through the speakers. The last thing I noticed was that when the radio was on and playing music the systems back lighting would flicker when the music was turned up. I have a feeling it's a faulty resistor or something of that nature in the new radio. I'm not an expert though. Any ideas??

jeeps4u2nv88 is offline   Quote Quick Reply
Old 05-22-2013, 09:20 AM   #2
Jeeper
 
Plowboy1970's Avatar
 
Join Date: Nov 2010
Location: Burlington WI
Posts: 1,187
You need new speakers.

Plowboy1970 is offline   Quote Quick Reply
Old 05-22-2013, 09:28 AM   #3
Jeeper
 
jeeps4u2nv88's Avatar
 
Join Date: May 2012
Location: Lake Orion, MI
Posts: 118
That's what I thought at first but my speakers didn't do that before I replaced the radio. There was no crackle in the speakers with the original radio which I was listening to a few hours before I replaced the radio yesterday.
jeeps4u2nv88 is offline   Quote Quick Reply
Old 05-22-2013, 10:03 AM   #4
Jeeper
 
Wattapunk's Avatar
 
Join Date: Mar 2012
Location: North TX
Posts: 1,745
x2 on the speakers. The Kenwood has a higher speaker output (50wx4 peak) than your stock radio. It's too much for the factory speakers to handle when you are increasing the volume, hence the distortion.
Wattapunk is offline   Quote Quick Reply
Old 05-22-2013, 10:39 AM   #5
Jeeper
 
jeeps4u2nv88's Avatar
 
Join Date: May 2012
Location: Lake Orion, MI
Posts: 118
I know the speakers in the dash are updated. The PO replaced them with Panasonic's. I'm not sure of the sound bar speakers though. The sound bar is aftermarket and make the same noise but I'm not sure what the specs on those speakers are.
jeeps4u2nv88 is offline   Quote Quick Reply
Old 05-22-2013, 10:48 AM   #6
Jeeper
 
Join Date: Dec 2012
Posts: 2,631
I have a similar issue, where the PO replaced the stock radio in my TJ with a Sony Xplod deck instead (which would of been on the list of things to change but he beat me to it) and when I increase the volume, it crackles abit BUT I adjusted for the factors by playing with the EQ settings and it seems to have brought that crackle problem to a minimum/non-existant song depending of course. PS I don't crank my volume for the record.
RevCo666 is offline   Quote Quick Reply
Old 05-22-2013, 11:16 AM   #7
Jeeper
 
free78's Avatar
 
Join Date: May 2011
Location: Seminole, Florida
Posts: 238
Replaced mine last night with the same kenwood deck. Still trying to get use to it but I like it so far. It sounds like your speakers. The stock radio just didnt have enough power to hear it before. Like mentioned, try adjusting your equalizer and see if that helps. Replacements speakers wouldn't cost to much to go ahead and replace.
What setbacks did you have installing?
__________________
1997 TJ
2011 Liberty
free78 is offline   Quote Quick Reply
Old 05-22-2013, 12:18 PM   #8
Jeeper
 
jeeps4u2nv88's Avatar
 
Join Date: May 2012
Location: Lake Orion, MI
Posts: 118
Rev, I don't crank my volume either. Just enough to hear it when going down the road with road noise and wind. I played with the EQ settings and it helped a little but not enought to eliminate/ resolve the problem.

Free, I love the deck! looks great, has all the options I want on it for a reasonable price. The thing I don't get is why would the lights and display on the radio dim when the volume of the song/voices increase during emphasis. Some of the set backs were stupid mistakes on my part. having to redo a few steps and running out to get more conectors for the wires. The mounting plate gave me the most problems becasue I thought I had the wrong one and had to run back to Bestbuy to find out I didn't have the wrong one. It was a long night.
jeeps4u2nv88 is offline   Quote Quick Reply
Old 05-22-2013, 12:25 PM   #9
Jeeper
 
free78's Avatar
 
Join Date: May 2011
Location: Seminole, Florida
Posts: 238
Ok I missed the dimming lights part the first time. How did you hook it up? What wires are connected to what wires (colors)?
__________________
1997 TJ
2011 Liberty
free78 is offline   Quote Quick Reply
Old 05-22-2013, 01:52 PM   #10
Jeeper
 
jeeps4u2nv88's Avatar
 
Join Date: May 2012
Location: Lake Orion, MI
Posts: 118
I would have to look again. I know I went off of what was in the book that came with the radio. I also double checked the factory wires by googling what each wire was for. I think I have everything right since everything thing works and produces sound in the right speakers. The only thing wrong is the sound at a certain level and above.
jeeps4u2nv88 is offline   Quote Quick Reply
Old 05-22-2013, 01:58 PM   #11
Jeeper
 
free78's Avatar
 
Join Date: May 2011
Location: Seminole, Florida
Posts: 238
How many wires did you have not connected to anything?
__________________
1997 TJ
2011 Liberty
free78 is offline   Quote Quick Reply
Old 05-22-2013, 02:08 PM   #12
Jeeper
 
jeeps4u2nv88's Avatar
 
Join Date: May 2012
Location: Lake Orion, MI
Posts: 118
coming out of the radio I think it was 3. The three that are folded over on themselves with tape calling out what they are. 2 or 3 coming out of the factory harness. I can't remember exactly without looking at it.
jeeps4u2nv88 is offline   Quote Quick Reply
Old 05-22-2013, 02:52 PM   #13
Jeeper
 
Virus692's Avatar
 
Join Date: Oct 2012
Location: Maine
Posts: 534
Send a message via AIM to Virus692 Send a message via Yahoo to Virus692
you have a grounding issue with the radio... did you tape wires together or tape the one at a time? you may need some who knows what they are doing look at this before it causes more issues.
Virus692 is offline   Quote Quick Reply
Old 05-22-2013, 03:00 PM   #14
Jeeper
 
jeeps4u2nv88's Avatar
 
Join Date: May 2012
Location: Lake Orion, MI
Posts: 118
I used the ground strap that was on the back of the original radio (since that was the radio I replaced). Do you know of any better place I could use for a ground rather than using the ground strap?
jeeps4u2nv88 is offline   Quote Quick Reply
Old 05-23-2013, 07:18 AM   #15
Jeeper
 
jeeps4u2nv88's Avatar
 
Join Date: May 2012
Location: Lake Orion, MI
Posts: 118
Thumbs up

So I fixed my problem last night. I stopped by Best buy where I bought the new unit and the car tech took a look at what I explained earlier and he said it was defiantly a short of some sort. So I checked all my connections behind the radio and the front connections were fine, but when I connected my sound bar the sound would become all crackled again. This told me that the short was due to my wiring to my sound bar. I pulled the wires for the sound bar and found that the PO wired the front speakers with the rear speakers. In other words the front speakers were wired correctly and the rear speakers were wired correctly but the PO spliced wires together to connect the front and rear speakers. Once I disconnected these spliced wires everything worked perfect. Just another case of bad wiring. Thanks everyone for the help!
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	32
Size:	221.3 KB
ID:	252580  
jeeps4u2nv88 is offline   Quote Quick Reply
Old 05-23-2013, 07:20 AM   #16
Jeeper
 
jeeps4u2nv88's Avatar
 
Join Date: May 2012
Location: Lake Orion, MI
Posts: 118
Oh and the blue and red wires coming out of the dash are for my fog lights. I'm waiting for a switch to install.
jeeps4u2nv88 is offline   Quote Quick Reply
Old 05-23-2013, 08:10 AM   #17
Jeeper
 
Bielzebub's Avatar
 
Join Date: Jun 2012
Location: Jefferson City, MO
Posts: 144
So which speakers are the soundbar supposed to be hooked up to, front or rear? My PO removed the sound bar and jerry-rigged some panasonic pods in the back (zip tied to the roll cage bar). I am going to be building a new soundbar since I don't want to spend $200 on one and I can fit it for whatever speakers I want. Thanks!
__________________
Jeep. There's a reason the Postal Service has been using them for over 50 years!
Bielzebub is offline   Quote Quick Reply
Old 05-23-2013, 08:30 AM   #18
Jeeper
 
jeeps4u2nv88's Avatar
 
Join Date: May 2012
Location: Lake Orion, MI
Posts: 118
The sound bar is hooked up to be the rear speakers. What year is your jeep? because mine is a 1998 TJ and the sound bar harness is right under neath the dash on the drivers side behind the Connector to read codes. (I don't know what its called) So my dash speakers are my front speakers and my speaker bar speakers are my rear speakers. The wires for my roll bar runs along the floor to the roll bar behind the drivers seat and then up to the speaker bar. Mine is zip tied to the roll bar as well. The only thing about mine right now is that my speaker bar is on the floor behind my seats because of my cover. I have a summer top which encloses the cab from the roll bar forward so my speaker bar would be outside.
Attached Thumbnails
Click image for larger version

Name:	iPhone Pictures 016.jpg
Views:	28
Size:	221.8 KB
ID:	252601  
jeeps4u2nv88 is offline   Quote Quick Reply
Old 05-23-2013, 08:42 AM   #19
Jeeper
 
jeeps4u2nv88's Avatar
 
Join Date: May 2012
Location: Lake Orion, MI
Posts: 118
I know its a different forum but this thread really helped me with all my wiring.

Need Factory stereo wiring diagram, see pics for reason!! - JeepForum.com
jeeps4u2nv88 is offline   Quote Quick Reply
Old 05-24-2013, 12:56 PM   #20
Jeeper
 
Bielzebub's Avatar
 
Join Date: Jun 2012
Location: Jefferson City, MO
Posts: 144
Mine is a '99, but the PO cut all the factory wires to the rear and ran junk he got that's not even 18 gauge wire... When I build my box I will be running all new 12 gauge to a quick connect on the side of the box.

Something that you may want to think about if you don't want to leave it exposed too much to the elements is wrapping it in vinyl. I am talking like the vinyl flooring type stuff. Well, at least that's what my plan is for mine. I don't know how much you would really have to worry about the speakers getting too wet as they are on the under side and water shouldn't really be getting to them, but it may not be a bad idea to put some kind of rubber or plastic spacer between it and the box to give it a little depth away from the box. Just a thought.

__________________
Jeep. There's a reason the Postal Service has been using them for over 50 years!
Bielzebub is offline   Quote Quick Reply
Reply

Tags
aftermarket , installation , problems , radio , speakers

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:00 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC