Cruise Control problems on 2006 Rubicon - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-12-2012, 08:55 PM   #1
RLB
Newb
 
RLB's Avatar
 
Join Date: Jun 2012
Location: Kentucky
Posts: 7
Cruise Control problems on 2006 Rubicon

My 2006 Rubicon has a cruise control problem. The CC works for about 20 to 25 miles then the green cruise light goes out and the CC stops working. After I stop for a few minutes, it will work fine for another 25 miles or so. Any help appreciated!

RLB is offline   Quote Quick Reply
Old 11-12-2012, 09:57 PM   #2
Jeeper
 
Some Farkin Guy's Avatar
 
Join Date: Jun 2012
Location: Northern Kentucky
Posts: 278
The CC system is operated via a vacuum line. Check your lines for leaks, might just be a slightly loose boot. I had the same issue in my 2005. Does yours by chance have any issues with the vent switch? Mine had a tendency to stay on defrost until I found the leak because it's on the same vacuum line as the CC.

Some Farkin Guy is offline   Quote Quick Reply
Old 11-12-2012, 10:09 PM   #3
Jeeper
 
blueskiesbill's Avatar
 
Join Date: May 2012
Location: Baltimore
Posts: 726
Not sure if this would help you. Mine acted funny twice and without even realizing I I fixed it twice! Basically I realized that it came back to life after disconnecting and reconnecting my battery. Give it a try: it's only wierd if it doesn't work.
__________________
'when people look like ants -- Pull. when the ants look like people -- too late'

'if at first you do not succeed, skydiving is not for you'
blueskiesbill is offline   Quote Quick Reply
Old 11-13-2012, 03:55 AM   #4
RLB
Newb
 
RLB's Avatar
 
Join Date: Jun 2012
Location: Kentucky
Posts: 7
I will check the vacuum line for leaks. I have not had any issues with the vent switch. It is strange issue, the CC works for 25 minutes or so, then shuts down.
RLB is offline   Quote Quick Reply
Old 11-13-2012, 06:23 AM   #5
Jeeper
 
kylekae's Avatar
 
Join Date: Sep 2011
Location: Georgia
Posts: 689
At least your Ruby has cruise control haha, but really check the vacuum box where there hoses attach at the nipples, sometimes the hoses somewhat rot and leak there.
__________________
follow my build at http://www.wranglerforum.com/f5/my-j...ss-154212.html
kylekae is offline   Quote Quick Reply
Old 11-13-2012, 01:46 PM   #6
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: California/Nevada
Posts: 1,271
Mainly check the vacuum line to the reservoir in the fender well under the battery.
__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is offline   Quote Quick Reply
Old 02-16-2013, 08:56 AM   #7
RLB
Newb
 
RLB's Avatar
 
Join Date: Jun 2012
Location: Kentucky
Posts: 7
Cruise Control

The problem with the Cruise Control was the brake pedal switch, I picked one up and put it on and the cruise works great. I conducted an ohm test on the old one and sure enough, it was bad. Thanks for all the great advice, this is great forum. I found detailed instructions on how to find and replace it, only took fifteen minutes. Thanks Jeep Forum!

RLB is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:50 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC