edge trail jammer questions - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-21-2013, 08:23 PM   #1
Jeeper
 
fastlane_5's Avatar
 
Join Date: Feb 2013
Posts: 29
edge trail jammer questions

Hi everyone, i just put the edge tail jammer on my 99 tj. Can definitely tell a difference in power and throttle response. My question is how do i update the soft wear? Or can you even do that? Thanks.

fastlane_5 is offline   Quote Quick Reply
Old 03-22-2013, 12:28 AM   #2
Jeeper

WF Supporting Member
 
Join Date: Jul 2009
Location: Waterloo, IL
Posts: 41
I have the trail jammer set up on my 02 and agree throttle response is very much improved. Its a jeep so not sure you can actually tell performance gains but def runs smoother! I did not know soft ware update are available. The module doesn't hook up to a computer does it?

If anyone is interested I have another trail jammer for sale. For 03-04 only. Everything but the CAI but any CAI will work with it. $220 shipped

2500hd is offline   Quote Quick Reply
Old 03-23-2013, 04:25 PM   #3
Jeeper
 
Join Date: Mar 2012
Posts: 74
They are updatable. You will need to plug it into your computer. And go to their website. If you just got it I don't think there are any updates. Also I have it on a 2004 Rubicon with33s and it runs smoother and gave it back my top end power I lost when I went to 33s.
joedert is offline   Quote Quick Reply
Old 08-04-2013, 10:17 AM   #4
Jeeper
 
fastlane_5's Avatar
 
Join Date: Feb 2013
Posts: 29
I am having another problem with my edge. After plugging it in it works great.. After driving for about a half hour i turn the Jeep off.after restart it stumbles and will barely run.... I'm clueless.
fastlane_5 is offline   Quote Quick Reply
Old 08-04-2013, 03:42 PM   #5
Jeeper
 
DBoat's Avatar
 
Join Date: Jul 2012
Location: The Big D
Posts: 1,432
Quote:
Originally Posted by fastlane_5 View Post
I am having another problem with my edge. After plugging it in it works great.. After driving for about a half hour i turn the Jeep off.after restart it stumbles and will barely run.... I'm clueless.
that may not be the Edge but something else. I have one and am glad I did it. definitely more pep than before.
DBoat is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:26 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC