Electrical problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-30-2012, 04:26 PM   #1
Newb
 
Join Date: Aug 2012
Location: Colorado
Posts: 2
Electrical problem

Been off roading for years but this is my first jeep. Bought a 97 Wrangler TJ to use as a tow'd behind my motorhome. All was well until yesterday when I drove to town. Hit the turn indicator and got the rapid blink, figured I had a bulb out, seems to be a bit more complicated. I have no front turn signals or running lights. Rear blinkers work fine, 4 ways only work on the back. Can't find a loose wire or loose connector. Anyone seen this before? Ideas/suggestions?
Thanks in advance!
Scott

Scottsgreenjeep is offline   Quote Quick Reply
Old 08-30-2012, 04:33 PM   #2
GO STEELERS!

WF Supporting Member
 
geoffmarton's Avatar
 
Join Date: May 2012
Location: NE FL
Posts: 310
My experience has been that "mysterious" electrical problems almost always turn out to be ground issues. I'd double check any wires near the front tow bar to see if something got pinched. Also check the connection at both ends of the battery ground, though I'd think that a less likely culprit.

geoffmarton is offline   Quote Quick Reply
Old 08-30-2012, 04:40 PM   #3
Jeeper
 
Wattapunk's Avatar
 
Join Date: Mar 2012
Location: North TX
Posts: 1,808
Double check the connections on the bulbs into the light housing, then the housing screws are clean and secure to the body/chassis. You need to rule out a grounding issue of the bulbs>light housing>body.
Wattapunk is offline   Quote Quick Reply
Old 08-31-2012, 08:21 AM   #4
Newb
 
Join Date: Aug 2012
Location: Colorado
Posts: 2
I tow on a dolly so no pinched wires, already cleaned and retightened all the grounds I could find. Bulbs/sockets are clean. Took the lower dash off and didn't see anything that was out of place. Is there a connector to the front hidden somewhere I'm missing? I'm stumped.
Scottsgreenjeep is offline   Quote Quick Reply
Old 08-31-2012, 01:05 PM   #5
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: California/Nevada
Posts: 1,271
Does your horn work? There is a black connector on the left inner fender near the master cylinder area that has the wires for park/signal lights & horn & the solenoid for the fuel vapor canister. 3 wires at one corner are black/yellow, tan & gray. Those are for the park/signal lights. Check that connector for corrosion or not being fully connected together.
__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is offline   Quote Quick Reply
Old 08-31-2012, 01:14 PM   #6
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 3,825
Do the tail lights have brush guards on them.

__________________
Retired my 94 YJ 4cyl 5spd @ 200K
Now in a 04 TJ 4cyl 5spd CV @120K+
Both as a commuter vehicle in NW, NJ
April 2012.downsized and now a 99er.
Atthehop is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:38 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC