Engo e9000 terminal?? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-19-2013, 01:01 PM   #1
Jeeper
 
Join Date: Mar 2011
Posts: 810
Engo e9000 terminal??

Hey I have an engo winch. It works well. I noticed though that the one terminal is running extremely hot. It have one gauge wire running from it. I noticed that the terminal is actually loose and spinning free. How can I fix this? It sparks and has already melted the boot off. I'm not comfortable using it.

Click image for larger version

Name:	image-1923912361.jpg
Views:	40
Size:	133.4 KB
ID:	287665

It's the black one haha thanks for any help!! Tried calling engo but they won't pick up and have no voicemail....surprise.

techflork is offline   Quote Quick Reply
Old 08-19-2013, 01:54 PM   #2
Jeeper
 
Join Date: Mar 2011
Posts: 810
Well look at that... Took it apart and here's my problem.

Click image for larger version

Name:	image-2147851621.jpg
Views:	35
Size:	113.9 KB
ID:	287689



Click image for larger version

Name:	image-1576132722.jpg
Views:	31
Size:	133.3 KB
ID:	287690

And of course that falls out. I have no idea where it goes or came from haha. Just thought I'd share. Easy fix I think?

techflork is offline   Quote Quick Reply
Old 08-19-2013, 09:57 PM   #3
Jeeper
 
Join Date: Mar 2011
Posts: 810
failed, I soldered the connection. The moment it got power I saw it spark and it doesn't work anymore. Going to rip it apart tomorrow I guess...while I was working in the parking lot 2 ass hats blatantly drove over my brand new synthetic winch cable. rather ticked off, it's bright orange and pretty apparent I was doing something there. hate people >

on a side note, I have a million other things I need to do this week. If I never get around to dealing with the winch do they sell warn winches without cable?? just so I can save money since I've already purchased my synthetic rope?
techflork is offline   Quote Quick Reply
Old 08-19-2013, 10:10 PM   #4
Jeeper
 
Rumdog's Avatar
 
Join Date: Apr 2012
Location: Northern Michigan
Posts: 112
Warranty?
Rumdog is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:42 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC