Feels like Brakes are stuck - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-31-2012, 01:52 PM   #1
Join Date: Jun 2010
Posts: 24
Feels like Brakes are stuck

Driving around today, I felt like my brakes were engaged. Acceleration is slow, and I wasn't able to get above 40 MPH. The brake peddle seemed to be tight, and didn't have as much play as it usually does. I haven't done any reapirs or maintenance lately.

Does anyone have any suggestions as to where to start troubleshooting?

GatorInNola is offline   Quote
Old 08-31-2012, 01:55 PM   #2
MarkNog's Avatar
Join Date: Sep 2011
Location: Central Jersey
Posts: 607
Happened to me a few months ago, take off the brake pads, and use some brake cleaner to spray the piston/pistons down if they feel like the are stuck and play with it for a few minutes to work it in. Then do some hard braking around a parking lot of something to make sure the squeeze/retract like they are suppose to.

Is your pedal soft? It could be something else in the system.

MarkNog is offline   Quote
Old 08-31-2012, 02:01 PM   #3
Join Date: Jun 2010
Posts: 24
The pedal actually feels hard.
GatorInNola is offline   Quote
Old 08-31-2012, 02:55 PM   #4
Join Date: Aug 2011
Location: Lebanon
Posts: 796
Send a message via MSN to TLATEOTW
if you don't smell your brakes being toasted than your brakes are not locked.

it happened to me 2 weeks ago and the smell was very intense that you cant miss it. it turned out that the front left side was locked.

so i disassembled the brakes cleaned everything , and now it works fine.

you may need to bleed/calibrate
He who digs a hole and scoops it out falls into the pit he has made..............and if he has lockers he can simply get out of it!
-Mike T
TLATEOTW is offline   Quote
Old 09-08-2015, 01:49 PM   #5
Join Date: Sep 2015
Posts: 1
GatorNOLA, did you ever figure out what was wrong. My jeep started doing the exact same thing. It feels like I'm driving with the parking brake on but it isn't. I jacked it up and all the brakes are free and wheels turn normally. And it tops out at around 40mph. If I hit the gas hard I'll down shift and hit about 4Krpms but wont speed up. I have no check engine light, but had it read for codes anyway. No codes came up. Checked all my fluid in transfercase and tranny, all are good levels and clean.
fredricksondm is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:36 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC