Funny ground issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-16-2012, 06:12 AM   #1
Jeeper
 
Kevbz's Avatar
 
Join Date: Apr 2011
Location: O'Fallon, MO
Posts: 1,650
Funny ground issue

I hooked up my trailer yesterday and was going down the road and noticed my odometer reading was flickering...yep flickering on and off. I didn't put two and two together that it was the trailer, until I had driven long enough to realized that it flicked off when ever I pressed the brake, let up on the brakes and odo comes back. and if I was on the brake and then turned a blinker on, it would would flash.

Unplug the trailer and all was good. I wasn't aware that the cluster got its ground from the taillight circuit. Funny part is everything worked, blinkers, stop lights. I am assuming that when the trailer is plugged in that the ground is continued to the trailer circuit but that ground is good also. and my connection for my trailer harness is good also.

Go figure, but freaked me out when my odometer was flashing at me, I thought "Oh boy, what now"...

__________________
Semper Fidelis

Molon Labe

And all those other Latin and Greek phrases that mean don't mess with me, I am a bad ass that knows Latin and greek phrases!
Kevbz is offline   Quote
Old 04-16-2012, 02:33 PM   #2
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: California/Nevada
Posts: 1,591
If you check the resistance between the ground pin on the trailer connector & the tail light sockets you will probably find your problem. Usually the ground wire from the connector attaches to the trailer frame near the tongue & the lights are supposed to ground to the frame through their attachment points. If you only get the weird odo when you turn one way itís that light thatís not grounded. Other wise itís probably at the tongue. Itís possibly both lights but not likely.

Also make sure the ground pin on the connector on the jeep side is well grounded to the frame otherwise the trailer lights have to ground through the hitch-to-ball-to-frame. Not the best way & sometimes will cause the lights to flicker when you hit bumps & I suppose possibly something like you are having as well.(?)
__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 11:39 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC