gauges going crazy!!!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-16-2012, 02:26 AM   #1
Jeeper
 
98Tj_guy's Avatar
 
Join Date: Dec 2011
Location: Tulsa
Posts: 53
gauges going crazy!!!!

First off I have a 98 tj stock. I just replaced the intake/exhaust manifold gasket. Since I replaced that my battery gauge has been dropping from normal to 9, but my jeep runs fine? Then my heater ain't getting as hot as it normally does and if it does it works for a few mins then blows cold, now that would make me think that my themostat is stuck but my temp gauge stays normal then it will run hot for a min or two then back off red and go back. I'm just a shade tree mechanic so I have no clue what's going on. All help is greatly appreciated.

98Tj_guy is offline   Quote Quick Reply
Old 02-16-2012, 05:04 AM   #2
Jeeper
 
Join Date: Mar 2011
Posts: 121
4.0L or 2.5L?

Nailhead432 is offline   Quote Quick Reply
Old 02-16-2012, 05:05 AM   #3
Jeeper
 
98Tj_guy's Avatar
 
Join Date: Dec 2011
Location: Tulsa
Posts: 53
2.5
98Tj_guy is offline   Quote Quick Reply
Old 02-16-2012, 05:19 AM   #4
Jeeper
 
Join Date: Mar 2011
Posts: 121
I don't know the 2.5L that well, but based on ur symptoms, I would say u have an air pocket in ur cooling system and u possibly didn't get a ground wire reinstalled properly causing ur volt gauge to go crazy. Keep in mind ur voltage regulator is built into the PCM, and if all the ground wires (5 or 6) coming from ur PCM aren't located properly, clean and tight, it will cause all sorts of crazy problems.
Nailhead432 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken wire going into rear rubicon locker Waterlogged11 TJ General Discussion Forum 9 05-30-2014 09:59 AM
Tierra Del Sol, who's going? Xjman1 California Jeep Forum 32 03-06-2012 08:03 PM
Gauges blowing fuse? Boston_Bruins30 YJ Tech Forum 5 02-17-2012 01:43 PM
Need Advise on Good Shocks but Nothing Crazy stevekaz99 TJ General Discussion Forum 15 02-14-2012 03:18 PM
horn going mad 91badass TJ General Discussion Forum 1 02-13-2012 02:21 PM



» Featured Product

All times are GMT -5. The time now is 10:50 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC