general jeep questions - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-29-2009, 01:05 PM   #1
Newb
 
Join Date: May 2009
Location: i live in erie Pa.
Posts: 2
Question general jeep questions

i got a question, my jeep which is a 1998 wrangler Sahara sometimes has trouble accelerating. in the winter or when my jeep has been out in the rain i will be driving down the street and my foot is on the gas and the jeep will slow down. then it will lurch forward, and slow down again. i have to tap the gas several times for it to finally steadily increase speed. i don't know what it is and i was hoping for some suggestions. i think it could be a gas filter but im not sure.

alytle is offline   Quote
Old 05-29-2009, 01:26 PM   #2
Jeeper
 
G-Pur's Avatar
 
Join Date: Sep 2008
Location: Lowell, MA
Posts: 1,645
I just encountered a similar problem with the wife's Kia. Dealer said that the air intake hose was disconnected from wherever it mixes with the gas. The engine wasn't getting the proper mixture of gas and air to fire correctly so it made first gear a nightmare.

__________________
Check us out at NorthShoreJeeps.com

G-Pur is offline   Quote
Old 05-29-2009, 02:38 PM   #3
Jeeper
 
DallanG's Avatar
 
Join Date: Apr 2009
Location: Womelsdorf,PA
Posts: 138
Did your check engine light come on at all? If it did, then there should be a code stored in the computer that hould help determine the problem.
DallanG is offline   Quote
Old 05-29-2009, 02:43 PM   #4
Jeeper
 
Sb5551's Avatar
 
Join Date: Feb 2008
Location: South Philadelphia
Posts: 2,077
There are several things that could cause this. I have heard of the TPS causing this and when I switched mine it didn't do it again, but my symptoms weren't as bad as you describe. Any codes?
__________________
No more jeep for now
But I have free kandy and kittens in the back of my van


Sb5551 is offline   Quote
Old 05-29-2009, 03:19 PM   #5
Jeeper
 
leesmythe's Avatar
 
Join Date: Apr 2009
Location: PX ,Tucson, arizona
Posts: 99
very well could be injectors..

i have a 98 as well with 140,000 miles, and im startin tohave injector issues...

im surprised mine have lasted this long though.

buy some seafoam and drop it in your gas tank.
leesmythe is offline   Quote
Old 05-29-2009, 08:12 PM   #6
Jeeper
 
InfernoGirl's Avatar
 
Join Date: May 2009
Location: Newburgh IN
Posts: 11,419
Tps??? How does that affect driving? Assuming you mean Tire Pressure sensors.

I would also look at the fuel filter.
InfernoGirl is offline   Quote
Old 05-29-2009, 08:36 PM   #7
Jeeper
 
DallanG's Avatar
 
Join Date: Apr 2009
Location: Womelsdorf,PA
Posts: 138
Quote:
Originally Posted by InfernoGirl View Post
Tps??? How does that affect driving? Assuming you mean Tire Pressure sensors.

I would also look at the fuel filter.
TPS means throttle position sensor.
DallanG is offline   Quote
Old 05-30-2009, 01:28 AM   #8
Jeeper
 
1997redTJ's Avatar
 
Join Date: May 2009
Posts: 29
yeah and that would effect many things
1997redTJ is offline   Quote
Old 05-30-2009, 08:04 AM   #9
Jeeper
 
InfernoGirl's Avatar
 
Join Date: May 2009
Location: Newburgh IN
Posts: 11,419
Ok, thanks for clearing that up for me... Too many acronyms, not enough brain!
InfernoGirl is offline   Quote
Old 05-30-2009, 08:10 AM   #10
Jeeper
 
meyers's Avatar
 
Join Date: Apr 2009
Location: Dover, New Hampshire
Posts: 738
Sounds like the TPS, I would take it to a parts place that does free scans and see what it says.
meyers is offline   Quote
Old 06-01-2009, 04:33 PM   #11
Jeeper
 
1997redTJ's Avatar
 
Join Date: May 2009
Posts: 29
if you have a multimeter you could hot it up to the source and ref wires and then turn the key to the on position then move the thottle by hand and see if the voltage moves accordingly
1997redTJ is offline   Quote
Old 06-01-2009, 07:39 PM   #12
Jeeper
 
Join Date: May 2009
Posts: 18
Have you changed your O2 sensor in the last 50,000 mi? I had a similar problem (97 4.0).
The new sensor felt like a new Jeep.
blackjeep51 is offline   Quote
Old 06-02-2009, 11:25 AM   #13
Newb
 
Join Date: May 2009
Location: i live in erie Pa.
Posts: 2
i was really thinking it was the 02 censor ill probably get it looked at do you knwo how much a check would cost?
alytle is offline   Quote
Old 06-02-2009, 11:28 AM   #14
Jeeper
 
Join Date: May 2009
Posts: 30
i have the same exact thing going on right now does it only do it at first then once it does it once you are good for the rest of the trip. if so that is the same thing i have and i have asked many mechanics and not one of them has been to figure it out
1999tj is offline   Quote
Old 06-02-2009, 08:03 PM   #15
Jeeper
 
603TJ's Avatar
 
Join Date: Apr 2008
Location: New Hampshire
Posts: 191
I have a 98 with a similar problem.... Does anyone know if this is a easy fix? and by easy I mean, not cost a fortune and I could do it myself?
__________________
98TJ. wheels. shocks. motor. other things that make a jeep move.
603TJ is offline   Quote
Old 06-02-2009, 08:07 PM   #16
Jeeper
 
Join Date: Apr 2009
Posts: 538
Quote:
Originally Posted by InfernoGirl View Post
Tps??? Assuming you mean Tire Pressure sensors.
.
your thinking of TPMS. tire pressure monitor system
dooder is offline   Quote
Old 06-02-2009, 09:12 PM   #17
Jeeper
 
jjseel's Avatar
 
Join Date: Jan 2007
Location: Rowlett, TEXAS!
Posts: 2,955
Quote:
Originally Posted by alytle View Post
i was really thinking it was the 02 censor ill probably get it looked at do you knwo how much a check would cost?
Places like Auto Zone will read your codes for free, so they can sell you the parts.

__________________
jjseel is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Frequently asked questions about the YJ Iquois YJ General Discussion Forum 11 09-03-2011 07:07 PM
newbie, a few general questions... fourdoorfanatic YJ General Discussion Forum 11 05-14-2009 06:22 PM
Two Questions: 1. My jeep now 2. Upgrades to my jeep XNeoJesterX TJ General Discussion Forum 19 03-17-2008 08:53 AM
NEW Aussie Locker For Dana 30 Jeep Differentials (IL) BUSAFREAK Classifieds Archive 13 01-22-2008 09:39 PM
post up jeep resto part/accs. catalogs 1987 wrangler YJ Tech Forum 0 09-05-2007 11:42 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:04 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC