Getting nippy fast.....held needed asap! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-12-2009, 07:06 AM   #1
Jeeper

WF Supporting Member
 
Jp90Talon's Avatar
 
Join Date: Dec 2008
Location: CT
Posts: 3,137
Getting nippy fast.....held needed asap!

Well I am posting this from my phone so I am going to try and keep it short.

Today my jeep decided that it didn't like to keep me warm. I can't get the heat or AC to blow anything at all. I checked all the fuses and didn't see anything blown so I am starting to think my blower went. Is this a common issue with wranglers? Is there any way to verify its the blower or anything else that I can rule out? How hard is it to replace....does the entire dash have to come off?

Please help.....its getting cold.

Jp90Talon is offline   Quote Quick Reply
Old 11-12-2009, 07:33 AM   #2
Jeeper
 
mudslinger150's Avatar
 
Join Date: Jul 2009
Location: Northern VT
Posts: 1,128
Images: 1
Yes it is some what common. My jeep had the same symptoms a few weeks back. I flushed the heater core and the cooling system. The heater core i flushed one way and then the other, to get it flowing nice and free. I then re filled the jeep with some 50/50 anti-freeze (about 2 gallons) and we were blowing hot air again, and fast!

note: the coolant i flushed out was like pee soup, real dark green, with some streaks of brown (rust).

__________________
Mitch

Vermont
The Green Mountain State

http://www.cardomain.com/ride/3821222

http://www.youtube.com/watch?v=20dGUB6uJcQ
mudslinger150 is offline   Quote Quick Reply
Old 11-12-2009, 08:03 AM   #3
Jeeper

WF Supporting Member
 
Jp90Talon's Avatar
 
Join Date: Dec 2008
Location: CT
Posts: 3,137
Well it sounds as though your blower was still putting out air but that it was not hot air since your heater core was clogged.

I don't think that I'm having the same issue since I can feel a little hot air in the vents but nothing is actually blowing....heat or AC. That's why I am leaning towards a bad blower.
Jp90Talon is offline   Quote Quick Reply
Old 11-12-2009, 08:27 AM   #4
Show Me Your 8008135!

WF Supporting Member
 
s3nt3nc3d's Avatar
 
Join Date: Oct 2009
Location: Piqua, OH
Posts: 3,641
Send a message via AIM to s3nt3nc3d
I'd guess either a bad blower or possibly blower resistor...can you get air moving on any fan speed setting, possibly just high? Or none whatsoever?
__________________
"We don't build great brakes because we think you don't know how to drive, we build them for the guy on the road in front of you that doesn't." - Black Magic Brakes
s3nt3nc3d is offline   Quote Quick Reply
Old 11-12-2009, 08:50 AM   #5
Jeeper

WF Supporting Member
 
Jp90Talon's Avatar
 
Join Date: Dec 2008
Location: CT
Posts: 3,137
I can't get any air moving at all.
Jp90Talon is offline   Quote Quick Reply
Old 11-12-2009, 08:54 AM   #6
Jeeper
 
mrcarcrazy's Avatar
 
Join Date: Jul 2009
Location: Midland/Odessa, TX
Posts: 3,590
bad connection, or blower motor itself. possibly the switch...but I don't see all contacts failing at same time. and recheck fuse.
__________________
#2 Jeep http://www.wranglerforum.com/f322/99...ld-819418.html
99 Sahara, automatic.
mrcarcrazy is offline   Quote Quick Reply
Old 11-12-2009, 09:40 AM   #7
Jeeper

WF Supporting Member
 
Jp90Talon's Avatar
 
Join Date: Dec 2008
Location: CT
Posts: 3,137
Anyone have suggestions on how to go about trouble shooting this or should I just start buying parts and installing them starting with the cheaper parts first.
Jp90Talon is offline   Quote Quick Reply
Old 11-12-2009, 04:36 PM   #8
Jeeper
 
Bignuke's Avatar
 
Join Date: Mar 2009
Location: Fort Mill, SC
Posts: 1,057
Take off the metal plate that is infront of the steering wheel. There is a protector infront, 2 screws then the metal plate, see if all the hose are connected.

Bignuke is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
YJ parts needed ASAP sayers316 Classifieds Archive 4 10-13-2009 08:59 AM
ax-5 for 91 yj needed fast & cheap!!! Vplayer Classifieds Archive 0 06-03-2007 11:09 PM



» Featured Product

All times are GMT -5. The time now is 12:25 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC