Guages, Interior Lights, Radio stopped working - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-19-2011, 05:47 PM   #1
Jeeper
 
BigSahara's Avatar
 
Join Date: Feb 2009
Location: West Chester, PA
Posts: 155
Send a message via AIM to BigSahara
Exclamation Guages, Interior Lights, Radio stopped working

I just recently hit a pretty bad bump in the road in a construction area that I drive through daily and suddenly my radio and the aftermarket amp, gauges, interior lights and even the OBDII port are not working. I checked the fuses and everything looks fine. The battery seems fine as well, both terminals are tight. This used to happen a lot but when I hit the same bump, the radio shut off, then it would come back on in a few seconds. This time is permanent. I even took the entire dash apart and the connectors for the gauges look perfect. I know it's probably a loose ground somewhere but I'm not sure where to look. The Haynes manual doesn't say jack about this. Should I just take it to the stealership?

__________________
'00 TJ Sahara 4.0L, 3.5" RE Superflex, 1'' Body Lift, 35" Mickey Thompson MTZ's
BigSahara is offline   Quote Quick Reply
Old 10-19-2011, 06:14 PM   #2
Jeeper
 
fabrikate_it's Avatar
 
Join Date: Sep 2011
Location: Tulsa, OK
Posts: 459
check all the grounds you can find and use a test light on all the fuses to be double sure they are good to go sometimes a visual check will fool you.

__________________
American born and bred, union 'til I die!
United Association Plumbers and Pipefitters Local 430
PM me if you need a diagram I have All Data Pro access.
fabrikate_it is offline   Quote Quick Reply
Old 10-19-2011, 07:33 PM   #3
Jeeper
 
Join Date: Jul 2011
Location: Broken Arrow, OK
Posts: 2,305
Quote:
Originally Posted by fabrikate_it View Post
check all the grounds you can find and use a test light on all the fuses to be double sure they are good to go sometimes a visual check will fool you.
+1. A visual check doesn't always tell the whole story. If you're not getting power to the fuse it doesn't matter if it's good or not. Using a test light to check them will show that problem if it's there. Ignition switches are famous for this sort of problem on some models. I don't know if the TJ is one of them, but if you're not getting power to the fuse that's where I would start the search. It sounds like the accesory terminal of the switch hasn't been working right for a while and now it's finally failed completely.
__________________
2012 Silver Sport S, Silver, 6 speed, soft top, 3.73s, LSD, PCG, Infiniti, deep tint windows, Pro Comp 1028 wheels, 33" Duratracs, Smittybilt bumpers and steps, KC fog lights, Mopar slush mats and fuel door.

Happiness is a belt fed weapon.
oilwell1415 is offline   Quote Quick Reply
Old 10-20-2011, 09:19 AM   #4
Jeeper
 
BigSahara's Avatar
 
Join Date: Feb 2009
Location: West Chester, PA
Posts: 155
Send a message via AIM to BigSahara
__________________
'00 TJ Sahara 4.0L, 3.5" RE Superflex, 1'' Body Lift, 35" Mickey Thompson MTZ's
BigSahara is offline   Quote Quick Reply
Old 10-20-2011, 10:51 PM   #5
Jeeper
 
wranglerTX's Avatar
 
Join Date: Mar 2011
Posts: 443
check your fuse box, happen to me like 3 weeks ago and found a bad fuse. dont remember wich one.
__________________
2002 TJ Yellow
wranglerTX is offline   Quote Quick Reply
Old 10-21-2011, 06:26 AM   #6
Jeeper
 
BigSahara's Avatar
 
Join Date: Feb 2009
Location: West Chester, PA
Posts: 155
Send a message via AIM to BigSahara
:::Found the issue:::

It was the IOD fuse under the hood. I'm not sure what this is for but apparently replacing it made everything work again. Does anyone know what it does? Now the only problem is the amp to my sub-woofer is not working so I'm assuming there's still a ground out somewhere.

__________________
'00 TJ Sahara 4.0L, 3.5" RE Superflex, 1'' Body Lift, 35" Mickey Thompson MTZ's
BigSahara is offline   Quote Quick Reply
Reply

Tags
gauges , ground , interior lights , not working , radio

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
Help! Headlights stopped working Lazsjs2000 JK General Discussion Forum 3 10-02-2011 11:36 AM
All 4 seatbelts stopped working simultaneously robbywiggles General Jeep Discussion 3 10-02-2011 04:45 AM
interior lights & radio quit working..fuse? rowemania YJ Tech Forum 6 01-03-2009 03:50 PM
engine light stopped working mrbigjeep TJ Tech Forum 8 09-22-2006 10:38 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:10 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC