Hard Top Wiper/Washer help? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-30-2007, 10:54 AM   #1
Jeeper
 
nregas1's Avatar
 
Join Date: Jul 2007
Location: over yonder...in Tejas
Posts: 857
Send a message via Yahoo to nregas1
Question Hard Top Wiper/Washer help?

I just put the hardtop back on and reconnected the small hose and wiring harness. The wiper is working but not getting any washer fluid to pump out. When I hold the button down you can hear the pump working, but nothing coming out?

Any suggestions?

__________________

04 Sahara, with a lift, some stuff, and a few things, on some 33's, blah, blah, blah.
A perpetual work in progress. Too much to list, not nearly enough to matter.
My RigRater Score: 387RRv1.0 with a BOA of 18.92 (and just how exactly is this going to help me over that big arse rock?)
http://www.myjeepsite.com/nregas1

Always do sober what you said you'd do drunk. That will teach you to keep your mouth shut.
~ Ernest Hemingway
nregas1 is offline   Quote Quick Reply
Old 07-30-2007, 03:31 PM   #2
Jeeper
 
Vector6's Avatar
 
Join Date: Jan 2006
Location: Morgantown,WV
Posts: 1,025
fill the washer fluid tank?

__________________
USN 1985-1993
Vector6 is offline   Quote Quick Reply
Old 07-30-2007, 03:44 PM   #3
Jeeper
 
Tj Bunch's Avatar
 
Join Date: Mar 2007
Posts: 944


Too Obvious
__________________
[2001 Wrangler 2.5 New Bumper and 2" BB-31x10.50-15 General AT2 on Soft 8 Steel Rims....
http://www.myjeepspace.com/TJ_BUNCH
Fresno Ca


Tj Bunch is offline   Quote Quick Reply
Old 07-30-2007, 05:33 PM   #4
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
ITs a looooong hose. YOu have to hold it down untill it reaches the rear system.
AzTJ is offline   Quote Quick Reply
Old 07-31-2007, 12:05 AM   #5
Jeeper
 
nregas1's Avatar
 
Join Date: Jul 2007
Location: over yonder...in Tejas
Posts: 857
Send a message via Yahoo to nregas1
Quote:
Originally Posted by Vector6 View Post
fill the washer fluid tank?
__________________

04 Sahara, with a lift, some stuff, and a few things, on some 33's, blah, blah, blah.
A perpetual work in progress. Too much to list, not nearly enough to matter.
My RigRater Score: 387RRv1.0 with a BOA of 18.92 (and just how exactly is this going to help me over that big arse rock?)
http://www.myjeepsite.com/nregas1

Always do sober what you said you'd do drunk. That will teach you to keep your mouth shut.
~ Ernest Hemingway
nregas1 is offline   Quote Quick Reply
Old 07-31-2007, 12:07 AM   #6
Jeeper
 
nregas1's Avatar
 
Join Date: Jul 2007
Location: over yonder...in Tejas
Posts: 857
Send a message via Yahoo to nregas1
Quote:
Originally Posted by AzTJ View Post
ITs a looooong hose. YOu have to hold it down untill it reaches the rear system.
That was my first thought. I just wasn't sure if the stupid thing had to be primed somehow. Hell, I laid on that washer button about 30+ secs and still nothing. Guess I'll give it a full 60-90 seconds next time. Surely it would be able to pump less than 10' in that amt of time???
__________________

04 Sahara, with a lift, some stuff, and a few things, on some 33's, blah, blah, blah.
A perpetual work in progress. Too much to list, not nearly enough to matter.
My RigRater Score: 387RRv1.0 with a BOA of 18.92 (and just how exactly is this going to help me over that big arse rock?)
http://www.myjeepsite.com/nregas1

Always do sober what you said you'd do drunk. That will teach you to keep your mouth shut.
~ Ernest Hemingway
nregas1 is offline   Quote Quick Reply
Old 07-31-2007, 11:20 AM   #7
Jeeper
 
nregas1's Avatar
 
Join Date: Jul 2007
Location: over yonder...in Tejas
Posts: 857
Send a message via Yahoo to nregas1
Well, I held that damn rear wiper button down for 2 miles on my way to work this AM and didn't get a single drop of wiper fluid. Sure would like to know what the hell went wrong in the simpleton process of reconnecting the hose/harness. Just my luck.
__________________

04 Sahara, with a lift, some stuff, and a few things, on some 33's, blah, blah, blah.
A perpetual work in progress. Too much to list, not nearly enough to matter.
My RigRater Score: 387RRv1.0 with a BOA of 18.92 (and just how exactly is this going to help me over that big arse rock?)
http://www.myjeepsite.com/nregas1

Always do sober what you said you'd do drunk. That will teach you to keep your mouth shut.
~ Ernest Hemingway
nregas1 is offline   Quote Quick Reply
Old 07-31-2007, 02:27 PM   #8
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
check your fluid tank and see if its empty. If you had fluid in it and after pushing the button it went somewhere, I'd think there is a leak. THose plastic tanks do get cracks... but check the hoses too.
AzTJ is offline   Quote Quick Reply
Old 07-31-2007, 02:30 PM   #9
Jeeper
 
2002Apex's Avatar
 
Join Date: Jun 2007
Location: Birmingham
Posts: 277
just a quick question. Are all soft top jeeps hard top ready? (wiring, bolting on, and washer fluid ready.) i did notice a tube that looks like a washer fluid hose in the back of my jeep one day.
__________________

If in FIRST you dont succeed, hit SECOND and gas it!
2002Apex is offline   Quote Quick Reply
Old 07-31-2007, 02:41 PM   #10
Jeeper
 
Levinoss's Avatar
 
Join Date: Apr 2007
Location: Jeffersontown
Posts: 5,540
Like AZ said, it might be cracked or even clogged. I would run down the line and make sure its not pinched?

~Lev
__________________

"Yesterday is history, tomorrow is a mystery, but today is a gift. That is why it is called the "present."
Levinoss is offline   Quote Quick Reply
Old 07-31-2007, 03:02 PM   #11
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
Quote:
Originally Posted by 2002Apex View Post
just a quick question. Are all soft top jeeps hard top ready? (wiring, bolting on, and washer fluid ready.) i did notice a tube that looks like a washer fluid hose in the back of my jeep one day.
Not all are hardtop ready - apparently yours had a hardtop at one time as it has the harness and tubing. The only other thing youd need are the bolts to bolt it to the tub.
AzTJ is offline   Quote Quick Reply
Old 07-31-2007, 06:41 PM   #12
Jeeper
 
nregas1's Avatar
 
Join Date: Jul 2007
Location: over yonder...in Tejas
Posts: 857
Send a message via Yahoo to nregas1
Quote:
Originally Posted by AzTJ View Post
check your fluid tank and see if its empty. If you had fluid in it and after pushing the button it went somewhere, I'd think there is a leak. THose plastic tanks do get cracks... but check the hoses too.
First...Yes, the fluid is full. Second, What puzzles me is I only had the damn HT off for about 5 days. AND, I know it was working just before removing it.

It's almost like it's just not picking up the fluid or something. You can hear the motor running, trying to pump...but nothing. Of course, the first and last thing I did was bump the front wiper and confirm the fluid is still pumping up there. So it would seem obvious that the issue is somewhere in the lines. How/what I don't know.


Quote:
Originally Posted by Levinoss View Post
Like AZ said, it might be cracked or even clogged. I would run down the line and make sure its not pinched?

~Lev
Good idea. I suppose, even in just a few days something could have crawled up there. I'm just suprised anything could have clogged it that much, that quickly.

I think I'm going to blow my air compressor through it.
__________________

04 Sahara, with a lift, some stuff, and a few things, on some 33's, blah, blah, blah.
A perpetual work in progress. Too much to list, not nearly enough to matter.
My RigRater Score: 387RRv1.0 with a BOA of 18.92 (and just how exactly is this going to help me over that big arse rock?)
http://www.myjeepsite.com/nregas1

Always do sober what you said you'd do drunk. That will teach you to keep your mouth shut.
~ Ernest Hemingway
nregas1 is offline   Quote Quick Reply
Old 08-01-2007, 10:26 PM   #13
Jeeper
 
nregas1's Avatar
 
Join Date: Jul 2007
Location: over yonder...in Tejas
Posts: 857
Send a message via Yahoo to nregas1
Cool

Well, here's the update on my dumb a$$. And no, the wiper jug wasn't empty! BUT, when I finally took the extensive measures of looking into the wiper reserviour I saw that the hose that feeds the rear wiper sits about 3" higher than the front feeder hose. And wouldn't you know it, the fluid had dropped just below that rear feeder tube... Basically I glanced and saw plenty of fluid but never noticed the second tube was higher.
__________________

04 Sahara, with a lift, some stuff, and a few things, on some 33's, blah, blah, blah.
A perpetual work in progress. Too much to list, not nearly enough to matter.
My RigRater Score: 387RRv1.0 with a BOA of 18.92 (and just how exactly is this going to help me over that big arse rock?)
http://www.myjeepsite.com/nregas1

Always do sober what you said you'd do drunk. That will teach you to keep your mouth shut.
~ Ernest Hemingway
nregas1 is offline   Quote Quick Reply
Old 08-01-2007, 10:55 PM   #14
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
lol - I forgot about that too.... when the fronts work and the rear doesn't you need more fluid. Happened to me when I first got mine.

you can go to an auto part store and pick up some vacuum/washer fluid line thats big enough to slip over the pick up so that it will reach farther down.
AzTJ is offline   Quote Quick Reply
Old 08-01-2007, 11:00 PM   #15
Jeeper
 
Levinoss's Avatar
 
Join Date: Apr 2007
Location: Jeffersontown
Posts: 5,540
At least its fixed now, lesson learned.

~Lev

__________________

"Yesterday is history, tomorrow is a mystery, but today is a gift. That is why it is called the "present."
Levinoss is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard Top Questions Allagash TJ Tech Forum 14 11-10-2008 02:37 PM
Hard Top Storage cowboy12 JK General Discussion Forum 5 08-01-2008 12:21 AM
Besttop hard upper doors bozz YJ General Discussion Forum 1 01-02-2008 08:17 PM
1/2 hard top for my 91 YJ amara8 YJ General Discussion Forum 2 12-16-2007 10:58 AM
Hard top and doors HkdOnJP Classifieds Archive 10 12-02-2007 02:48 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:49 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC