Heater problems need help - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-10-2012, 05:03 AM   #1
Jeeper
 
dillinghamte2's Avatar
 
Join Date: Mar 2011
Location: South Korea
Posts: 36
Heater problems need help

Switch melted, ordered repair kit and new switch..no good only low speed
Now have put new resister, fan, relay and control switch which by the way is out of position and to long..and just have low speed can put halfway between high and next lowest setting and the blower will go on high???
Does anyone have any idea s what to do??

dillinghamte2 is offline   Quote
Old 04-10-2012, 05:11 AM   #2
Jeeper
 
Jeeplover1's Avatar
 
Join Date: Mar 2012
Location: Arkansas
Posts: 15,761
Quote:
Originally Posted by dillinghamte2 View Post
Switch melted, ordered repair kit and new switch..no good only low speed
Now have put new resister, fan, relay and control switch which by the way is out of position and to long..and just have low speed can put halfway between high and next lowest setting and the blower will go on high???
Does anyone have any idea s what to do??
mine did this and it was the switch? there is a way to run a jumper wire to the switch and run it on high.. my mech did it then i put new switch in and it worked fine.

__________________
Im a Vet and bled for my beliefs and was willing to die for them, what have you done for yours?
Jeeplover1 is offline   Quote
Old 04-10-2012, 10:01 AM   #3
Jeeper
 
Shelby427's Avatar
 
Join Date: May 2011
Location: Lakeland FL and Hooversville PA
Posts: 2,198
Or just from your post, you may have the wrong switch.
__________________
97 Sahara, 74 Renegade, 72 CJ5, 55 Willy's (the Beast) Boss 302, 6:34 gearing, Bose 901 speakers.
God I miss that Jeep. Forgot the kinda Jeep, 80 SX4.
Shelby427 is offline   Quote
Old 04-10-2012, 06:20 PM   #4
Jeeper
 
dillinghamte2's Avatar
 
Join Date: Mar 2011
Location: South Korea
Posts: 36
2 wrong switches?? do you know who or where to get the correct one?
dillinghamte2 is offline   Quote
Old 04-25-2012, 05:40 AM   #5
Jeeper
 
dillinghamte2's Avatar
 
Join Date: Mar 2011
Location: South Korea
Posts: 36
correct swith now still not all the speeds could I have wired the switch repair wrong??
Anyone know what colors go to each fan speed switch posts??
dillinghamte2 is offline   Quote
Old 04-25-2012, 06:53 PM   #6
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: California/Nevada
Posts: 1,738
For 1997:
Lo = tan, m1= light green/light blue, m2= light blue, hi= brown/tan.

To test the switch, disconnect the connector & jump the tan wire to each of the others to get the other speeds. Tan to br/tn gives hi, tn to lb = m2 etc.
__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is offline   Quote
Old 04-25-2012, 10:42 PM   #7
Jeeper
 
dillinghamte2's Avatar
 
Join Date: Mar 2011
Location: South Korea
Posts: 36
Thanks !!! I'll check it out tonight when I get home..Hope fully I just have a wire switched.

dillinghamte2 is offline   Quote
Reply

Tags
heater , heater switch

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 11:01 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC