heater question - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-06-2011, 07:59 PM   #1
Jeeper
 
robbiecc's Avatar
 
Join Date: Sep 2010
Posts: 771
heater question

I have a 98 and the heater works, just not the super hot i keep reading about. I have noticed that while it works all the time and is fairly warm-when i'm arounf 2k rpm it seems to work really good-to the point if it worked like that all the time i'd probably have to turn it down some. i was thinking maybe a vacum leak somewhere but i would think the higher the rpm, the better the heat.
anyone have a similar experience or ideas? be nice if i could get it to work like that all the time. and everything else is normal-temp 210, did back flush the core a month or so back and all speeds, vents work as they should.
thanks

robbiecc is offline   Quote Quick Reply
Old 12-06-2011, 08:29 PM   #2
Jeeper
 
Buddy B's Avatar
 
Join Date: May 2011
Location: Monmouth Co
Posts: 325
Quote:
Originally Posted by robbiecc
I have a 98 and the heater works, just not the super hot i keep reading about. I have noticed that while it works all the time and is fairly warm-when i'm arounf 2k rpm it seems to work really good-to the point if it worked like that all the time i'd probably have to turn it down some. i was thinking maybe a vacum leak somewhere but i would think the higher the rpm, the better the heat.
anyone have a similar experience or ideas? be nice if i could get it to work like that all the time. and everything else is normal-temp 210, did back flush the core a month or so back and all speeds, vents work as they should.
thanks
Ok so you have little heat at low RPM? Things to check, temp selector, blend door (s) replace the thermostat, never a bad idea , flushing the radiator. If all the blend doors work and no hissing sound after they've closed/opened. No obstructions in or in front of the radiator. Besides flushing the core, what else did you flush? Your heat at idle or low RPMs fully warmed up should be very hot.

__________________
OIIIIIIIO
Buddy B is offline   Quote Quick Reply
Old 12-07-2011, 04:52 AM   #3
Jeeper
 
robbiecc's Avatar
 
Join Date: Sep 2010
Posts: 771
flushed/back flushed the heater core, theromstat good-temp right at 210. when i change the selector i hear the doors moving and air comes out the correct vents-did have a prob with dash vents but fixed it(cut hose from PO replaceing stero/sirrus. took off air intake on hood-clean. haven't visually checked vent doors-guess i'll be doing that this week end. just find it weird that at 2K rpm the heater cooks-all other rpm's it works but not like at 2K----guess i could drive the whole winter at 40 mph
robbiecc is offline   Quote Quick Reply
Old 12-07-2011, 06:37 AM   #4
Jeeper
 
Buddy B's Avatar
 
Join Date: May 2011
Location: Monmouth Co
Posts: 325
Its fustrating I know, when i'm handed a work order for a vehicle w/ similar symptoms I cringe... the most common of the blend doors to malfunction is the temp selection, the higher RPMs pull more vacuum, maybe your losing it just enough to give poor heat. Did you check the vacuum reservoir, it should be located right corner somewhere below the headlight? It could be a circulation problem but its hard to diagnose via Forum. Do you have a vacuum diagram? Google " images" and work from that, your model has 5 or 6 photos of the vacuum routing on there. You have 2 different size heater hoses, i'm sure you checked that, you burped the coolant sys right? Did the PO Maintenance the coolant sys correct service intervals . Let us know how your doing.
__________________
OIIIIIIIO
Buddy B is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
heater problem snowman53 TJ General Discussion Forum 1 11-02-2011 10:40 PM
Heater challenge! Razorcat YJ Tech Forum 8 10-25-2011 07:18 AM
Heater core Question willardstanley YJ Tech Forum 3 10-22-2010 11:58 PM
Heater question ks90yj TJ Tech Forum 3 02-24-2010 02:34 PM
heater control question timmy2004 TJ Tech Forum 4 02-03-2008 07:13 AM



» Featured Product

All times are GMT -5. The time now is 10:46 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC