heater vent don't work - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-12-2010, 03:22 PM
Thread Starter
  #1
Newb
 
Join Date: Mar 2010
Posts: 2
Steevy is on a distinguished road
heater vent don't work

i have a 1998 jeep wrangler and only the defroster works. I don't have any air coming from the dash vents or floor vents. can does anyone know what is wrong.
Steevy is offline   Quote
Old 03-12-2010, 03:34 PM   #2
Brewing, Skiing & Jeeps..

WF Supporting Member
 
Bruck's Avatar
 
Join Date: Mar 2010
Location: Right next to the Kegerator...
Posts: 549
Bruck is on a distinguished road
Maybe it has to do with your grammar??? Just joking dude. I'll bet it has to do with your climate control dial. They can get a little punchy and not catch.

Bruck is offline   Quote
Old 03-12-2010, 03:39 PM   #3
Jeeper
 
bob09's Avatar
 
Join Date: Sep 2009
Location: Ohio
Posts: 40
bob09 is on a distinguished road
Well, It could be that, it could also be the control module or even the blower. And if it is a control module, you can replace the pieces that go in the module itself instead of paying a ridiculous amount for a whole new module. And I go to RockAuto Auto Parts
__________________
If we lose freedom here, there is no place to escape to. This is the last stand on Earth. -Ronald Reagan-
bob09 is offline   Quote
 
Old 03-12-2010, 08:09 PM
Thread Starter
  #4
Newb
 
Join Date: Mar 2010
Posts: 2
Steevy is on a distinguished road
does anyone no where the actuator, vacuum on a 1998 jeep wrangler
Steevy is offline   Quote
Old 03-12-2010, 08:37 PM   #5
Jeeper
 
jamesdeanblvd's Avatar
 
Join Date: May 2009
Posts: 161
jamesdeanblvd is on a distinguished road
check the vacuum modulator on the drivers side floorboard. Mine did the same thing and I fixed it with a sheet metal screw. If you do a search on the topic under heater, I think you will even find a diagram of the modulators.
jamesdeanblvd is offline   Quote
Old 08-14-2011, 10:47 AM   #6
Newb
 
Join Date: Aug 2011
Posts: 2
jjlyne is on a distinguished road
luv my jeep,but i cant figure out my heating problem. Tested the blower motor,replaced the blower switch and the resistor checked the fuses and still nothing . Any help please! New here
jjlyne is offline   Quote
Old 08-14-2011, 07:18 PM   #7
Jeeper
 
wirejock's Avatar
 
Join Date: May 2011
Posts: 175
wirejock is on a distinguished road
If the other fixes don't help, try tracking down the vacuum lines.
Thread link below.
http://www.wranglerforum.com/f5/vacu...ry-107278.html
wirejock is offline   Quote
Old 08-14-2011, 09:07 PM   #8
Newb
 
Join Date: Jul 2011
Location: AR-Hog Heaven
Posts: 13
MathewsHunter is on a distinguished road
i had the same issues. The c/c stopped woking too. It was a vacuum leak. easy cheap fix. I started a thread a few weeks back that has pictures. Good lucK!
MathewsHunter is offline   Quote
Old 08-15-2011, 10:35 AM   #9
Newb
 
Join Date: Aug 2011
Posts: 2
jjlyne is on a distinguished road
thank you for the info, found that my heater / ac control switch was melted. Strange to me how that would happen. Now the question is how to fix so it doesnt happen agian. And still not quite sure if that will fix it.
jjlyne is offline   Quote
Old 08-15-2011, 12:10 PM   #10
Jeeper
 
robbiecc's Avatar
 
Join Date: Sep 2010
Posts: 771
robbiecc is on a distinguished road
1st-pop the covers fron under the steering wheel-looking towards the center you'll see 3 actuators-top is dash, middle is defrost and bottom is floor. start the jeep and move the selector around and see if anything moves. if it does, check the arms to make sure not broken/disconnected. if not, make sure hoses are connected to the actuators-top/bottom have 1, middle has 2(thin and colored-look like wires, not hoses) if connected, remove the glove box and you'll see a connector with a bunch of colored hoses to it-make sure it's tight and connected.
this is as far as i made it as my problem was at the connector(1 hose cut) if it's connected and looks good you'll have to keep going and disconnect, remove center dash and look at the switch. this is about as far as i can help as i didn't need to go past the connector. sure others can guide you farther.
robbiecc is offline   Quote
Old 10-27-2011, 08:37 PM   #11
Newb
 
Join Date: Jun 2011
Location: North Carolina
Posts: 5
100baden is on a distinguished road
2002 two problems

First my heat/ Air vent do not work. I have plenty of air blowing but not in the location the switch is in.Second my air bag light is on. Is there a test to find out if it is the switch on the console or the module.
100baden is offline   Quote
Old 10-28-2011, 09:31 PM   #12
Jeeper
 
Join Date: Sep 2011
Location: North Franklin, CT
Posts: 78
pickncrew is on a distinguished road
May '02 has the same problem... only defrost works; happy I saw this post.
pickncrew is offline   Quote
Old 05-07-2012, 04:58 PM   #13
Jeeper
 
Join Date: Apr 2012
Posts: 23
Shooting Jack is on a distinguished road
My 97 has a similar problem and found that the top actuator is not hooked up and can't figure where it connects. The rod is coming out of it but didn't see any place to hook it to. Anyone have picture or can tell me where to hook it. Thanks.

Shooting Jack is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
will this gas tank swap work??? sayers316 YJ Tech Forum 3 07-21-2009 12:43 PM
Estimate on mechanical work diab-o TJ General Discussion Forum 2 10-30-2007 09:40 PM
Heater core??? Shortpunter TJ Tech Forum 5 10-30-2007 05:30 AM
heater oneman275 YJ Tech Forum 5 02-08-2006 10:14 PM
my weekend work on the jeep (rambling) whitebuffalo General Jeep Discussion 6 07-18-2005 11:05 AM





All times are GMT -5. The time now is 05:24 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC
« Back

Enter your email address:

Delivered by FeedBurner