Heating Issues - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-22-2013, 09:47 AM   #1
Join Date: Jun 2012
Location: New York
Posts: 100
Heating Issues

Hey everyone, I've got a 98 TJ SE. Just recently, my heat doesn't work too well. Air blows out the defrost vents only, and it's always at the highest setting. No matter what fan speed or location I select, it's always defrost on high. Any ideas?

Ginsu is offline   Quote
Old 04-22-2013, 09:49 AM   #2
Timberline's Avatar
Join Date: Sep 2012
Location: 38.8339° N, 104.8208° W, Colorado
Posts: 1,135
Sounds to me like you have a vacuum leak going on. I would check all your vacuum lines to see if you can find anything going on. If there are any near the battery, that would be my first place to look.

2004 Sahara TJ
3.73 Gears / 4.0L / 2" Pro Comp Lift / BF Goodrich AT 32x11.50R15 / 15x8 Pro Comp Alloy Series 1059 / 4' Firestik Ant / Midland CB Radio / Roll & Pitch Clinometer / KC & Hella 700FF Driving Lights / Winch / Smittybilt Bumpers (modified)/ Teraflex 9550 SS
Timberline is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:10 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC