Help!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-17-2012, 11:48 PM   #1
Jeeper
 
MaxTurner's Avatar
 
Join Date: Jun 2012
Posts: 48
Help!!

I have a 99 jeep tj 4.0 6 cl. I have been having problems when i first start the engine, the engine will immediately bog way down. Usually in the past i push the gas and rev it up a little and then all is good from there. But today when i pushed the gas the engine tried to rev but it wouldn't and eventually the engine died. After a few more tries it finally hooked up and went. Also while this was happening there was a burning smell. Not very familiar with that so not sure what it smelled like. I drove it to a couple more places and started up fine, with only one time that i had to rev the engine to get it going.

Also my Jeep just hit 160k miles and is my dd if that info is needed.

ANY help is greatly appreciated. Just trying to figure out whats wrong with my baby.

MaxTurner is offline   Quote Quick Reply
Old 08-18-2012, 12:04 AM   #2
Jeeper
 
2004 lj's Avatar
 
Join Date: Jun 2012
Posts: 16,694
Is your ac on?

__________________
Yes it is a rubicon
2004 lj is offline   Quote Quick Reply
Old 08-18-2012, 12:11 AM   #3
Jeeper
 
MaxTurner's Avatar
 
Join Date: Jun 2012
Posts: 48
I cant remember if it was or not. Very very possible that it was though.
MaxTurner is offline   Quote Quick Reply
Old 08-18-2012, 12:12 AM   #4
Jeeper
 
2004 lj's Avatar
 
Join Date: Jun 2012
Posts: 16,694
Quote:
Originally Posted by MaxTurner
I cant remember if it was or not. Very very possible that it was though.
Try shutting ac off when you start up. You could have a bad clutch on your compressor.
__________________
Yes it is a rubicon
2004 lj is offline   Quote Quick Reply
Old 08-18-2012, 01:31 AM   #5
Jeeper
 
jeepwayoflife's Avatar
 
Join Date: Nov 2011
Location: California
Posts: 3,061
What about a dieing clutch? Do you have a manual? What if the clutch is still slightly engaged when you push the pedal to the floor, causing stress on the engine and a burning smell? Idk just an idea
__________________
--------------------------------------------------------
jeepwayoflife is offline   Quote Quick Reply
Old 08-18-2012, 01:35 AM   #6
Jeeper
 
2004 lj's Avatar
 
Join Date: Jun 2012
Posts: 16,694
Quote:
Originally Posted by jeepwayoflife
What about a dieing clutch? Do you have a manual? What if the clutch is still slightly engaged when you push the pedal to the floor, causing stress on the engine and a burning smell? Idk just an idea
Dont have a manual. But had problem on my 04 with ac clutch staying engaged. Caused ruff start up but was ok when running.
__________________
Yes it is a rubicon
2004 lj is offline   Quote Quick Reply
Old 08-18-2012, 11:42 AM   #7
Jeeper
 
MaxTurner's Avatar
 
Join Date: Jun 2012
Posts: 48
Yes i do have a manual trans. Thanks for the idea!

I will try making sure i always turn off the A/C and see if it goes fine.
If the A/C is the problem how exactly do i go about fixing? Is it something that's necessary to be fixed?
MaxTurner is offline   Quote Quick Reply
Old 08-18-2012, 12:18 PM   #8
Jeeper
 
ken78744's Avatar
 
Join Date: Aug 2012
Posts: 689
Got to go to local autoparts store and see if you can buy a a/c compressor clutch with out having to buy a new compressor.... New compressor $180-$285, new clutch IF they sell it $35-$75....
ken78744 is offline   Quote Quick Reply
Old 08-19-2012, 12:23 AM   #9
Jeeper
 
2004 lj's Avatar
 
Join Date: Jun 2012
Posts: 16,694
Quote:
Originally Posted by MaxTurner
Is it possible that this part being bad causes my A/C to be stuck in defrost? Because at the moment my a/c blows cold but the switch is locked up and no matter where you turn it it stays in defrost.
Wow dont know. I would start by checking under dash to make sure you dont have anything bound up on the ac controls. Dont force it or ur will have to get new knobs.
__________________
Yes it is a rubicon
2004 lj is offline   Quote Quick Reply
Old 08-19-2012, 06:45 AM   #10
Jeeper
 
ken78744's Avatar
 
Join Date: Aug 2012
Posts: 689
Mine did that yesterday, pop the hood your vacum line for the a/c control came off... It is located on the outer bottom side of the intake right below throttle body...
ken78744 is offline   Quote Quick Reply
Old 08-20-2012, 12:13 AM   #11
Jeeper
 
MaxTurner's Avatar
 
Join Date: Jun 2012
Posts: 48
Thank you so much! I will try this tomorrow and see if it fixes it!
MaxTurner is offline   Quote Quick Reply
Old 08-20-2012, 10:07 AM   #12
Jeeper
 
Join Date: Mar 2011
Posts: 35
your TJ has AC?
lol mine doesn't

seanbateman7 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:04 AM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC