Help Appreciated???? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-24-2012, 05:27 PM   #1
Newb
 
Join Date: Oct 2011
Posts: 14
Help Appreciated????

2001 Jeep Wrangler TJ 4.0

Jeep was running very rough and CEL came on blinking.
Immediately ran codes and this is what I recieved:
P0203
Injector 3 control Circuit
Heater Bank 1 sensor 2 shorted to voltage
cyl 1 misfire
cyl 3 misfire
O2 sensor
Based on what I have researched I believe its the 02 sensor and would like to dig into this tomorrow.....any help greatly appreciated!

CB21 is offline   Quote Quick Reply
Old 02-25-2012, 06:53 AM   #2
Newb
 
Join Date: Oct 2011
Posts: 14
Ttt

CB21 is offline   Quote Quick Reply
Old 02-25-2012, 07:04 AM   #3
Show Me Your 8008135!

WF Supporting Member
 
s3nt3nc3d's Avatar
 
Join Date: Oct 2009
Location: Piqua, OH
Posts: 3,641
Send a message via AIM to s3nt3nc3d
I'm confused...is the only code you got P0203? Or did you get a code for each of the items above?

If you only got the PO203 code...it's either a problem in the cylinder 3 injector circuit (short/open in wiring or bad injector) or a bad PCM. The most common cause is a bad injector, but all are possibilities.

If you got a code for each item above, I would say O2 sensor might resolve some of the problems, but I think you got more problems than just an O2 sensor bad.
__________________
"We don't build great brakes because we think you don't know how to drive, we build them for the guy on the road in front of you that doesn't." - Black Magic Brakes
s3nt3nc3d is offline   Quote Quick Reply
Old 02-25-2012, 07:11 AM   #4
Newb
 
Join Date: Oct 2011
Posts: 14
Thats almost how the diagnostic spit it out
1 p0203 injector 3 control circuit
2 cyl 1 misfire
3 cyl 3 misfire
4 o2 sensor
Heater bank 1 sensor 2 shorted to voltage

It will run fine and then become very rough ......just not sure .....did this once long ago replaced plugs and coilpack and 02 sensor and was good for 3-4 years....Im at my wits end with this thing!
CB21 is offline   Quote Quick Reply
Old 02-25-2012, 08:03 AM   #5
Show Me Your 8008135!

WF Supporting Member
 
s3nt3nc3d's Avatar
 
Join Date: Oct 2009
Location: Piqua, OH
Posts: 3,641
Send a message via AIM to s3nt3nc3d
Go out to your Jeep...turn ignition on, off, on, off, on (leave it on the 3rd time--don't start it any of those times.

See what it spits out then...just codes. I'm thinking what you may have is either something related to bad injectors, fouled plugs, or a bad coil pack which is giving you erroneous readings from the O2 sensor. I'm also thinking I'm drugged up on sleeping pills right now and may not be thinking very clearly either. lol
__________________
"We don't build great brakes because we think you don't know how to drive, we build them for the guy on the road in front of you that doesn't." - Black Magic Brakes
s3nt3nc3d is offline   Quote Quick Reply
Old 02-25-2012, 08:18 AM   #6
K O R

WF Supporting Member
 
dabolt55's Avatar
 
Join Date: Jul 2011
Location: Clinton, Tn.
Posts: 12,450
Images: 52
The po had the o2 sensors changed before I bought it, everythings fine now. good luck... 01 4.0l sport.
__________________
Nothing to it but to do it.
SIMPLE AS THAT.

'04 TJ RUBICON, 4.0l auto
2"BDS coils, Rubicon express shocks, 33/12.50/15 Dick Cepek Mud Country tires yellowed out, on Black steel D's.
dabolt55 is online now   Quote Quick Reply
Old 02-25-2012, 11:01 AM   #7
Newb
 
Join Date: Oct 2011
Posts: 14
I will try that after bit......Get this thing back in good shape and I think I may have to send it down the road!
CB21 is offline   Quote Quick Reply
Old 02-26-2012, 07:17 AM   #8
Newb
 
Join Date: Oct 2011
Posts: 14
Anybody have anything else to add to help out.....or anyone wanna come to ohio for a hell of a deal on a jeep ?
CB21 is offline   Quote Quick Reply
Old 02-26-2012, 11:00 AM   #9
Jeeper
 
jgorm's Avatar
 
Join Date: May 2010
Location: San Diego
Posts: 1,923
The o2 short needs to be found. That can cause the ecu to do the other weird stuff and are probably 'fantom' codes. If there is no short, then its probably internal in the ecu (super rare and probably not the problem). I had a friend with weird codes that didn't make sense and some of the wires on the ecu harness were loose. Start with a jiggle test (jiggle all wires pretty hard and listen for engine changes or stutters). Double check the o2 wires first to make sure none are burned or shorted to the headers.
__________________
my 06 LJ rubicon
2.5" SL, 1" BL, DIY highline, 35s with double beadlocks.
jgorm is offline   Quote Quick Reply
Old 02-26-2012, 03:34 PM   #10
Newb
 
Join Date: Oct 2011
Posts: 14
jgorm will do......I have twins coming in about 2 days so I guess I'm gonna have to take it in to the mechanic and let him know what ya said...but I do appreciate any and all suggestions!

CB21 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! Getting spraypaint off ktot General Jeep Discussion 12 02-29-2012 08:48 AM
alright jeep gods, i need a little help!! acwrangler General Jeep Discussion 5 02-29-2012 12:14 AM
Blinker Issue!!! HELP! HELP! krobmark TJ General Discussion Forum 5 02-26-2012 11:17 PM
Please help my 89 yk stalls in water? pendletontn YJ Tech Forum 2 02-24-2012 08:22 PM
Hard top mounting help ej_fireman TJ General Discussion Forum 13 02-24-2012 06:33 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:32 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC