Help changed fuel pump won't start! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-23-2012, 10:01 AM   #1
Jeeper
 
Join Date: Jan 2011
Posts: 32
Help changed fuel pump won't start!

Ok I changed fuel pump. When I disconnect fuel line at rail gas shoots out so I guess it is working. It cranks but won't fire Iprimeda bunch of times When I pour gas in the throttle it starts then dies. I have spark. What next?? I switched relays but nothing please help. Thanks

BEBOP86 is offline   Quote Quick Reply
Old 02-23-2012, 01:53 PM   #2
Jeeper

WF Supporting Member
 
jeepjones's Avatar
 
Join Date: Jul 2010
Location: Canada, Eh?
Posts: 1,892
Can you hear the pump running when you turn the key? It should "buzz" for about 2 sec then shut off.

__________________
jeepjones is offline   Quote Quick Reply
Old 02-23-2012, 02:12 PM   #3
Jeeper
 
Join Date: Jan 2011
Posts: 32
thanks - yes I have gas coming to the fuel rail but will not crank over- any other ideas I am open and need help- thanks-
BEBOP86 is offline   Quote Quick Reply
Old 02-23-2012, 06:19 PM   #4
Jeeper
 
Muddr1's Avatar
 
Join Date: Nov 2009
Location: New Hampshire
Posts: 454
trying to diagnose a problem without the proper tools is hard. If you had a fuel pressure guage it would tell you right away wether or not you had fuel to the fuel rail. then you can go from there,
Now its a guessing game. shot in the dark make sure the fuel connections are tight. make sure the electrical connections are tight.
__________________
Keep calm, Chive On
Muddr1 is offline   Quote Quick Reply
Old 02-23-2012, 06:29 PM   #5
Newb
 
Join Date: Dec 2011
Posts: 6
Definately need a fuel pressure guage. It takes a considerable amount of pressure to feed the injectors. It may initially pressure up but the volume might not be there.
CMFR1 is offline   Quote Quick Reply
Old 02-24-2012, 10:32 AM   #6
Jeeper
 
Join Date: Jan 2011
Posts: 32
Ok ordered gauge will check pressure if pressure not enough what does that mean being that I just installed a new fuel pump thanks
BEBOP86 is offline   Quote Quick Reply
Old 03-01-2012, 12:53 PM   #7
Jeeper
 
Join Date: Jan 2011
Posts: 32
OK got the fuel pressure guage and she is reading around 48!! which seems to be OK- qucik question since she sat thru the summer fall- is it possible that it is old/bad gas??- although she was at 1/8th of a tank whens he died - i put 4 gallons fresh gas in and still nothing??- what do I look for next??
BEBOP86 is offline   Quote Quick Reply
Old 03-03-2012, 09:17 AM   #8
Jeeper
 
Join Date: Jan 2011
Posts: 32
- I rechecked spark and have plenty- I put a 12v test light into the injector wires and get power when cranking- SO if I have spark and plenty of fuel pressure why wont she start???- Please help--thanks
BEBOP86 is offline   Quote Quick Reply
Old 03-08-2012, 03:16 PM   #9
Jeeper
 
Join Date: Jan 2011
Posts: 32
update- checked injectors with a noid light and they pulse fine- what else do I check- again runs fine when gas in tb- good spark, inj. pulse, fuses ,good but just cranks????
BEBOP86 is offline   Quote Quick Reply
Old 03-11-2012, 07:10 AM   #10
Jeeper
 
Join Date: Jan 2011
Posts: 32
guys really need some help here thanks
BEBOP86 is offline   Quote Quick Reply
Old 03-19-2012, 05:20 PM   #11
Jeeper
 
Join Date: Jan 2011
Posts: 32
update- pulled fuel rail- Injectors are firing and squirting gas-BUT when I crank her over a few times the spark plugs remain dry???_ I would think they should be wet????- what would cause this problem??- thanks guys I am at my wits end with this!!!!
BEBOP86 is offline   Quote Quick Reply
Old 03-24-2012, 02:01 PM   #12
Jeeper
 
Join Date: Jan 2011
Posts: 32
Guys any idea why the plugs remain dry even though injectors fire fuel. This must be my problem. Thanks
BEBOP86 is offline   Quote Quick Reply
Old 03-24-2012, 03:14 PM   #13
Jeeper
 
Join Date: Jan 2010
Location: Houston, Tx
Posts: 629
It sounds to me like everything is working except you are not getting gas. I would take the pump back and try annother one. What brand pump did you get? If it was an Airtex try a better brand.

Shoe is online now   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tax return coming need help picking black wheels jmt27 TJ General Discussion Forum 28 03-08-2012 01:10 PM
2.5L or 4.0L please help Jatt-YJ YJ Tech Forum 145 03-07-2012 11:13 PM
Need help finding a thread. Deadening the soundbar Grateful Parrot TJ General Discussion Forum 14 02-23-2012 04:00 AM
seat belt help bama0915 Builders Corner 0 02-23-2012 12:35 AM
help in sw Portland stretch05 Oregon Jeep Forum 18 02-22-2012 11:51 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:04 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC