Help with my indicators please ! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-13-2011, 10:53 AM   #1
Newb
 
Lazsjs2000's Avatar
 
Join Date: Oct 2011
Posts: 14
Help with my indicators please !

Jeep wrangler 2003 4ltr sport

Ey all, I replaced my headlight assembly as my headlights stopped working however now my indicator lights have stopped working, I've tried the old light unit where the indicators did work but they don't work with that as well. I replaced the flasher unit that attaches to the back of the light assembly but no joy. I've tried the fuses, there ok, I've ran out of options so some suggestions would be very welcome.

When I replaced the light assembly unit I discovered it was not that at fault, it was the wire connector that attaches to the back that had become brittle and has melted slightly. So I broke it up and wired the connectors directly into the back of the new light assembly, in the correct order of course. But like I said I got the headlights to work but now the indicators don't, neither do the hazards, nothing there completely dead.

Like I said I checked the fuses at the back of the glove box and under the bonnet.

Can't think what else it could be......please help.

Many thanks in advance......Shaun

Lazsjs2000 is offline   Quote Quick Reply
Old 11-13-2011, 12:54 PM   #2
Jeeper
 
BigSahara's Avatar
 
Join Date: Feb 2009
Location: West Chester, PA
Posts: 155
Send a message via AIM to BigSahara
First check all of the connection points for the wires for each light assembly. There could be dirt or corrosion trapped inside. If they are fine check the ground points. If you have a Haynes manual it will make locating them a lot easier as it has complete diagrams for the entire lighting system.
__________________
'00 TJ Sahara 4.0L, 3.5" RE Superflex, 1'' Body Lift, 35" Mickey Thompson MTZ's
BigSahara is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fitting of Clear lens indicators on front and side of 2007 Rubicon Wilhemina07 Europe Jeep Forum 0 05-08-2011 10:28 AM
vehicle laws- from the texas department of public safety web site busemans Texas Jeep Forum 1 04-28-2011 05:26 PM
Horn Problem Tbear JK General Discussion Forum 3 03-17-2011 06:53 AM
MCE In-Cab winch remote installation erickpl Communications and Electronics 8 01-21-2011 05:11 PM
Dash Indicators Vaultzz YJ General Discussion Forum 7 09-30-2009 02:42 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:07 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC