HVAC problems - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-27-2012, 10:21 AM   #1
Newb
 
Join Date: Feb 2012
Posts: 2
HVAC problems

Ok, I've searched the forum and can't seem to find the exact problem I'm having with my HVAC controls. It started out with the blower motor only working on high, so I bought a new resistor and installed it and still had the same problem. So I let it go for a while, mostly because I haven't had the time, and now it doesn't work at all unless you push in on the blower knob. As soon as you let go it turns off. I pulled the controls out of the dash and there are no melted wires or anything that looks out of whack in there. So I'm assuming the switch is just bad and I need to replace it. Wanted to run it by you guys and see if there is something I'm missing or another known problem I haven't addressed. Thank you in advance!!!


Oh yeah, 06 TJ X, 99k miles....

Impact is offline   Quote
Old 02-27-2012, 01:01 PM   #2
Jeeper
 
Join Date: Oct 2011
Posts: 384
Quote:
Originally Posted by Impact View Post
Ok, I've searched the forum and can't seem to find the exact problem I'm having with my HVAC controls. It started out with the blower motor only working on high, so I bought a new resistor and installed it and still had the same problem. So I let it go for a while, mostly because I haven't had the time, and now it doesn't work at all unless you push in on the blower knob. As soon as you let go it turns off. I pulled the controls out of the dash and there are no melted wires or anything that looks out of whack in there. So I'm assuming the switch is just bad and I need to replace it. Wanted to run it by you guys and see if there is something I'm missing or another known problem I haven't addressed. Thank you in advance!!!


Oh yeah, 06 TJ X, 99k miles....
You are correct. 95% sure its your switch. Buy one from RockAuto. Really easy fix. If that doesn't solve your problem post up here.

__________________
1999 Jeep Wrangler SE 2.5 (Jasper Re-Built) - Dozer Orange
2005 Chrysler Crossfire SRT-6 3.2 (Supercharged) - Black
mrobinso is offline   Quote
Old 02-27-2012, 05:27 PM   #3
Supporting Member

WF Supporting Member
 
JimsJeep's Avatar
 
Join Date: Feb 2012
Location: Long Branch NJ
Posts: 1,816
I had the same problem and the fan speed switch was the fix as stated above.
JimsJeep is offline   Quote
Old 02-27-2012, 07:20 PM   #4
Newb
 
Join Date: Feb 2012
Posts: 2
Thanks guys! Ordering up the parts now.
Impact is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
has anyone with an 06 not have opda problems? bheiser TJ General Discussion Forum 123 05-07-2015 10:44 PM
Electrical problems jeepwrangler97 TJ Tech Forum 11 11-02-2013 07:25 PM
2000 tj electrical problems help bumblebeetj TJ General Discussion Forum 7 07-10-2012 06:51 AM
Brake boost problems fatcrack13 YJ Tech Forum 0 02-26-2012 08:24 PM
more huge problems LouieDelTorchio TJ General Discussion Forum 30 02-25-2012 04:06 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:32 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC