idle miss - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 08-27-2012, 08:19 PM   #1
Join Date: Aug 2012
Location: stuart,fl.
Posts: 8
idle miss

I have an 04 rubicon its awsome runs great idle it seems like the engine misses sometimes the rmp drops alittle .when the a/c is on the rpms are in normal range. on take off on highway and while driving the jeep is great ??? problem only on idle. any ideas I also used sprays and fuel cleaners??

lap12 is offline   Quote
Old 08-28-2012, 07:03 PM   #2
mrbat23's Avatar
Join Date: Jan 2012
Location: illinois
Posts: 314
I have the exact same thing going on . I thought i had it fixed, but its back. I did change my iac and tps and top 2 o2 sensors, but its the same ,and this is a brand new engine, so i'm thinking maybe coil pack or injecters. I will keep you posted.

mrbat23 is offline   Quote
Old 08-30-2012, 08:45 PM   #3
Join Date: Aug 2012
Location: stuart,fl.
Posts: 8
Ok thanks
lap12 is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:22 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC