Jeep Problem - Help Requested - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-31-2011, 09:35 PM   #1
Jeeper
 
holes's Avatar
 
Join Date: Jan 2010
Location: south east mn
Posts: 321
Jeep Problem - Help Requested

Well I've got a problem that has been around for the last week or so. Its a 98 4.0. Randomly my jeep will loose power and regain it very quickly causing my jeep to "hop" at low speeds, keep in mind its a manual. When it does this I generally pull off to the shoulder. My jeep idle will go down to about 400 rpm and get rough, sometimes it will die, sometimes it will regain to about 900-1000. The problem comes and goes but seems to have gotten worse. Only had the jeep for a week.

The check engine light was on for the 2nd o2 sensor, replaced it, cleared code, problem still persists. I'm afraid its a fuel pump, hopefully not.
Any thoughts? Thanks

holes is offline   Quote Quick Reply
Old 05-31-2011, 09:50 PM   #2
Jeeper
 
holes's Avatar
 
Join Date: Jan 2010
Location: south east mn
Posts: 321
When the Jeep does die, it always starts right back up. I know on previous jeeps they cranked for a little bit before starting up. This one always fires right up.

holes is offline   Quote Quick Reply
Old 05-31-2011, 10:16 PM   #3
Jeeper
 
03 sahara jeeper's Avatar
 
Join Date: Apr 2011
Posts: 499
My 03 was doing the same thing and I cleaned my pap. When it gets dirty it sends the wrong air mixture to the computer.
03 sahara jeeper is offline   Quote Quick Reply
Old 05-31-2011, 10:23 PM   #4
Jeeper
 
holes's Avatar
 
Join Date: Jan 2010
Location: south east mn
Posts: 321
Any idea how to remove and clean the PAP? What does PAP stand for. Thanks
holes is offline   Quote Quick Reply
Old 05-31-2011, 11:16 PM   #5
Jeeper
 
holes's Avatar
 
Join Date: Jan 2010
Location: south east mn
Posts: 321
Other than the o2 Sensor code, the Check Engine light is not on..
holes is offline   Quote Quick Reply
Old 05-31-2011, 11:40 PM   #6
Jeeper
 
03 sahara jeeper's Avatar
 
Join Date: Apr 2011
Posts: 499
Sorry I ment the map sensor. It is on the engine side of

your throttle body. Take the air intake tube off of your throttle body. Once you do that you will see a cavity ln it. The map has a brass nipple in that cavity. 2 screws hold it in place, remove them and clean the map. I used electronics cleaner. Did it 7 months ago still runs great
03 sahara jeeper is offline   Quote Quick Reply
Old 05-31-2011, 11:50 PM   #7
Jeeper
 
holes's Avatar
 
Join Date: Jan 2010
Location: south east mn
Posts: 321
Will have to try it tommorrow. Still looking for some input, all tips appreciated.
holes is offline   Quote Quick Reply
Old 06-01-2011, 11:13 AM   #8
Jeeper
 
holes's Avatar
 
Join Date: Jan 2010
Location: south east mn
Posts: 321
Cleaned the MAS up and didn't get a result. Not sure how exactly it is supposed to be cleaned but I tried.
holes is offline   Quote Quick Reply
Old 06-01-2011, 11:17 AM   #9
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 33,751
IAC? Tb dirty, butterfly valve sticking? There was a post earlier this week with a similar problem.
__________________
2007 Rubicon/Rock Krawler TR 2.5 coils/rear TB/Rancho 9000 31/32XL shocks/Teraflex monster TB/Synergy highsteer,tie rod, ball joints/Hankook MT 315-75-16 on Level 8 ZX's/MC front SB links/Rancho geo brackets & shocks/Fox ATS stabilizer/Adams front DS/Artec front armor w/ Currie upper bushings=Frankinjeep from hell.

Lifting your JK? Read this!!



Click HERE to become a WranglerForum Supporting Member!
kjeeper10 is offline   Quote Quick Reply
Old 06-02-2011, 11:53 AM   #10
Jeeper
 
holes's Avatar
 
Join Date: Jan 2010
Location: south east mn
Posts: 321
Turned out to be o2 sensor, bank one sensor one. Computer finally threw the right code.
holes is offline   Quote Quick Reply
Old 06-02-2011, 12:55 PM   #11
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 33,751
Sweet

__________________
2007 Rubicon/Rock Krawler TR 2.5 coils/rear TB/Rancho 9000 31/32XL shocks/Teraflex monster TB/Synergy highsteer,tie rod, ball joints/Hankook MT 315-75-16 on Level 8 ZX's/MC front SB links/Rancho geo brackets & shocks/Fox ATS stabilizer/Adams front DS/Artec front armor w/ Currie upper bushings=Frankinjeep from hell.

Lifting your JK? Read this!!



Click HERE to become a WranglerForum Supporting Member!
kjeeper10 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Jeep Beach in Daytona Beach FL. mnypitjeep General Jeep Discussion 6 11-09-2013 10:55 AM
2004 Rubicon Transmisson Problem King of Beers TJ Tech Forum 5 12-06-2012 03:13 PM
Runaway Off Topic Thread amerijeep Off-Topic 2723 01-30-2011 07:19 PM
Fellow Ohio Jeepers Help fick15 Ohio Jeep Forum 11 01-19-2010 10:56 PM
History of the Jeep. George T. General Jeep Discussion 8 02-04-2009 01:03 AM


» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:42 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC