Jeep Troubled - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 05-20-2012, 04:00 PM   #1
Join Date: May 2012
Posts: 2
Jeep Troubled

I recently purchased a 2000 Jeep Wrangler. Recently I took it to the mechanic because it cut off and wouldn't restart. He replaced the crank sensor and for a few days it seemed to be running fine. Then a few days later it began to idle and cut off at every stop light. My mechanic could not figure out the problem so I drove it straight to a Jeep dealership. On the way it lurched hard as I tried to get on the freeway. The Jeep dealership fixed some faulty wiring behind the steering column and the sensor that tells the Jeep it has hit 110mph and cuts it off. I picked it up today and despite initially running fine it began cutting off at lights (not with the strong idling) and still lurched on the freeway.

Any suggestions? I am taking it back Monday but thought it wouldn't hurt to come with suggestions.


uncmeshell is offline   Quote
Old 05-20-2012, 04:19 PM   #2
Join Date: May 2012
Posts: 1
Have you tried changing the fuel pump ... It may be bad I had a similar problem in the past .
Slimer83 is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:47 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC