KC Slimlite electrical problem...help! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-01-2011, 11:26 PM   #1
Newb
 
Join Date: Mar 2011
Location: Corpus Christi, TX
Posts: 2
KC Slimlite electrical problem...help!

Hey im new here, i tried asking some electrical savvy friends but they didn't really know what was causing my problem so i figured id join the forum. anyways, onto my problem...this past weekend i bought and installed the KC slimlite 130w long range lights and mounted them to my windshield. Everything worked fine and went smoothly the first day i did it but now for some reason my "ABS" light has come on on the dashboard and i hear occasional clicking noises similar to the ones you hear when youre using a turn signal, only at random speeds and at random times. Ive tried to duplicate the problem to figure out what causes it but so far ive got nothing. my friends think it may have something to do with the way i grounded the wire; i grounded the on/off switch near my gas pedal and grounded the relay near the battery. someone help me!

TexasSaharaTJ is offline   Quote
Old 03-02-2011, 12:16 AM   #2
Jeeper

WF Supporting Member
 
Join Date: Aug 2010
Posts: 7,505
May not be much help-I also installed the same kit my TJ. I grounded switch to the bottom dash panel by courtesy light.

I need to look to be absolutely sure but don't think I grounded the relay under the hood-except to ground on battery

jp2611 is offline   Quote
Old 03-02-2011, 12:48 AM   #3
Newb
 
Join Date: Mar 2011
Location: Corpus Christi, TX
Posts: 2
alright and you have no problems with it? i think this weekend ill try leaving it hooked up to the battery but driving around with it ungrounded at the switch to see if anything helps. not that it may be of help but just driving home a second ago, i noticed that the electrical clicking noise stops when you have your foot on the break if thats any help
TexasSaharaTJ is offline   Quote
Old 03-03-2011, 05:52 AM   #4
Jeeper

WF Supporting Member
 
Join Date: Aug 2010
Posts: 7,505
I installed mine in the spring almost 4 years ago-no problems-did hard wire at the lights-took out little plug and soldered the wire and used heat shrink.
jp2611 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
94 Electrical Problem Captainframe YJ Tech Forum 2 05-01-2010 02:42 PM
1998 TJ Electrical Problem - Check Gages/Volt Meter SVRangerDad TJ Tech Forum 3 08-21-2009 07:56 PM
Electrical Problem Help popatop YJ Tech Forum 2 09-07-2008 01:53 PM
Electrical and Stall Problem - Please Help... jwh21236 TJ Tech Forum 13 08-27-2008 05:07 AM
tj electrical problem mick laporta TJ Tech Forum 17 03-24-2007 03:50 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 12:38 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC