left front brake locking up? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-23-2006, 07:01 PM   #1
Jeeper
 
upinar's Avatar
 
Join Date: Sep 2006
Location: miami, Florida
Posts: 489
left front brake locking up?

About a week ago, my jeep started to pull hard to the left. like if it needs an alignment, but it doesnt. U can smell brake really strong and starts to smoke a little on the front left brake. But this only happens when i drive my jeep for a while, then it starts to pull to left harder and harder, to the point where i can let go of the wheel and my car will be in the next lane in about 30 feet. Pulls hard! I heard this can happen when mudd gets into ur callipars of something like this. I need help fast because i can drive like this anymore and i dont wanna buy parts that i dont need. thanks. And by the way, when it pulls to the left, i am just cruising with out the brake. thanks again

__________________
boosted inline 6 50. trim turbo
40" super swamper boggers
high pinion d44 front trussed
ford 8.8 rear axle conversion
se 9500 milemarker winch
locked front and rear
rough country steering stabilizers
clayton long arm
3inch body lift
2 coil spacer lift
eagle alloys 15's
on-board air system
kc daylighters 100w long range
rocker guards
rhino liner
upinar is offline   Quote Quick Reply
Old 12-23-2006, 08:52 PM   #2
Jeeper
 
amerijeep's Avatar
 
Join Date: Apr 2005
Location: Mississippi.
Posts: 3,951
Been in any mud lately? Happens to me all the time after riding in the muck. I have to pull the front wheels off to dig the stuff out of the brake assembly.

__________________
To all who serve, Thank You.
amerijeep is offline   Quote Quick Reply
Old 12-23-2006, 09:39 PM   #3
Jeeper
 
Mudweiser's Avatar
 
Join Date: May 2006
Location: Panama City Florida
Posts: 359
Send a message via AIM to Mudweiser Send a message via MSN to Mudweiser Send a message via Yahoo to Mudweiser
Mud will do it agreed. Also watch that hub bearing on that side. As the bearing gets worse it will push on the caliper harder..and start heating up more. Ide check your bearing too.
__________________
01 TJ. Dana 30/44 4:88's, 4.0 5 speed, 38.5x15 Boggers on 15x10 Streetlocks, CAI, B&M short throw, Neoprene Covers, 4" RC, 3" BL, too much to list and building. >..<
Mudweiser is offline   Quote Quick Reply
Old 12-23-2006, 09:53 PM   #4
Jeeper
 
Join Date: Nov 2006
Location: Chicago, IL
Posts: 8,286
Send a message via AIM to Triple88a Send a message via MSN to Triple88a Send a message via Yahoo to Triple88a Send a message via Skype™ to Triple88a
I used to have similar problem on my first car. It turned out the lower bolt that holds the brake caliper froze so the break pads would wear out only on one side and make the surface area bigger and eventually it just started pulling towards that brake. Check the movement on your brake calipers to make sure you dont have that problem.
Triple88a is offline   Quote Quick Reply
Old 12-24-2006, 10:01 PM   #5
Jeeper
 
upinar's Avatar
 
Join Date: Sep 2006
Location: miami, Florida
Posts: 489
will do thanks. but it hasnt done it since a few days ago right after i got stuck for the whole day. but ill still pull the wheel and check it out
__________________
boosted inline 6 50. trim turbo
40" super swamper boggers
high pinion d44 front trussed
ford 8.8 rear axle conversion
se 9500 milemarker winch
locked front and rear
rough country steering stabilizers
clayton long arm
3inch body lift
2 coil spacer lift
eagle alloys 15's
on-board air system
kc daylighters 100w long range
rocker guards
rhino liner
upinar is offline   Quote Quick Reply
Old 12-24-2006, 10:27 PM   #6
Jeeper
 
lost's Avatar
 
Join Date: Sep 2006
Location: ɹǝʌo dılɟ Miami,FL
Posts: 2,165
lol do you remember what I said the other day?
__________________
74'cj5: 360v8, d30, d44, 32"BFG a/t's
73'cj5: 258, d30, d44
00'tj:242
lost is offline   Quote Quick Reply
Old 12-26-2006, 09:49 PM   #7
Jeeper
 
revreed's Avatar
 
Join Date: Jul 2006
Posts: 20
I have known of 2 different vechicles that have had the problem that you describe. Both were front rotors and both turned out to be a bad flex brake line hose. The lining came loose and would let the pressure through but would not release it. It acted just like a check valve in the line on one rotor. One of them finally locked the rotor completely. Just a thought from my experience...
revreed is offline   Quote Quick Reply
Old 12-27-2006, 08:17 AM   #8
IITYWTMWYBMAB

WF Supporting Member
::WF Administrator::
 
4Jeepn's Avatar
 
Join Date: Apr 2005
Location: Florence, KY
Posts: 10,077
Images: 5
Either a bad caliper or you have mud in the caliper so it can't move towards the brake pad.. pull it clean it and see how it go's, If its still pulling and its clean replace the caliper.
__________________
79.96.85.00.01.97.00.97.93.97.95.94
CJ.XJ.CJ. TJ. TJ.ZJ. TJ.TJ. ZJ.ZJ.YJ. XJ
4Jeepn is offline   Quote Quick Reply
Old 12-27-2006, 07:30 PM   #9
Jeeper
 
robjeep's Avatar
 
Join Date: Apr 2006
Location: Roanoke, VA
Posts: 35
Mine did the same thing at 100K miles...I just went and got new calipers, Rotors and flushed the old crappy looking fluid out....Works perfect again!
Good luck...
Robert
__________________
http://i11.photobucket.com/albums/a1...b/DSC00011.jpg

New Jeep- 2007 Wrangler Rubicon JK, 3.8L, Auto
Black soft top, AWESOME BABY!

OLD JEEP-Red 2000 Wrangler Sport, 4.0L, 5 spd., Black Hardtop,and Soft top BFG 30 x 9.50 All Terrain T/A'S
robjeep is offline   Quote Quick Reply
Old 12-27-2006, 07:55 PM   #10
Jeeper
 
Join Date: Nov 2006
Location: Chicago, IL
Posts: 8,286
Send a message via AIM to Triple88a Send a message via MSN to Triple88a Send a message via Yahoo to Triple88a Send a message via Skype™ to Triple88a
Rob mine looks just like yours. Only difference is mine is only 40k

Triple88a is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Project Coyote_94YJ Off-Topic 264 06-09-2011 05:33 AM
Front Brakes Lock Keep Locking Up BigMike YJ Tech Forum 10 03-02-2011 02:11 PM
Left front noise sollucho YJ Tech Forum 2 11-12-2008 10:41 AM
left front u joint Jonny15 TJ Tech Forum 11 12-31-2007 02:22 PM
Front Brake Problem! OneBoltShort TJ Tech Forum 5 08-25-2006 06:47 AM



» Featured Product

All times are GMT -5. The time now is 03:06 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC