Low Idle When Braking - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-14-2011, 06:58 PM   #1
Jeeper
 
Join Date: Feb 2011
Location: Michigan
Posts: 433
Low Idle When Braking

Just recently I've been idling around 400 as low as 350 when braking down for a light and reversing. I did a complete tune up, spark plugs, wires, cap, rotor and a few other things TPS and IAC. What could be creating this low idle? Also no check engine light

2dmud is offline   Quote Quick Reply
Old 04-14-2011, 07:50 PM   #2
Jeeper
 
Black98's Avatar
 
Join Date: Nov 2010
Location: South East PA
Posts: 379
does the engine also sound like it is actually idling that low or does it just say it is on the tachometer. Also is this an auto or manual?

Black98 is offline   Quote Quick Reply
Old 04-14-2011, 08:11 PM   #3
Jeeper
 
Join Date: Dec 2010
Location: Philadelphia
Posts: 443
Send a message via AIM to mannyssj13
Now when you mean braking only when you brake or when the car comes to a stop. Mine does the same as well when I come to a stop at times when stalls on me when switching gears at times.. I have a auto by the way! I cleaned all my sensors and replace my idle control and still nothing!
mannyssj13 is offline   Quote Quick Reply
Old 04-14-2011, 08:12 PM   #4
Jeeper
 
Join Date: Feb 2011
Posts: 15
My 2006 is doing the same thing, not as low however. Doesn't sound low but shakes and stumbles. No check engine light. New TPS, Plugs, 02 Sensors, IAC is spotless, no vacum leaks as I can tell and I just replaced my crankshaft position sensor tonight. Same thing... and oddly enough it runs great down the road. Also, mine is an Auto 4.0
Routzahn is offline   Quote Quick Reply
Old 04-14-2011, 08:19 PM   #5
Upside-down Disorder
 
InvertChaos's Avatar
 
Join Date: Sep 2010
Location: NoVa
Posts: 7,879
Quote:
Originally Posted by Routzahn
My 2006 is doing the same thing, not as low however. Doesn't sound low but shakes and stumbles. No check engine light. New TPS, Plugs, 02 Sensors, IAC is spotless, no vacum leaks as I can tell and I just replaced my crankshaft position sensor tonight. Same thing... and oddly enough it runs great down the road. Also, mine is an Auto 4.0
Same here for my 04 4.0L 5 speed. It only happens occasionally and when it does happen I'm on a hill facing downward. I can feel the rpm drop and the tach reads at 250rpm or so as I brake around the turn. I just push in the clutch and blip the throttle and it returns to normal. No codes or engine lights here either. Like I said it doesn't happen very often though. Probably around 1-2 times a month.
__________________
|2004 Jeep TJ "Green Machine"|4.0L 5 speed Dana44|33x12.50x15 Goodyear Duratracs|2.5" RC coils + 1.25" body lift|OME NitroSport shocks|4.56 gears|Skid Row Engine Skid|BCC Sliders|Currie AntiRock|
InvertChaos is offline   Quote Quick Reply
Old 04-14-2011, 08:26 PM   #6
Jeeper
 
Join Date: Feb 2011
Posts: 15
Thats how mine was... few and far between. Now it's EVERY time I come to a stop. Thinking maybe the MAP sensor. It gets worse the longer I sit. If it's a quick stop, no biggie. If I put it in neutral/park to feather the gas to "help" it it hets worse when the RPM's drop. Very weird. Never has stalled and I occassionaly will test it if I run into a store quickly, leave the Jeep running and it's always running when I return. Last code I had was for a 02 so i changed the 2 upstream. Only thing that got better was MPG's
Routzahn is offline   Quote Quick Reply
Old 04-14-2011, 08:35 PM   #7
Jeeper
 
Black98's Avatar
 
Join Date: Nov 2010
Location: South East PA
Posts: 379
If its an auto and only happens when braking(when in drive) or reversing i suspect the torque converter or something in the transmission gripping too much w/o throttle application. I suggest a transmission fluid change and some kind of professional inspection if that does not help. If not the trans i suspect something with the computer or sensors that control the idle.
Black98 is offline   Quote Quick Reply
Old 04-14-2011, 08:37 PM   #8
Jeeper
 
Join Date: Feb 2011
Location: Michigan
Posts: 433
It's an auto 2.5 with about 13,000 miles on the new motor. Did a trans flush and inspection about 200 miles ago everything is good there.
2dmud is offline   Quote Quick Reply
Old 04-15-2011, 06:53 AM   #9
Newb
 
Join Date: Feb 2010
Location: Austria / Europe
Posts: 8
maybe you should remove and clean the "idle speed motor" - I use brake cleaner spray or gasoline.



Original Replacement Parts 4874373AB - Idle Speed Motor for a 98-06 Jeep® Wrangler TJ 6 Cylinder - Quadratec
TJERALD_AUSTRIA is offline   Quote Quick Reply
Old 04-15-2011, 07:26 AM   #10
Jeeper
 
h2obill's Avatar
 
Join Date: Dec 2010
Location: Lisle
Posts: 139
Mine idles rough and low at ~250rpm (04 4.0L auto) after its warmed up (10-15min) but only after coming to a complete stop. A tap on the gas will bring the idle back up and then it'll hold.

I threw a code once that was related to a gas cap / evap system leak so it could be the evap cannister. I tried cleaning the IAC but haven't touched the TPS (can't clean it but have to replace). The other strange thing is that if I have the HVAC on I have no low idle issues.

h2obill is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
4.2 carb problems stray YJ Tech Forum 18 12-27-2011 05:39 PM
Idle air control motor tbush95YJ YJ Tech Forum 0 12-22-2010 08:03 AM
rough idle dmwilson01 YJ Tech Forum 4 12-12-2010 10:16 PM
question for master mechanics about idle? autopc25 TJ Tech Forum 11 01-19-2010 05:52 PM
Erratic idle after start up for a minute when hot or cold? autopc25 TJ Tech Forum 2 01-09-2010 06:25 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:50 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC