Malfunction Indicator Lamp - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-20-2009, 05:50 PM   #1
Newb
 
Join Date: Nov 2009
Location: Vacherie
Posts: 10
Malfunction Indicator Lamp

When I left the house this evening I noticed the "malfunction Indicator Lamp", the engine symbol light in the instrument panel was on. Drove to work 22miles with no trouble. Is there anything I can check, or a fuse may be out?? Anyone else had this light come on?

rambone is offline   Quote Quick Reply
Old 12-20-2009, 06:35 PM   #2
I am JD & It's my Dream

WF Supporting Member
::WF Administrator::
 
JDsDream's Avatar
 
Join Date: Jan 2009
Location: The Peach State
Posts: 26,863
Images: 4
Mine comes on randomly in cold weather. First thing that you need to do is check the code. Put you key in the ignition and turn to on position (do not crank) them off repeat this twice rapidly and then back to the on position. The code should appear in your odometer window. After it gives the code it should read "done" So it is on, off, on, off, on quickly to get your code. There are several sites where you can check it and I believe there is one on this forum. I will see if I can find it and post a link in this thread.

__________________
The kind of woman that when my feet hit the floor each morning the devil says "Oh Crap, She's up!"

To All Of Our Forum Veterans and Active Service Members.
Our Debt To You Is Greater Than We Could Ever Repay.
Thank You

Become a Supporting Member!
JDsDream is offline   Quote Quick Reply
Old 12-20-2009, 07:00 PM   #3
Newb
 
Join Date: Nov 2009
Location: Vacherie
Posts: 10
OK, the code was "P 0442" Thanks for the info. Didn't know that about getting the code..
rambone is offline   Quote Quick Reply
Old 12-20-2009, 07:12 PM   #4
I am JD & It's my Dream

WF Supporting Member
::WF Administrator::
 
JDsDream's Avatar
 
Join Date: Jan 2009
Location: The Peach State
Posts: 26,863
Images: 4
Most Complete List For Jeep Check Engine Light Codes
This site has some good info.

P0442 Evaporative Emission Control System Leak Detected (small leak)

OBD II Generic Check Engine Light Codes
Welcome to our listing page for Generic Check Engine Light Codes. This is an all inclusive list intended to help you get not only a code definition, but also some information on what could cause these codes and what can be done to repair the related faults. Generic check engine light codes were set up so that there would be a more standardized system of defining trouble codes from all the vehicle manufacturers.
__________________
The kind of woman that when my feet hit the floor each morning the devil says "Oh Crap, She's up!"

To All Of Our Forum Veterans and Active Service Members.
Our Debt To You Is Greater Than We Could Ever Repay.
Thank You

Become a Supporting Member!
JDsDream is offline   Quote Quick Reply
Old 12-20-2009, 07:13 PM   #5
Newb
 
Join Date: Nov 2009
Location: Vacherie
Posts: 10
P0442 OBD-II Trouble Code

Evaporative Emission Control System Leak Detected (small leak)

What does that mean?This indicates a fuel vapor leak in the EVAP control system. It means a very small leak has been detected. In fact, the leak can be from a hole as small as 0.04" in diameter. The (EVAP) emission control system prevents the escape of fuel vapors from a vehicle's fuel system. Fuel vapors are routed by hoses to a charcoal canister for storage. Later, when the engine is running a purge control valve opens allowing intake vacuum to siphon the fuel vapors into the engine.

Just last week I put gas and left the gas cap on the back light!!! Gas cap gone, had to get one from auto-zone. I guess this is the problem, being an after market cap..
rambone is offline   Quote Quick Reply
Old 12-20-2009, 07:24 PM   #6
I am JD & It's my Dream

WF Supporting Member
::WF Administrator::
 
JDsDream's Avatar
 
Join Date: Jan 2009
Location: The Peach State
Posts: 26,863
Images: 4
Very well could be that simple. Grab a new cap from the stealership or order one online and give it a couple of days. The light should go out on it's own. I have a random code that shows up in cold weather for a slow response on one of the o2 sensors. It goes off after 3 to 4 start ups and has never given me a problem. These exhaust systems (thanks to the epa) are a pain in the ........ well you know where. Keep us posted as to what you find.
__________________
The kind of woman that when my feet hit the floor each morning the devil says "Oh Crap, She's up!"

To All Of Our Forum Veterans and Active Service Members.
Our Debt To You Is Greater Than We Could Ever Repay.
Thank You

Become a Supporting Member!
JDsDream is offline   Quote Quick Reply
Old 12-20-2009, 10:27 PM   #7
Show Me Your 8008135!

WF Supporting Member
 
s3nt3nc3d's Avatar
 
Join Date: Oct 2009
Location: Piqua, OH
Posts: 3,642
Send a message via AIM to s3nt3nc3d
I work for a Chrysler dealership and 2 days after buying my Jeep got the light...took it to them to have it checked out and it threw the same code. I asked if it was gas cap related and they said typically a leaking gas cap will show a large evap leak and not a small one. He said the usual cause of this problem is a cracked fuel line and in order for them to find it, they often have to run smoke through the fuel system and replace any cracked lines that show up. He cleared the code for me and it's been over a month and hasn't returned so we haven't messed with it since.

Anyway...something to think about...might be a cracked line.
__________________
"We don't build great brakes because we think you don't know how to drive, we build them for the guy on the road in front of you that doesn't." - Black Magic Brakes
s3nt3nc3d is offline   Quote Quick Reply
Old 08-22-2011, 07:10 PM   #8
Newb
 
Join Date: Aug 2011
Posts: 1
Ongoing MIL Problem

I have a 2004 Jeep Wrangler (65K miles). The light came on and I had it turn off at the inspection station. They told me it was "a very small evap leak" and to drive it a few days and come back. Returned after 3 days and it passed inspection. The MIL stayed off only a few more days (~ 1 week total).

Took it in to the dealer and they also said it was "a very small evap leak". They turned it off and I bought a new gas cap from the dealer (i.e. not an after market) and the light stayed off only a few days. I took it back again and they simply dismissed me turning it off agian and telling me to just drive it if it comes back on again. Of course, it did.

Just recently it was time to inspect it again. Repeated the whole process again. Turned the light off and drove a few days only this time the light came back on before it could pass inspection. They ran a "smoke test" but said they could not find a leak. So, they turned the light off again and this time, it did pass inspection two days later. This time, the light stayed off 4 weeks, but it back on again.

As suggested on this site, I turned the switch on and off 3 times and got the following code: P 0456. Any words of wisdom. My fear, the dealer will keep dismissing the problem until any warranty I might have remaining is gone.
tbw76rjw is offline   Quote Quick Reply
Old 06-09-2012, 09:01 AM   #9
Newb
 
edens2021's Avatar
 
Join Date: Apr 2012
Location: Marietta
Posts: 3
I had the same exact problem this past week. Come to find out a had a small hole in my vapor canister that is back behind the rear passenger tire. It took multiple trips to find the issue. When it was all said and done. All i did to fix it was get some silicone and filled the whole and problem was solved. So you might want to check there.
edens2021 is offline   Quote Quick Reply
Old 04-03-2014, 09:46 AM   #10
Jeeper
 
rgrwolf's Avatar
 
Join Date: Jul 2012
Posts: 21
I have a 2013 WUR, I got the MIL lite and conducted the code test. All I got was the word "done" on the odometer and no code. Any ideas what that means?

rgrwolf is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Has This Malfunction Happened To Anyone Else? RenoosRemoob JK Tech Forum 4 11-17-2013 10:50 PM
Jeep Wrangler Sport 03 Cluster Malfunction. Nano TJ Tech Forum 2 08-26-2009 08:44 PM
Throttle malfunction!!!! txag02 JK Tech Forum 18 08-23-2007 10:26 PM
First malfunction! jeeps&comics YJ Tech Forum 10 07-25-2007 07:19 AM


» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:24 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC