Many components stops working when using turn signal. - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-18-2011, 09:18 AM   #1
MKM
Newb
 
Join Date: Dec 2011
Posts: 5
Many components stops working when using turn signal.

Sometimes when I use my turn signal (at least) the following components stop working: turn sinal, wiper and radio. One time components stopt working even without using turn signal.
By turning jeep off and on again, all componets works again (crazy). I suspect it has to do with electricity; but what?

Can someone help me?
Thanks

MKM is offline   Quote
Old 12-18-2011, 10:24 AM   #2
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 36,654
That sounds like a ground connection is missing somewhere. Have you or someone else done any work on the Jeep where one of its ground wires might not have been reconnected properly?

__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote
Old 12-18-2011, 10:36 AM   #3
MKM
Newb
 
Join Date: Dec 2011
Posts: 5
No one worked on Jeep resently. Do you think the ground is in the turn signal circuit or nearby turn signal switch?
MKM is offline   Quote
Old 12-18-2011, 10:55 AM   #4
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 36,654
The possible weak/missing ground is more likely to be at or by one of the turn signal sockets. Check the bulbs in all the turn signal bulb sockets as well as the sockets too, bulbs and/or their sockets can cause strange problems too.

No guarantee your problem is caused by a faulty ground but as a guy who has done a lot of electrical/electronic troubleshooting over 50+ years, that is where I'd look first.
__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote
Old 12-18-2011, 12:28 PM   #5
MKM
Newb
 
Join Date: Dec 2011
Posts: 5
Could it be the switch in the key cylinder?
See: wipers,turn signals and radio not working - JeepForum.com
MKM is offline   Quote
Reply

Tags
electrical stops working , radio , turn signal , wipers

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signal Problem** Johntom TJ Tech Forum 2 11-16-2014 01:23 PM
Turn signal issue. kdukes4 TJ Tech Forum 8 03-12-2013 06:07 AM
? Multi-funcion fog light turn signal switch issue. Mudquest TJ General Discussion Forum 6 04-23-2012 08:11 AM
Erratic Turn Signal... Only When Driving with Lights Off??? I have SFF mrobinso TJ General Discussion Forum 28 12-12-2011 06:52 PM
Weird Turn Signal Issue toddyfresh TJ Tech Forum 0 09-03-2008 07:31 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:15 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC